Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Country Coach Owners Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-23-2013, 10:13 AM   #1
Member
 
2TALK42's Avatar
 
Alpine Owners Club
Join Date: Oct 2006
Location: West Monroe, LA
Posts: 60
Generator failure

Bought our 04 Affinity about three months ago, gen(Onan12.5, 2050hrs) quit two weeks ago. Would crank, but shut down after approximate10 seconds showing fault code 27. We replaced all four house batteries with Deka 8A8Ds, cleaned and tightened connections. Still same gen results. Took in to Onan shop, bearing had went out and bell housing destroyed, in short, $4750.00 for repair, we are very thankful we bought Good Sam extended service, our cost, $500! Mech said need to have bearing and such inspected...not sure how often.
__________________

__________________
Brian & Vicki

"Sharing th Gospel of Jesus Christ through ventriloquism and puppetry."
2TALK42 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-23-2013, 11:48 AM   #2
laj
Senior Member
 
Join Date: Nov 2010
Posts: 1,241
never heard of having to check bearings before. do you have previous maint. history on it.
__________________

__________________
laj is offline   Reply With Quote
Old 08-23-2013, 12:19 PM   #3
Member
 
2TALK42's Avatar
 
Alpine Owners Club
Join Date: Oct 2006
Location: West Monroe, LA
Posts: 60
No maint records....never heard of that either. We put over 8000 hrs on our last one, fixed one water leak and changed filters and fluids, 7.5 Onan.
__________________
Brian & Vicki

"Sharing th Gospel of Jesus Christ through ventriloquism and puppetry."
2TALK42 is offline   Reply With Quote
Old 08-23-2013, 03:02 PM   #4
Senior Member
 
Bigbluedog55's Avatar
 
Country Coach Owners Club
Join Date: Mar 2010
Location: Las Cruces NM
Posts: 177
Generator failure

I had about the same identical problem you had at 2000 hours on my 12.5KW QD.

Seemed simple at first. Onan manual says:
code 27
inverter lost PMA sensing
1 check wires between stator and inverter for loose or bad connection

2 ohm stator there are 3 pairs of wires check
t1-1 and t2-1
t2-1 and t3-1
t1-1 and t3-1
t2-2 and t1-2
t3-2 and t2-2
t1-2 and t2-3
.997-1.219 ohms at 70*
if winding open replace stator

3 replace control

Only 2 things can be bad. Control board or the stator.

EXCEPT, if the bearing has gone bad, and the shaft turns out of round, scores the stator wiring, and causes an intermittent sysmptom while trouble shooting.

Finally just pulled the housing apart, pulled the stator, which had a few scored windings, and a frozen end bearing.

Replaced stator, end bearing and was good to go.

Called ONAN and they recommend checking the bearing play every 2 - 3 years. No way to lube it, just have to replace it if crummy.

So, that makes 2 of us.

Glad you didn't have to pay a fortune for the repair.

Luck,

Bob
__________________
BigBlueDog
01 Country Coach Affinity 42 Enclave Toad
Lilly the Raschon and Lulu the Terrier.
Bigbluedog55 is offline   Reply With Quote
Old 08-23-2013, 04:39 PM   #5
Senior Member
 
Ford Super Duty Owner
Join Date: Apr 2012
Location: Austin, TX
Posts: 1,885
Quote:
Originally Posted by laj View Post
never heard of having to check bearings before. do you have previous maint. history on it.
Internal bearings? Yea, that makes no sense.
__________________
cb1000rider is offline   Reply With Quote
Old 08-24-2013, 04:08 PM   #6
Member
 
2TALK42's Avatar
 
Alpine Owners Club
Join Date: Oct 2006
Location: West Monroe, LA
Posts: 60
Replaced control board also...it was spiking 350 volts
__________________

__________________
Brian & Vicki

"Sharing th Gospel of Jesus Christ through ventriloquism and puppetry."
2TALK42 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:43 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.