Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Country Coach Owners Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-25-2009, 02:48 PM   #1
Junior Member
 
Join Date: Feb 2009
Location: everywhere and traveling
Posts: 19
help please-my horn quit working

I have an 07 Allure. The horn quit working. The fuse is good, the relay is good, the contacts in the steering wheel are good and there are no broken wires. Air is up to pressure. Any ideas? Maybe something in the smart wheel? Thanks for the help. Rich
__________________

__________________
mohotravelers is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-25-2009, 07:34 PM   #2
Moderator Emeritus


 
Monaco Owners Club
Excel Owners Club
Join Date: Nov 2006
Location: Hangin' with Sacs and the Pins
Posts: 9,413
Rich...You may want to check your horn solenoid. We had the same problem with our Diplomat. You can take it apart where you will find a plunger that is stuck. Clean it and that should solve your problem.

You will find a photo below. Our horn solenoid is in the outside front run bay on our Diplomat. It is the goldish looking thing attached to the left wall in the photo.

Good Luck!

__________________

__________________
MM
*MonacoMama with the 2 Pins & SacsTC Nearby*
*2007 Monaco Diplomat 40' SFT<>2006 Chevy VortecMax Toad<>2006 Buick Lucerne Leading the Way*
MonacoMama is offline   Reply With Quote
Old 08-26-2009, 04:08 AM   #3
Community Moderator
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 12,062
I concur the solenoid is probably stuck. You could have someone push the horn button and you can rap the solenoid with a hammer. If not used regularly they tend to stick.
__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Old 08-27-2009, 03:38 PM   #4
Junior Member
 
Join Date: Feb 2009
Location: everywhere and traveling
Posts: 19
Thank you both. Bad solenoid was the answer. Not stuck but a burnt out magnet. 65.00 OEM part at NAPA. I will have her fixed in nothing flat.
__________________
mohotravelers is offline   Reply With Quote
Old 11-22-2010, 10:48 PM   #5
Junior Member
 
Join Date: Nov 2010
Posts: 8
Post Can't find my horn

Monacomama,
You may the person who solves my problem. Recently purchased this coach kowing the horn did not work, thinking was not a big deal. Problem is I can't locate it. It may be the horn is missing, however I did find a red air line next to the generator that releases air when the steering wheel cap is depressed. Can you tell me where the horn is located?

PS: It's not on the roof.

Thanks
Randy
__________________
ibsnazy is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Remotes for Jenson Radio quit working LCD Winnebago Industries Owner's Forum 6 08-13-2009 03:59 PM
2004 Allegro 32BA Cruise Control quit working? k1hog Workhorse and Chevrolet Chassis Motorhome Forum 7 07-31-2009 12:03 PM
Dash AC quit working while parked BEBOP Workhorse and Chevrolet Chassis Motorhome Forum 7 04-10-2009 09:54 PM
Help IE quit working MikeCoke Technology: Internet, TV, Satellite, Cell Phones, etc. 6 03-29-2009 01:36 PM
Horn (non air) not working on W24 Nonno Workhorse and Chevrolet Chassis Motorhome Forum 13 08-26-2007 04:30 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:29 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.