Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Country Coach Owners Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-13-2015, 10:41 AM   #1
Senior Member
 
Smitty77's Avatar
 
Join Date: Aug 2010
Location: Over the next hill, around the next curve...
Posts: 3,309
Hydro Hot- Diesel not starting back up

We have a 2004 Allure, with a single electric element Hydro Hot (Can't recall the model number, but can get it again if it helps.).

For the last few months, the Diesel function will start up, and run well and heat the water as it should. Sometimes, like during a shower, the Diesel heating function will not kick back on as the hot water needs replenishing. At those times, the green light on the switch above the door, goes off. I believe Roger Berke indicated this was a problem with one of the sensors, or perhaps the board itself.

As it is happening more frequently, and we're planning to travel for another few months, can anyone recommend any areas I should check and possibly clean some connections? Or, other items to look at?

TIA,
Smitty
__________________

__________________
Roo II is our 04 Country Coach Allure 40'
OnDRoad for The JRNY! Enjoy life...
Smitty77 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-13-2015, 10:44 AM   #2
Senior Member
 
Spk64's Avatar


 
Join Date: Apr 2014
Location: Floyds Knobs, In.
Posts: 1,762
Is the HydroHot being serviced annually?
Fuel Filter
New Nozzle with gap adjustment
__________________

__________________
Steve
2002 Newmar Mountain Aire 4095
Spk64 is offline   Reply With Quote
Old 07-13-2015, 11:35 AM   #3
Senior Member
 
Smitty77's Avatar
 
Join Date: Aug 2010
Location: Over the next hill, around the next curve...
Posts: 3,309
Quote:
Originally Posted by Spk64 View Post
Is the HydroHot being serviced annually?
Fuel Filter
New Nozzle with gap adjustment

Yes, and come to think of it, it was after the last service that this started up... Very few times at first, maybe once every 2-3 days. We did a 2 1/2 month trip without much problems or bother from this... Then I just forgot about it - until we headed out this time. Now on the road for a month, and I'd say it is now not restarting up, about 40% of the time.

I did check all levels, opened the cap to see if needed burping, etc.

Smitty
__________________
Roo II is our 04 Country Coach Allure 40'
OnDRoad for The JRNY! Enjoy life...
Smitty77 is offline   Reply With Quote
Old 07-13-2015, 11:39 AM   #4
Senior Member
 
Spk64's Avatar


 
Join Date: Apr 2014
Location: Floyds Knobs, In.
Posts: 1,762
Having nozzle and electrode gap checked might be a good place to start.
Also if the shower starts out hot then cools then goes hot for remainder of shower. Might have an issue with the stir pump.
__________________
Steve
2002 Newmar Mountain Aire 4095
Spk64 is offline   Reply With Quote
Old 07-13-2015, 11:47 AM   #5
Senior Member
 
Smitty77's Avatar
 
Join Date: Aug 2010
Location: Over the next hill, around the next curve...
Posts: 3,309
Quote:
Originally Posted by Spk64 View Post
Having nozzle and electrode gap checked might be a good place to start.
Also if the shower starts out hot then cools then goes hot for remainder of shower. Might have an issue with the stir pump.
Thanks - I thought I kept an email from Roger back in our Feb travels, where he said the light going on the switch indicated ...????

I'll check the suggested items.

And it just uses up all of he hot water, without the diesel firing back up.

Appreciate the ideas!
Smitth
__________________
Roo II is our 04 Country Coach Allure 40'
OnDRoad for The JRNY! Enjoy life...
Smitty77 is offline   Reply With Quote
Old 07-15-2015, 04:40 PM   #6
Senior Member
 
Join Date: Feb 2011
Posts: 229
Hi we also have a 2004 Allure, we started having problems with the Hydro Hot about a year ago, we ended up having to replace the board. Good luck.
__________________

__________________
Larry Young is offline   Reply With Quote
Reply

Tags
diesel



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
hydro hot not working dconley RV Systems & Appliances 4 06-13-2015 02:05 PM
Onan 10kw diesel generator not starting redbaron73 RV Systems & Appliances 16 06-01-2015 11:00 PM
Diesel dies after starting bgholson Cummins Engines 5 05-19-2015 12:58 PM
Hydro Hot Problem cavedvr RV Systems & Appliances 3 01-24-2014 10:04 AM
Hydro Hot blowing white smoke Jimcounts iRV2.com General Discussion 1 10-29-2013 03:54 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:52 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.