RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Country Coach Owners Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 01-13-2020, 08:05 PM   #1
Member
 
BigALBigRig's Avatar
 
Country Coach Owners Club
Join Date: Jan 2018
Location: Scottsdale, Arizona
Posts: 33
No house power

Just got my Country Coach Magna back after a 1 1/2 year legal battle relating to faulty maintenance work. The case is over and I settled for an amount that barely covered my costs.

I have now discovered that I have no house power to the motorhome whatsoever. I have purchased ALL new batteries but I still have no power to many of the systems. Here are the symptoms

1. Shore power is definitely delivering power to the inverter
2. I rebooted the inverter (Xantrex Freedom 3012)
3. The inverter fan starts and shuts off as per the manual
4. The inverter is "Enabled" and the light remains on.
5. Motorhome has no interior lights
6. Generator not getting ANY power to start
7. There is no power to the HMS system
8. There is no power to the radio/video cam

If anyone has an answer to this riddle I would greatly appreciate it. I've already spent 2 days crawling around the motorhome.

Thanks in Advance!!
Big AL
__________________

__________________
2005 Country Coach Magna 630 "Monet"
Caterpillar 525 C-13
Dynomax Chassis
BigALBigRig is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-13-2020, 08:26 PM   #2
Senior Member
 
R.Wold's Avatar


 
Newmar Owners Club
Ford Super Duty Owner
Join Date: Jan 2019
Location: Rosemary Farm
Posts: 828
Quote:
Originally Posted by BigALBigRig View Post
Just got my Country Coach Magna back after a 1 1/2 year legal battle relating to faulty maintenance work. The case is over and I settled for an amount that barely covered my costs.

I have now discovered that I have no house power to the motorhome whatsoever. I have purchased ALL new batteries but I still have no power to many of the systems. Here are the symptoms

1. Shore power is definitely delivering power to the inverter
2. I rebooted the inverter (Xantrex Freedom 3012)
3. The inverter fan starts and shuts off as per the manual
4. The inverter is "Enabled" and the light remains on.
5. Motorhome has no interior lights
6. Generator not getting ANY power to start
7. There is no power to the HMS system
8. There is no power to the radio/video cam

If anyone has an answer to this riddle I would greatly appreciate it. I've already spent 2 days crawling around the motorhome.

Thanks in Advance!!
Big AL
Sounds like you converter is either not working or disconnected/unplugged. Everything you are missing is 12v. See if the 110 outlets and appliances are working.
__________________

__________________
2010 Bay Star 2901: Victron 24/3000 inverter/charger, 1575w residential solar, and a whole lot of elec and plumbing mods. In the process of upgrading...
R.Wold is online now   Reply With Quote
Old 01-13-2020, 08:38 PM   #3
Community Moderator
 
CountryFit's Avatar


 
Join Date: Sep 2011
Location: Between the Oceans
Posts: 6,078
Blog Entries: 4
Check the house battery master breaker.
Also check if your house battery negative terminal is grounded (connected to the chassis).
__________________
Steven & Polly
2000 Country Coach Intrigue 40'
2014 Ford C-Max Energi
CountryFit is offline   Reply With Quote
Old 01-13-2020, 08:49 PM   #4
Senior Member
 
IASM's Avatar
 
Join Date: Nov 2013
Posts: 728
i think i would start with the voltage at the batteries then move upstream
IASM is offline   Reply With Quote
Old 01-13-2020, 08:54 PM   #5
Senior Member
 
deandec's Avatar
 
Country Coach Owners Club
Join Date: Jan 2006
Location: Northern California
Posts: 4,266
My rig has two 300A Class T fuses in the wiring between the inverter and the house batteries.

If one of the fuses blows, I get your symptoms.

Last time it occurred after being in a shop for a couple of weeks.....
__________________
Dean
1995 38' CC Magna #5280
C8.3L 300hp Cummins, 31,000lbs
deandec is offline   Reply With Quote
Old 01-13-2020, 08:58 PM   #6
Senior Member
 
Join Date: Jul 2014
Posts: 20,151
Battery disconnect switch off, or fuse/breaker tripped supplying it.

As mentioned, start at the battery and follow the power. Don't follow the inverter/charger cable, that doesn't supply 12 volts to the house.
There will be a second pos. cable going to a 60 to 120 amp fuse or breaker and then on to the house disconnect solenoid. That solenoid is controlled by the Use/Store switch.
twinboat is online now   Reply With Quote
Old 01-13-2020, 11:26 PM   #7
Senior Member
 
Join Date: Nov 2015
Posts: 322
Try some 110 appliance like your washing machine that does not go through the inverter. On the 12 volt side check the voltage at your house batteries.

Rich 2002 Magna
birdhunter is offline   Reply With Quote
Old 01-14-2020, 08:22 AM   #8
Senior Member
 
BrianGlenn's Avatar
 
Country Coach Owners Club
Join Date: Apr 2015
Location: Alberta
Posts: 1,233
No house power

New batteries - check and double check battery wiring and confirm +/- posts. As well tightness of post connections. Follow ground to chassis connection and ensure it is clean/tight as well.

Gen/dash radio power take off upstream of my salesman solenoid, if I remember correctly. 2007 Allure.
__________________
Towr: 2007 Country Coach Allure 470 - 37 Sunset Bay Cummins 400 ISL
Toad: 2016 F150 King Ranch - 3.5L EcoBoost 4x4 Supercrew (curb weight 4,775 lbs)
Toad: SOLD 2007 Jeep Grand Cherokee (yes, it has a Hemi) (curb weight 4,720 lbs)
BrianGlenn is offline   Reply With Quote
Old 01-14-2020, 09:34 AM   #9
Senior Member
 
KanzKran's Avatar
 
Join Date: Sep 2018
Posts: 714
By any chance, is the "AC In" light burning steady, or is it blinking? Blinking is supposed to indicate that it's charging the battery, and solid indicates only AC pass-thru.

I have the same inverter/converter/charger (Freedom SW3012), and am still learning its quirks. There is the ability to connect via wifi to see what it's doing, but I haven't yet got that far. The wifi router is there and wired (by Coachmen), but I need some warm weather and free time to go out there and mess with it.

Perhaps yours has that capability too?
__________________
Tom & Jeri
2018 Coachmen Galleria 24T Li3
KanzKran is online now   Reply With Quote
Old 01-14-2020, 11:24 AM   #10
Member
 
BigALBigRig's Avatar
 
Country Coach Owners Club
Join Date: Jan 2018
Location: Scottsdale, Arizona
Posts: 33
Wow, this forum truly is the best resource for information. Those were all excellent suggestions.

I've made checklist based on your suggestions. I am heading out there this afternoon and I'll report back what the problem was. (I'm leaning toward a setting on the inverter).

THANK YOU!!!!
__________________
2005 Country Coach Magna 630 "Monet"
Caterpillar 525 C-13
Dynomax Chassis
BigALBigRig is offline   Reply With Quote
Old 01-14-2020, 05:49 PM   #11
Member
 
BigALBigRig's Avatar
 
Country Coach Owners Club
Join Date: Jan 2018
Location: Scottsdale, Arizona
Posts: 33
Ok, the outlets are all working when shore power is plugged in. The batteries are all fully charged (new). ALL 12 Volt power is not working...i.e. no interior lights, power drapes, etc.

There is a 400 amp fuse in the inverter bay that looks fine...I think.

House battery IS grounded..definitely.

Washing machine IS working...definitely.

Don't know where the "AC IN" light is as per KanzKran.

House breaker is also good...I think..if you mean the breakers in the house battery compartment.
__________________
2005 Country Coach Magna 630 "Monet"
Caterpillar 525 C-13
Dynomax Chassis
BigALBigRig is offline   Reply With Quote
Old 01-14-2020, 06:11 PM   #12
Senior Member
 
deandec's Avatar
 
Country Coach Owners Club
Join Date: Jan 2006
Location: Northern California
Posts: 4,266
Quote:
Originally Posted by BigALBigRig View Post
Ok, the outlets are all working when shore power is plugged in. The batteries are all fully charged (new). ALL 12 Volt power is not working...i.e. no interior lights, power drapes, etc.

There is a 400 amp fuse in the inverter bay that looks fine...I think.

House battery IS grounded..definitely.

Washing machine IS working...definitely.

Don't know where the "AC IN" light is as per KanzKran.

House breaker is also good...I think..if you mean the breakers in the house battery compartment.


The large Class T fuses I have lost did not give any visual clue.

Put a meter on each side of the fuse to see if the 12v is passing through.

Or you could bypass the fuse with a 16ga wire to see if things light up briefly.
__________________
Dean
1995 38' CC Magna #5280
C8.3L 300hp Cummins, 31,000lbs
deandec is offline   Reply With Quote
Old 01-14-2020, 06:18 PM   #13
Senior Member
 
KanzKran's Avatar
 
Join Date: Sep 2018
Posts: 714
Quote:
Originally Posted by BigALBigRig View Post
Don't know where the "AC IN" light is as per KanzKran.
Page 12 of 122 in the manual. See Item 4.

As I said, I’m still learning about my own system, and this may not be the same unit as yours, but it’s the only 3000W (Freedom SW 3012) unit they show.
Attached Thumbnails
Click image for larger version

Name:	9F9181DF-D50B-4E1D-80C4-C260BF8D0566.jpg
Views:	6
Size:	240.8 KB
ID:	272268  
__________________
Tom & Jeri
2018 Coachmen Galleria 24T Li3
KanzKran is online now   Reply With Quote
Old 01-14-2020, 07:00 PM   #14
Community Moderator
 
CountryFit's Avatar


 
Join Date: Sep 2011
Location: Between the Oceans
Posts: 6,078
Blog Entries: 4
Quote:
Originally Posted by twinboat View Post
Battery disconnect switch off, or fuse/breaker tripped supplying it.

As mentioned, start at the battery and follow the power. Don't follow the inverter/charger cable, that doesn't supply 12 volts to the house.
There will be a second pos. cable going to a 60 to 120 amp fuse or breaker and then on to the house disconnect solenoid. That solenoid is controlled by the Use/Store switch.
^^ follow this.
__________________

__________________
Steven & Polly
2000 Country Coach Intrigue 40'
2014 Ford C-Max Energi
CountryFit is offline   Reply With Quote
Reply

Tags
power



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
House Fuse Panel? - Radio not working on House Power Twin Gulf Stream Owner's Forum 1 09-17-2018 04:06 PM
No Power from house batteries or shore power deepfish Winnebago Industries Owner's Forum 2 07-25-2014 01:44 PM
12 volt power relay for house power panga22 Monaco Owner's Forum 5 08-12-2013 07:22 AM
No power in house when off shore power. Batteries good. wbezemek Winnebago Industries Owner's Forum 13 01-04-2012 08:16 PM
RV genset to power house during power outage McDanie1 Newmar Owner's Forum 8 07-16-2009 09:54 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:54 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×