Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Country Coach Owners Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-03-2013, 09:35 PM   #1
Moderator Emeritus
 
smlranger's Avatar


 
Country Coach Owners Club
Freightliner Owners Club
Join Date: Sep 2004
Location: Glen Allen, VA
Posts: 7,273
Blog Entries: 1
Odd Odometer Behavior

During the first month of owning this coach, the digital odometer seemed to lose its mind. It would not display mileage, only a garbled mix of characters. That lasted for about 2 hours of driving and resolved on its own.

Has been fine for 5 months until today. Started the coach after sitting for a week in Myrtle Beach and got the scrambled display. Tried using the 'trip' rocker switch to jog it into action but nothing. Drove for about 200 miles, stopped at a rest area, shut down engine. When we restarted, the display blinked a couple of times and started working fine for rest of the trip.

Has anyone else seen this?
__________________

__________________
'07 Country Coach Allure 470 Siskiyou Summit #31578, Cummins ISL 425; 2014 Ford F150 toad; Air Force One Toad Brake.
Glen Allen, VA; Smith Mountain Lake, VA.
smlranger is online now   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-03-2013, 10:55 PM   #2
Senior Member
 
VanDiemen23's Avatar
 
Join Date: Oct 2010
Posts: 779
digital displays that glitch are usually due to the connectors on the ribbon cable between the display and the driver board.

It's delicate work, but you can disconnect and re-connect the parts a few times and that will clean off any corrosion and re-seat the connections.
__________________
VanDiemen23 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:14 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.