Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Country Coach Owners Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 11-26-2007, 10:44 AM   #1
Senior Member
 
Join Date: Jul 2005
Location: Pahrump, NV
Posts: 329
We have the Xantrex RC7/GS with an RV2012 inverter.

Going down the road a few weeks ago when we went to turn off the gen @ the remote panel the panel was dead -- no LCD display, no LED's.

It looks like the RV2012 is OK based upon the fact that we cna tell by its LED that it is charging correctly and no error flashes.

I'll be back to the rig in another week or so and will try a cable direcly between the inverter and the remote panel itself to see if its a connector or cable problem.

Has anyone else ever had this happen to them and what was the outcome?

FYI -- I spoke with Xantrex who were less than helpful telling me that these never fail (of course they hesitated when I pointed out that my RV2012 had been replaced a few months ago due to its failing).

CC has been helpful in letting us know where to look et al but I think it would be great iof anyone else who has had this problem could provide any insight.
__________________

__________________
2011 Airstream Classic Limited
2011 GMC Sierra 2500HD Duramax/Allison
Techie is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-26-2007, 10:44 AM   #2
Senior Member
 
Join Date: Jul 2005
Location: Pahrump, NV
Posts: 329
We have the Xantrex RC7/GS with an RV2012 inverter.

Going down the road a few weeks ago when we went to turn off the gen @ the remote panel the panel was dead -- no LCD display, no LED's.

It looks like the RV2012 is OK based upon the fact that we cna tell by its LED that it is charging correctly and no error flashes.

I'll be back to the rig in another week or so and will try a cable direcly between the inverter and the remote panel itself to see if its a connector or cable problem.

Has anyone else ever had this happen to them and what was the outcome?

FYI -- I spoke with Xantrex who were less than helpful telling me that these never fail (of course they hesitated when I pointed out that my RV2012 had been replaced a few months ago due to its failing).

CC has been helpful in letting us know where to look et al but I think it would be great iof anyone else who has had this problem could provide any insight.
__________________

__________________
2011 Airstream Classic Limited
2011 GMC Sierra 2500HD Duramax/Allison
Techie is offline   Reply With Quote
Old 11-27-2007, 08:58 PM   #3
Registered User
 
Join Date: Aug 2007
Location: Chambersburg, PA
Posts: 246
hers a link that may help. http://www.xantrex.com/web/id/425/docserve.asp
__________________
RVRONINPA is offline   Reply With Quote
Old 11-28-2007, 07:43 AM   #4
Senior Member
 
Join Date: Jul 2005
Location: Pahrump, NV
Posts: 329
We checked the site out before (and rechecked your link) it;s basically the manual and we already had that; when we talked to Xantrext they really weren't of (any) much help either.

In about 2 weeks I'll be @ the rig and will be checking the cable itself and I'll let everyone know what the cause was (if I find it).
__________________
2011 Airstream Classic Limited
2011 GMC Sierra 2500HD Duramax/Allison
Techie is offline   Reply With Quote
Old 11-28-2007, 07:53 AM   #5
Registered User
 
Join Date: Aug 2007
Location: Chambersburg, PA
Posts: 246
I'll keep checking for possible answers but it does kind of sound like you lostpower to the monitor so maybe wire off,etc. lets hope its an easy fix for you. Ron
__________________
RVRONINPA is offline   Reply With Quote
Old 12-10-2007, 07:53 PM   #6
Senior Member
 
Join Date: Jul 2005
Location: Pahrump, NV
Posts: 329
Quick update -- just tried the panel directly to the inveter with a short data cable and no joy -- th epanel does not come on -- no LED and no LCD display...so, now I need to find out if the problem is with the inverter or the panel.

Any ideas would be aprpeciated.
__________________
2011 Airstream Classic Limited
2011 GMC Sierra 2500HD Duramax/Allison
Techie is offline   Reply With Quote
Old 12-14-2007, 04:22 PM   #7
Senior Member
 
Join Date: Jul 2005
Location: Pahrump, NV
Posts: 329
The problem turned out to be the remote panel -- you know, the one that Xantrex saya never fails
CC sent us a new planel and it came up and ran fine as soon as we plugged it in.

Now I just need to find out if there is any point in holding onto the old one or if anyone knows who can repair these "never fail" panels!
__________________

__________________
2011 Airstream Classic Limited
2011 GMC Sierra 2500HD Duramax/Allison
Techie is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
RS2000 Remote Panel Blank Wil Rathke Alpine Coach Owner's Forum 7 11-04-2008 01:49 PM
gen started by itself/won't shut down from remote panel Techie Country Coach Owners Forum 1 09-10-2008 02:52 PM
Inverter -- Remote Panel not working journey15 Winnebago Industries Owner's Forum 5 09-18-2006 03:39 PM
Generator Remote Switch Stopped Working Jack Barbic MH-General Discussions & Problems 2 03-05-2006 04:14 PM
RS2000 Remote Panel Blank RV Systems & Appliances 7 12-31-1969 07:00 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:42 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.