Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Country Coach Owners Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-04-2015, 06:23 AM   #15
Moderator Emeritus
 
smlranger's Avatar


 
Country Coach Owners Club
Freightliner Owners Club
Join Date: Sep 2004
Location: Glen Allen, VA
Posts: 7,266
Blog Entries: 1
UPDATE: Well, the 'check engine' light is back along with engine de-rate and the 'low fuel pressure' error code on the Silverleaf. This time I noticed that while this fault occurred, my electronic odometer got goofy..... it just displays strange characters. I have had this same display intermittently several times with no check engine light but now I wonder if these two issues are somehow related.

If I take it back to Cummins, it will be working fine of course .
__________________

__________________
'07 Country Coach Allure 470 Siskiyou Summit #31578, Cummins ISL 425; 2014 Ford F150 toad; Air Force One Toad Brake.
Glen Allen, VA; Smith Mountain Lake, VA.
smlranger is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-05-2015, 10:13 AM   #16
Senior Member
 
Join Date: Feb 2010
Posts: 4,493
Goofy computer display that is intermittent points toward power supply.

Did it run different while error displayed?

Look for loose or odd connections either in connectors or grounds.

If engine was fine but silverleaf stated otherwise then look at dash area for poor ground buss connections.

Get an auto headlamp for test load and test ground buss to battery hot to see if it is good.
__________________

__________________
Tony & Lori
1989 Country Coach Savannah SE
TQ60 is offline   Reply With Quote
Old 03-05-2015, 11:38 AM   #17
Moderator Emeritus
 
smlranger's Avatar


 
Country Coach Owners Club
Freightliner Owners Club
Join Date: Sep 2004
Location: Glen Allen, VA
Posts: 7,266
Blog Entries: 1
Quote:
Originally Posted by TQ60 View Post
Goofy computer display that is intermittent points toward power supply.

Did it run different while error displayed?

Look for loose or odd connections either in connectors or grounds.

If engine was fine but silverleaf stated otherwise then look at dash area for poor ground buss connections.

Get an auto headlamp for test load and test ground buss to battery hot to see if it is good.
Engine was not fine.... when you get a 157 (559) error code the engine ECM thinks there is some problem with fuel delivery so you get a 'check engine' light and a significant loss of power. Based on the VMS history, this error code has occurred many times but only recently did I notice the goofy odometer display occur at the same time. I suspect these are two unrelated issues but was looking for any and all possibilities.
__________________

__________________
'07 Country Coach Allure 470 Siskiyou Summit #31578, Cummins ISL 425; 2014 Ford F150 toad; Air Force One Toad Brake.
Glen Allen, VA; Smith Mountain Lake, VA.
smlranger is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine shut down while driving kkquilter Caterpillar Engine Forum 28 03-08-2015 09:16 AM
Stop Engine Warning light Maxout Country Coach Owners Forum 13 12-31-2014 04:09 PM
Engine died after 15 seconds. ladagobago Cummins Engines 5 11-01-2014 08:58 PM
Engine Won't Start! Black Smoke Monaco Owner's Forum 9 10-19-2014 05:47 PM
50,000 Mile Report on the Brazel's UltraPower Engine Mod Duner Workhorse and Chevrolet Chassis Motorhome Forum 6 07-29-2013 02:30 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:46 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.