Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Country Coach Owners Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 12-27-2014, 07:09 AM   #1
Moderator Emeritus
 
smlranger's Avatar


 
Country Coach Owners Club
Freightliner Owners Club
Join Date: Sep 2004
Location: Glen Allen, VA
Posts: 7,259
Blog Entries: 1
Silverleaf, engine fault codes

Question for any of my fellow CC owners with a Silverleaf system and a Cummins engine....

I had a check engine light yesterday along with the Silverleaf displaying a fault code '157 1 1' with 'low fuel pressure' on the display. The engine had little pulling power during this episode. I pulled over, shut down the engine and after about 2 minutes, restarted the engine. Check engine light stayed off and coach ran fine until I got home 15 minutes later.

My question is related to the code displayed on the Silverleaf. If I go to the Cummins Quick Serve website and enter my engine serial number, it tells me that code 157 is not a valid code for my engine. Any of you with a similar set up have any ideas?
__________________

__________________
'07 Country Coach Allure 470 Siskiyou Summit #31578, Cummins ISL 425; 2014 Ford F150 toad; Air Force One Toad Brake.
Glen Allen, VA; Smith Mountain Lake, VA.
smlranger is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-27-2014, 10:26 AM   #2
Senior Member
 
Smitty77's Avatar
 
Join Date: Aug 2010
Location: Over the next hill, around the next curve...
Posts: 3,302
Maybe a call to Silverleaf would help on the puzzle of a code that is not relevant for your engine year/model?

Best,
Smitty
__________________

__________________
Roo II is our 04 Country Coach Allure 40'
OnDRoad for The JRNY! Enjoy life...
Smitty77 is offline   Reply With Quote
Old 12-29-2014, 08:04 AM   #3
Member
 
Join Date: Dec 2010
Location: Crestview, FL
Posts: 45
Silverleaf shows a different error code then what Cummins uses, I had called them and they explained this to me. Cummins takes this industry standard code and changes it to their own codes. Here is a link to a list of codes that the Silverleaf is showing.

http://www.heavydutypowertrain.com/md200codes.pdf

I hope this helps.
__________________
Bob & Terry Stockholm - Xenia, OH
2000 Country Coach Intrigue #11075
stkhlm is offline   Reply With Quote
Old 12-29-2014, 04:59 PM   #4
Moderator Emeritus
 
smlranger's Avatar


 
Country Coach Owners Club
Freightliner Owners Club
Join Date: Sep 2004
Location: Glen Allen, VA
Posts: 7,259
Blog Entries: 1
Quote:
Originally Posted by stkhlm View Post
Silverleaf shows a different error code then what Cummins uses, I had called them and they explained this to me. Cummins takes this industry standard code and changes it to their own codes. Here is a link to a list of codes that the Silverleaf is showing.

http://www.heavydutypowertrain.com/md200codes.pdf

I hope this helps.
Thanks for the tip. I called Silverleaf and the 157 code is the same as Cummins code 559 which has to do with fuel rail pressure.
__________________
'07 Country Coach Allure 470 Siskiyou Summit #31578, Cummins ISL 425; 2014 Ford F150 toad; Air Force One Toad Brake.
Glen Allen, VA; Smith Mountain Lake, VA.
smlranger is offline   Reply With Quote
Old 12-29-2014, 06:23 PM   #5
Senior Member
 
Smitty77's Avatar
 
Join Date: Aug 2010
Location: Over the next hill, around the next curve...
Posts: 3,302
Thanks for sharing that! Good to know their different, and nice to have the link of Cummins codes.

On my 'To Do' list, is to check in with Silverleaf on our unit, and see what updates and upgrades are available. For sure I'll do the updates, will $$ pencil out upgrade costs.

Best,
Smitty
__________________
Roo II is our 04 Country Coach Allure 40'
OnDRoad for The JRNY! Enjoy life...
Smitty77 is offline   Reply With Quote
Old 12-29-2014, 07:04 PM   #6
Moderator Emeritus
 
smlranger's Avatar


 
Country Coach Owners Club
Freightliner Owners Club
Join Date: Sep 2004
Location: Glen Allen, VA
Posts: 7,259
Blog Entries: 1
Quote:
Originally Posted by Smitty77 View Post
Thanks for sharing that! Good to know their different, and nice to have the link of Cummins codes.

On my 'To Do' list, is to check in with Silverleaf on our unit, and see what updates and upgrades are available. For sure I'll do the updates, will $$ pencil out upgrade costs.

Best,
Smitty
I gave the Silverleaf guy my software version and, while there are more recent versions, he said I would likely not see sufficient functional changes with the update to justify the cost. That is based on my 240 system.
__________________
'07 Country Coach Allure 470 Siskiyou Summit #31578, Cummins ISL 425; 2014 Ford F150 toad; Air Force One Toad Brake.
Glen Allen, VA; Smith Mountain Lake, VA.
smlranger is offline   Reply With Quote
Old 01-05-2015, 03:23 PM   #7
Moderator Emeritus
 
smlranger's Avatar


 
Country Coach Owners Club
Freightliner Owners Club
Join Date: Sep 2004
Location: Glen Allen, VA
Posts: 7,259
Blog Entries: 1
UPDATE: I changed both my fuel filters today and drove the coach for a few miles. The check engine light came on within the first 5 miles of driving. It came on whenever I tried to accelerate or climb even a little grade and went off if I was either coasting or using little throttle. I get the same Silverleaf code 157 (559 Cummins code).

Spoke to my contact at Cummins CoachCare and he said the 559 fault was one that could mean a number of items and they would need to do more diagnostics. Appointment made for next Monday so will limp the 50 miles to their shop.

I can already hear the giant sucking sound near my wallet .
__________________
'07 Country Coach Allure 470 Siskiyou Summit #31578, Cummins ISL 425; 2014 Ford F150 toad; Air Force One Toad Brake.
Glen Allen, VA; Smith Mountain Lake, VA.
smlranger is offline   Reply With Quote
Old 01-05-2015, 03:28 PM   #8
Senior Member
 
Hogbus's Avatar
 
Fleetwood Owners Club
Join Date: Jun 2014
Location: Lakeway,tx
Posts: 239
Quote:
Originally Posted by smlranger View Post
UPDATE: I changed both my fuel filters today and drove the coach for a few miles. The check engine light came on within the first 5 miles of driving. It came on whenever I tried to accelerate or climb even a little grade and went off if I was either coasting or using little throttle. I get the same Silverleaf code 157 (559 Cummins code).

Spoke to my contact at Cummins CoachCare and he said the 559 fault was one that could mean a number of items and they would need to do more diagnostics. Appointment made for next Monday so will limp the 50 miles to their shop.

I can already hear the giant sucking sound near my wallet .
Mine has been in the shop with the 559 code since before thanksgiving. They have replaced the fuel system from pre seperator all the way to return, fuel pump and ecm. Still throws the code whenever you need power. Cummins engineer to arrive Jan 7 to check it out. I will let you know what they find. Good luck! JD
__________________
Jeff & Steph
2010 Discovery 40x Spartan Cummins ISB
2015 Wrangler Sahara Unlimited
Hogbus is offline   Reply With Quote
Old 01-05-2015, 04:36 PM   #9
Moderator Emeritus
 
smlranger's Avatar


 
Country Coach Owners Club
Freightliner Owners Club
Join Date: Sep 2004
Location: Glen Allen, VA
Posts: 7,259
Blog Entries: 1
Quote:
Originally Posted by Hogbus View Post
Mine has been in the shop with the 559 code since before thanksgiving. They have replaced the fuel system from pre seperator all the way to return, fuel pump and ecm. Still throws the code whenever you need power. Cummins engineer to arrive Jan 7 to check it out. I will let you know what they find. Good luck! JD
Wow. I hope they don't have that issue with mine. We need the coach by January 24. Oh well, the trials of owning one of these beasts.
__________________
'07 Country Coach Allure 470 Siskiyou Summit #31578, Cummins ISL 425; 2014 Ford F150 toad; Air Force One Toad Brake.
Glen Allen, VA; Smith Mountain Lake, VA.
smlranger is offline   Reply With Quote
Old 01-05-2015, 05:26 PM   #10
Senior Member
 
greystroke's Avatar


 
Monaco Owners Club
Freightliner Owners Club
Holiday Rambler Owners Club
Join Date: Jul 2009
Location: Spring Hill, Florida
Posts: 1,150
Word of caution. Sometimes a wiring problem will generate a FMI/SID code. I had a bad crankshaft sensor causing a problem and generating spurious codes. Probably not your problem but sometimes things happen. Especially where there is a high rodent population. Might be worth a general inspection with a bright light before giving up your motorhome for a long period. Good Luck.
__________________
98 Endeavor DP, ISB275
RX300, Falcon II hitch, BB Vantage Select
VMSpc, 2002 Grey Ford Powerstroke
TST 507 w/ 10 Sensors
greystroke is offline   Reply With Quote
Old 01-15-2015, 08:16 PM   #11
Moderator Emeritus
 
smlranger's Avatar


 
Country Coach Owners Club
Freightliner Owners Club
Join Date: Sep 2004
Location: Glen Allen, VA
Posts: 7,259
Blog Entries: 1
Update: Took coach to Cummins Coach Care this week. Last time I drove the coach, even after changing the fuel filters, I was still getting check engine light and 'low fuel pressure fault' on Silverleaf. Coach sat for 5 days before I drove it 45 miles to Cummins. It ran like a top on the way to the shop... no faults.

So they drove the coach and it ran fine. Basically, they say the 559 fault is not very specific and can mean any number of things and it would require many hours of diagnostic work to chase it down. Since the code was showing inactive on their computer, they did not feel the diagnostic hours were justified at this time. So, I had them fix my oil leaks (new valve cover gasket, new gear cover gasket and shaft seal), and do a valve adjustment. They ran the coach on their dyno and said it ran great. I brought it home today and it ran like a scalded dog .

So, I will keep an eye on it and hope I just got some bad fuel, whatever.

They did say the valves were really out and adjustment was needed. I don't hear many Cummins folks speak of having their valve lash checked so I am glad I had them do that. I did notice the engine was less 'clacky' when I started it.
__________________
'07 Country Coach Allure 470 Siskiyou Summit #31578, Cummins ISL 425; 2014 Ford F150 toad; Air Force One Toad Brake.
Glen Allen, VA; Smith Mountain Lake, VA.
smlranger is offline   Reply With Quote
Old 01-15-2015, 08:33 PM   #12
Senior Member
 
Mr_D's Avatar
 
Solo Rvers Club
iRV2 No Limits Club
Join Date: May 2011
Location: Vancouver, WA
Posts: 28,392
Cummins specifies valve adjustment at 150,000 miles, 5000 hrs or 4 years so maybe it did need it.

What did they charge for it?
__________________
2009 45' Magna 630 w/Cummins ISX 650 HP/1950 Lbs Ft
Charter Good Sam Lifetime Member, FMCA, SKP
RV'ing since 1957, NRA Benefactor Life, towing '14 CR-V
Mr_D is online now   Reply With Quote
Old 01-16-2015, 06:32 AM   #13
Moderator Emeritus
 
smlranger's Avatar


 
Country Coach Owners Club
Freightliner Owners Club
Join Date: Sep 2004
Location: Glen Allen, VA
Posts: 7,259
Blog Entries: 1
Quote:
Originally Posted by Mr_D View Post
Cummins specifies valve adjustment at 150,000 miles, 5000 hrs or 4 years so maybe it did need it.

What did they charge for it?
Can't really identify specific charge for the valve adjustment since the total labor charge on the bill bundles all the work together. I know I paid a CAT dealer $450 for top end service on my 3126 CAT several years ago so it would have been at least that much or more.
__________________
'07 Country Coach Allure 470 Siskiyou Summit #31578, Cummins ISL 425; 2014 Ford F150 toad; Air Force One Toad Brake.
Glen Allen, VA; Smith Mountain Lake, VA.
smlranger is offline   Reply With Quote
Old 01-19-2015, 11:39 AM   #14
Senior Member
 
Hogbus's Avatar
 
Fleetwood Owners Club
Join Date: Jun 2014
Location: Lakeway,tx
Posts: 239
559 code finally fixed.

this is what they said.

-cummings field service engineer David Perez and myself performed all of the quickserve fuel system checks. all of our findings were the same as the previous findings. David then modified test procedure for the 'fuel rail return test". Rather than using insite to run a fuel leak test while measuring the fuel rail return. He stalled the engine during the test causing the "rail pressure relief valve" to unseat. the valve did reseat causing a loss of fuel. i then replaced the malfunctioning pressure relief valve. upon testing no fuel was lost through the return nor was the 559 code active. we are currently waiting on a new fuel/water separator housing. it is recommended by Mr. Perez that the housing is replaced.

-installed the new filter housing. I then test drove the RV. the test drive was successful
__________________

__________________
Jeff & Steph
2010 Discovery 40x Spartan Cummins ISB
2015 Wrangler Sahara Unlimited
Hogbus is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine shut down while driving kkquilter Caterpillar Engine Forum 28 03-08-2015 09:16 AM
Stop Engine Warning light Maxout Country Coach Owners Forum 13 12-31-2014 04:09 PM
Engine died after 15 seconds. ladagobago Cummins Engines 5 11-01-2014 08:58 PM
Engine Won't Start! Black Smoke Monaco Owner's Forum 9 10-19-2014 05:47 PM
50,000 Mile Report on the Brazel's UltraPower Engine Mod Duner Workhorse and Chevrolet Chassis Motorhome Forum 6 07-29-2013 02:30 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:39 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.