Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Country Coach Owners Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-04-2013, 06:33 PM   #1
Moderator Emeritus
 
smlranger's Avatar


 
Country Coach Owners Club
Freightliner Owners Club
Join Date: Sep 2004
Location: Glen Allen, VA
Posts: 7,261
Blog Entries: 1
Source for High Mount LED stop light

My oval LED center stop light is not working. Wiring seems OK and the other brake lights work (the high mount light is wired directly to the other stop lights). So, guess the gizmo has failed.

Other than CC, anyone know of a source for this particular light? I googled all the numbers I could find on the back but nothing comes up.

ATLED-24OVL and 2714670

I cannot find any manufacturer's name of logo....nothing other than 'Made in China.'
__________________

__________________
'07 Country Coach Allure 470 Siskiyou Summit #31578, Cummins ISL 425; 2014 Ford F150 toad; Air Force One Toad Brake.
Glen Allen, VA; Smith Mountain Lake, VA.
smlranger is online now   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-04-2013, 07:33 PM   #2
Senior Member
 
BFlinn181's Avatar
 
Gulf Streamers Club
Join Date: Jan 2012
Location: Cincinnati
Posts: 16,211
Can you remove the light fixture or lens? Check the wires for power at the light. It could be a bad ground. Perhaps the LED can be replaced with something close, or a strip of LEDs or a whole new fixture.
__________________

__________________

Bob & Donna
'98 Gulf Stream Sun Voyager DP being pushed by a '00 Beetle TDI
BFlinn181 is offline   Reply With Quote
Old 06-11-2013, 09:14 AM   #3
Senior Member
 
JohnFreyja's Avatar
 
Join Date: Dec 2007
Location: Anacortes, Wa.
Posts: 486
Send a message via AIM to JohnFreyja Send a message via MSN to JohnFreyja
Kevin Waite in Junction City found one for my 05 Inspire.
541-953-6162
__________________
John
08 Intrigue
2014 Ford Edge
JohnFreyja is offline   Reply With Quote
Old 06-11-2013, 07:51 PM   #4
Moderator Emeritus
 
smlranger's Avatar


 
Country Coach Owners Club
Freightliner Owners Club
Join Date: Sep 2004
Location: Glen Allen, VA
Posts: 7,261
Blog Entries: 1
Quote:
Originally Posted by JohnFreyja View Post
Kevin Waite in Junction City found one for my 05 Inspire.
541-953-6162
Thanks. I found them at Starcraft Products in Indiana for $29.50. However, my issue is not the light. It is something else and I am exhausted trying to figure it out.
__________________
'07 Country Coach Allure 470 Siskiyou Summit #31578, Cummins ISL 425; 2014 Ford F150 toad; Air Force One Toad Brake.
Glen Allen, VA; Smith Mountain Lake, VA.
smlranger is online now   Reply With Quote
Old 06-12-2013, 11:12 AM   #5
Senior Member
 
Country Coach Owners Club
Join Date: Jan 2006
Location: Redding
Posts: 3,412
Your same question was posted today on the same vintage coach on the Country Coach Owners site on Yahoo.

The single response was that maybe that LED light was not wired to the brake light system, but to the trailer brake wiring instead, as I recall.

Have you been able to verify that you do or do not have dc power to the light as BFlinn asked?
__________________
Dean
1995 CC Magna #5280
C8.3L 300hp Cummins, 31,000lbs
deandec is offline   Reply With Quote
Old 06-12-2013, 11:25 AM   #6
Senior Member
 
Arch Hoagland's Avatar
 
Monaco Owners Club
Workhorse Chassis Owner
Join Date: Aug 2002
Location: Clovis, CA, USA
Posts: 5,887
Did the light EVER work while you have had the coach?
__________________
2004 Monaco La Palma 36DBD, W22, 8.1, 7.1 MPG
2000 LEXUS RX300 FWD 22MPG 4020 LBS
Arch Hoagland is offline   Reply With Quote
Old 06-12-2013, 01:24 PM   #7
Moderator Emeritus
 
smlranger's Avatar


 
Country Coach Owners Club
Freightliner Owners Club
Join Date: Sep 2004
Location: Glen Allen, VA
Posts: 7,261
Blog Entries: 1
Quote:
Originally Posted by deandec View Post
Your same question was posted today on the same vintage coach on the Country Coach Owners site on Yahoo.

The single response was that maybe that LED light was not wired to the brake light system, but to the trailer brake wiring instead, as I recall.

Have you been able to verify that you do or do not have dc power to the light as BFlinn asked?
That post on the Yahoo forum was mine. Trying to get suggestions from wider CC owners forum.

According to CC tech support, the high mount light is wired to the left side tail light. That cannot be right since the coach does not have separate turn signals. I jumped a wire from the led to the left 'brake' wire but the led light then flashed with the left turn signal. I believe the high mount light get's it power from another source but I have yet to identify it.

The LED light did work up until recently. It passed Virginia state inspection and it would not have if the light did not work. It works if you jump a known 12v signal to it.
__________________
'07 Country Coach Allure 470 Siskiyou Summit #31578, Cummins ISL 425; 2014 Ford F150 toad; Air Force One Toad Brake.
Glen Allen, VA; Smith Mountain Lake, VA.
smlranger is online now   Reply With Quote
Old 06-12-2013, 05:43 PM   #8
Senior Member
 
Country Coach Owners Club
Join Date: Jan 2006
Location: Redding
Posts: 3,412
Does your toad wiring connection include a separate brake wire in addtion to the turn signal wire?

If so, you could jump from the coach side of that wire to the HM brake light to see if your get your desired result.
__________________
Dean
1995 CC Magna #5280
C8.3L 300hp Cummins, 31,000lbs
deandec is offline   Reply With Quote
Old 06-12-2013, 08:35 PM   #9
Moderator Emeritus
 
smlranger's Avatar


 
Country Coach Owners Club
Freightliner Owners Club
Join Date: Sep 2004
Location: Glen Allen, VA
Posts: 7,261
Blog Entries: 1
Quote:
Originally Posted by deandec View Post
Does your toad wiring connection include a separate brake wire in addtion to the turn signal wire?

If so, you could jump from the coach side of that wire to the HM brake light to see if your get your desired result.
That is my plan. I have discovered that the 'tow board' in the engine bay has a jumper that can be changed to support either a 3 wire or 4 wire signal to the toad wiring connection. However, whomever did the toad wiring for the prior owner created a real mess and Tom Johnson's did a poor job of dealing with it when they wired me up for my CRV. In fact, even though my CRV has separate turn signals, TJ's ignored that and when I apply the coach brakes, both my toad brake lights and my amber turn signals come on. I need to sort that out and, if I can get the toad wiring on the CC to deliver a separate brake signal, I will tap into that to power the center brake light.

I believe I now hate electrical problems worse than plumbing issues .
__________________
'07 Country Coach Allure 470 Siskiyou Summit #31578, Cummins ISL 425; 2014 Ford F150 toad; Air Force One Toad Brake.
Glen Allen, VA; Smith Mountain Lake, VA.
smlranger is online now   Reply With Quote
Old 06-12-2013, 11:17 PM   #10
Senior Member
 
Arch Hoagland's Avatar
 
Monaco Owners Club
Workhorse Chassis Owner
Join Date: Aug 2002
Location: Clovis, CA, USA
Posts: 5,887
smlranger said:

"I believe I now hate electrical problems worse than plumbing issues ."

I'm with you on that one!!!!
__________________
2004 Monaco La Palma 36DBD, W22, 8.1, 7.1 MPG
2000 LEXUS RX300 FWD 22MPG 4020 LBS
Arch Hoagland is offline   Reply With Quote
Old 06-16-2013, 01:44 PM   #11
Moderator Emeritus
 
smlranger's Avatar


 
Country Coach Owners Club
Freightliner Owners Club
Join Date: Sep 2004
Location: Glen Allen, VA
Posts: 7,261
Blog Entries: 1
UPDATE: I discovered the 'Tow Board' in the engine bay. Changing a jumper on that provides output to the tow pigtail that mimics separate turn sigs. Changed that jumper and, sure enough, there is a separate brake signal. I jumped a wire from the newly found brake signal wire directly to the + on the LED high mount light. Now I get brake lights but the LED flashes on/off for a half second and will not stay on with the other brake lights .

So, for any electrical experts out there....should I add a relay and use the brake signal to activate the relay to power the LED light (I have plenty of good 12v sources in the engine bay).?
__________________

__________________
'07 Country Coach Allure 470 Siskiyou Summit #31578, Cummins ISL 425; 2014 Ford F150 toad; Air Force One Toad Brake.
Glen Allen, VA; Smith Mountain Lake, VA.
smlranger is online now   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:40 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.