Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Country Coach Owners Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-25-2015, 12:39 PM   #1
MTT
Junior Member
 
Join Date: Sep 2012
Posts: 29
Transfer switch problems

When I start my generator on my 2007 CC Intrigue it switches to invert soon after I start it. It switches to pass thru fine when I'm on shore power. I have a 10k power tech gen set. Generator seems to be running fine and I did try changing the fuel filter. Is the transfer switch most likely the problem? How do I test it? Thanks.
__________________

__________________
MTT is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-25-2015, 12:48 PM   #2
KIX
Senior Member
 
KIX's Avatar


 
Join Date: Dec 2006
Location: St. Augustine, FL
Posts: 3,579
That sounds like you're only getting one leg of two when running the gen. I would guess that the leg that serves the inverter/charger is not getting 120v when on gen. If I am correct there will be other 120v appliances or receptacles that don't work that receive their power from the same leg. The issue could be a dirty contact or a loose connection inside the transfer switch.
The reason it's switching to invert is that it's not getting 120v power
__________________

__________________
KIX
'02 Ultimate Advantage 40J Spartan MM - Cummins ISC
2013 Jeep Rubicon JK Unlimited
KIX is offline   Reply With Quote
Old 07-25-2015, 01:19 PM   #3
Senior Member
 
Join Date: Aug 2011
Posts: 113
Reset the circuit breaker on the generator (turn it off and back on). Also check the breakers in the AC panel inside the coach.

Barney
07 Inspire 52059
__________________
BarneyM is offline   Reply With Quote
Old 07-25-2015, 11:15 PM   #4
MTT
Junior Member
 
Join Date: Sep 2012
Posts: 29
Thanks I'll ck those things.
__________________
MTT is offline   Reply With Quote
Reply

Tags
transfer switch



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Transfer Switch Problems? waterdoc Alpine Coach Owner's Forum 10 06-29-2015 11:08 PM
Transfer switch or generator? Old Dude 66 MH-General Discussions & Problems 7 09-19-2014 04:10 PM
No Output from Transfer Switch VickersC RV Systems & Appliances 14 07-10-2014 03:04 PM
IOTA transfer switch Dupdyke Class A Motorhome Discussions 3 02-02-2014 08:41 PM
Transfer switch hum? falconman Monaco Owner's Forum 12 01-15-2014 08:56 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:33 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.