Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Country Coach Owners Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 02-24-2014, 11:57 AM   #1
Senior Member
 
Ssgritton's Avatar
 
Join Date: Feb 2013
Location: Salem, Oregon
Posts: 199
Two things on my Country Coach - ABS light and Heater

My ABS light is on but my brakes work fine any idea?

Also my dash heater fan keeps turning on and off? On the way home yesterday it went completly off, when I got home and restarted it and it would turn on and off like a short in the switch?

Thanks for any help, Shawn
__________________

__________________
-------------------------------
2005 Country Coach Allure 37ft Tag
Toad 2014 Rubicon Jeep
Ssgritton is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 02-24-2014, 12:23 PM   #2
Moderator Emeritus
 
RickO's Avatar


 
Join Date: Jan 2007
Location: Litchfield Park, Arizona
Posts: 10,530
Can't help with the dash fan, but ABS sensors are infamous for getting dirty and giving false alarms. Use our search feature and I think you'll find some cleaning techniques.

Rick
__________________

__________________
Rick, Nancy, Peanut & Lola our Westie Dogs & Bailey the Sheltie.

2007 Itasca Ellipse 40FD
RickO is offline   Reply With Quote
Old 02-24-2014, 12:37 PM   #3
Senior Member
 
homeless's Avatar
 
Join Date: Mar 2012
Location: http://binged.it/1KdDqKO
Posts: 2,314
Blog Entries: 1
When the ABS light is on you don't have ABS but you have normal braking...

The fan is most likely a automatic Circuit Breaker....Try to run the fan on lower speed.
__________________
homeless is offline   Reply With Quote
Old 03-10-2014, 11:55 PM   #4
Senior Member
 
Ssgritton's Avatar
 
Join Date: Feb 2013
Location: Salem, Oregon
Posts: 199
Just had the coach in for its yearly service. The ABS light was a out of alignment sensor. The fan is running but stops once and a while?
__________________
-------------------------------
2005 Country Coach Allure 37ft Tag
Toad 2014 Rubicon Jeep
Ssgritton is offline   Reply With Quote
Old 03-11-2014, 11:02 AM   #5
Senior Member
 
Country Coach Owners Club
Join Date: Jan 2006
Location: Redding
Posts: 3,412
The fan could be something as simple as a loose ground connection or a broken wire. Simple, but challenging to find......

If the problem was mine, I would access the back of the switch panel, turn the fan on, and wiggle some wires to see if one would affect the fan
__________________
Dean
1995 CC Magna #5280
C8.3L 300hp Cummins, 31,000lbs
deandec is offline   Reply With Quote
Old 03-11-2014, 11:59 AM   #6
Member
 
2dogsbarkin's Avatar
 
Country Coach Owners Club
Join Date: Oct 2012
Location: Where ever we are parked!
Posts: 79
My ABS light comes on a lot when we are in cold damp areas.
We have been in Az for the last 3 months and it comes on now and then when we sit a while but as soon as I work the break a few time it clears up.
Moisture?
__________________
2dogsbarkin is offline   Reply With Quote
Old 05-20-2014, 04:20 PM   #7
Junior Member
 
Country Coach Owners Club
Join Date: May 2014
Posts: 7
The ABS is very likely a wheel sensor. a very easy fix and really not that expensive. Just did one on a smaller motor home
__________________
68fastback is offline   Reply With Quote
Old 05-20-2014, 04:21 PM   #8
Junior Member
 
Country Coach Owners Club
Join Date: May 2014
Posts: 7
i truly doubt the two are related.. two different issues, two different circuits
__________________
68fastback is offline   Reply With Quote
Old 05-24-2014, 06:04 AM   #9
Senior Member
 
sallylillian's Avatar
 
Country Coach Owners Club
Join Date: Sep 2011
Posts: 133
My ABS light comes on "sometimes" when I have the tag lifted. It goes off only after an engine restart.
__________________
Michael
In the UK with;
2008 Allure Sunset Bay
sallylillian is offline   Reply With Quote
Old 05-25-2014, 12:08 AM   #10
Junior Member
 
Country Coach Owners Club
Join Date: May 2014
Posts: 7
If you set your tag down your ABS would go off as well. This is not uncommon I'm told. Mine lights up when the tag is up and goes off when I set em down
__________________
68fastback is offline   Reply With Quote
Old 05-25-2014, 09:00 AM   #11
Member
 
DanInAlberta's Avatar
 
Join Date: Jun 2013
Location: Whitecourt, AB
Posts: 68
I had to lift the suspension so the mechanic could get under to change oil. When I left the shop the ABS light was on. After using the brakes the light went out.
__________________

__________________
2007 Country Coach Intrique 530
DanInAlberta is offline   Reply With Quote
Reply

Tags
heater



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Water Heater Question?? ArmyEOD Monaco Owner's Forum 11 01-24-2014 06:52 AM
Atwood water heater won't fire up Camperqueen RV Systems & Appliances 6 01-21-2014 04:17 AM
Atwood Water Heater won't re light jcwhitty RV Systems & Appliances 7 08-04-2013 10:52 AM
Hot water heater not sparking smittythebea RV Systems & Appliances 6 07-26-2013 09:57 AM
Atwood Water Heater LP Gas Operation BerylCop RV Systems & Appliances 4 07-23-2013 08:41 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:49 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.