Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Country Coach Owners Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-03-2014, 02:56 PM   #1
Moderator Emeritus
 
smlranger's Avatar


 
Country Coach Owners Club
Freightliner Owners Club
Join Date: Sep 2004
Location: Glen Allen, VA
Posts: 7,266
Blog Entries: 1
Weldex BU camera question

I've noticed recently a subtle intermittent flicker in the back up camera image on my Pioneer Nav gizmo. I have never lost the image but it occasionally just flickers. I removed the panel in the closet and checked all the connections.... all seem tight and dry. So, am I witnessing the imminent failure of the camera?
__________________

__________________
'07 Country Coach Allure 470 Siskiyou Summit #31578, Cummins ISL 425; 2014 Ford F150 toad; Air Force One Toad Brake.
Glen Allen, VA; Smith Mountain Lake, VA.
smlranger is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-03-2014, 03:43 PM   #2
Senior Member
 
JohnFreyja's Avatar
 
Join Date: Dec 2007
Location: Anacortes, Wa.
Posts: 487
Send a message via AIM to JohnFreyja Send a message via MSN to JohnFreyja
smlranger,
Although mine is a Kenwood it was preforming similar and would even quit completely for extended times. I pulled the unit out of the dash and discovered a loose connection, replugged it in until it clicked and now it works great.
__________________

__________________
John
08 Intrigue
2014 Ford Edge
JohnFreyja is offline   Reply With Quote
Old 05-03-2014, 06:12 PM   #3
Moderator Emeritus
 
smlranger's Avatar


 
Country Coach Owners Club
Freightliner Owners Club
Join Date: Sep 2004
Location: Glen Allen, VA
Posts: 7,266
Blog Entries: 1
Quote:
Originally Posted by JohnFreyja View Post
smlranger,
Although mine is a Kenwood it was preforming similar and would even quit completely for extended times. I pulled the unit out of the dash and discovered a loose connection, replugged it in until it clicked and now it works great.
John, thanks for that info. I will pull the Pioneer from the dash and check connections at that end.
__________________
'07 Country Coach Allure 470 Siskiyou Summit #31578, Cummins ISL 425; 2014 Ford F150 toad; Air Force One Toad Brake.
Glen Allen, VA; Smith Mountain Lake, VA.
smlranger is offline   Reply With Quote
Old 05-09-2014, 12:24 PM   #4
Senior Member
 
2 Stroker's Avatar
 
Join Date: Nov 2009
Location: Warren, Oregon
Posts: 1,719
I have the same BU camera and run my Silverleaf through it and it started to jump around and then going off. Check all conections even at the camera all tight. Then I got a small tube of Terminal Grease-Dielectric Silicone Compound put it on all the pins on the cable ends, now it works great just like watching tv at home. got it at Ace.
2 stroker
__________________
2006 Country Coach Inspire 360 40ft Genoa Designer Series, Samsung 197 RR
Cat C9--STEEL & COPPER Bolt Together Radiator w/ updated rubber mounting
SilverLeaf 330 Magnum 2812 PSW 2011 Ford Edge Sport-Air Force One
2 Stroker is offline   Reply With Quote
Reply

Tags
camera



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Adventurer rear camera question kevin1959 Winnebago Industries Owner's Forum 16 08-12-2014 04:39 PM
Weldex Rear View Camera - Audio but No Video volvik Technology: Internet, TV, Satellite, Cell Phones, etc. 7 07-04-2014 06:36 AM
Weldex camera dmsatori Travel Supreme Owner's Forum 3 02-17-2014 04:58 PM
Backup Camera Problem GM28 Class A Motorhome Discussions 7 02-13-2014 09:51 PM
Squirrely rear camera RJEV MH-General Discussions & Problems 8 06-08-2013 04:39 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:43 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.