Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Jayco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-09-2016, 03:56 PM   #1
Junior Member
 
Join Date: Aug 2016
Posts: 5
2015 Greyhawk-unusable in summer months

My husband and I bought a new 2015 Greyhawk 29ME last October and have had too many problems to list here. Our main problem is that while the coach is in motion we are unable to use the generator to run the A/C to cool the back of the coach. We actually had to drive home from Colorado in the middle of the night so we wouldn't cook the kids in the 100 weather. We took our coach in to two different Cummins and into the service department of our dealership several times with nothing being resolved. I finally emailed Jayco and received a reply saying they were looking into it. I emailed again and asked to be kept informed because we have two more trips planned this summer and they replied that they would. I then decided to call so I could find out a timeline, because of our upcoming trip and was told that the technicians were working hard to solve these issues and that hopefully by September they would know something. I asked if this was a widespread problem and was told that honestly it was! Why on earth the dealership wasn't notified that these issues were happening elsewhere, I can't fathom! Does anyone out there have these same issues?
__________________

__________________
Ryanandcolle is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-09-2016, 05:07 PM   #2
Senior Member
 
plasma800's Avatar
 
Fleetwood Owners Club
Join Date: Nov 2013
Location: Houston, Texas
Posts: 3,198
Blog Entries: 1
Yikes, what's stopping the generator from running while driving?

By the way, that just stinks, sorry you're having the "RV battle".

Have you posted any to the Jayco Owners Class C Forum located at -> http://www.jaycoowners.com/forums/f5/
__________________

__________________
RVM#78 - -USAF- F-15 Eagle Radar Vet
'05 Fleetwood Revolution '12 Chevy 2500 '15 Airstream Intl Sig. 27FB
'14 Ram 3500 Aisin
plasma800 is offline   Reply With Quote
Old 08-09-2016, 05:32 PM   #3
Senior Member
 
vsheetz's Avatar


 
Fleetwood Owners Club
Ford Super Duty Owner
Join Date: Jun 2012
Location: SoCal
Posts: 11,791
Two problem areas for a Oman generator that cause it to work ok when stationary but stop when in motion. Fuel pump bad and the low oil level cutoff. Ensure the oil is filled to the tippy top, not just the full mark.
__________________
Vince and Susan
2011 Tiffin Phaeton 40QTH (Cummins ISC/Freightliner)
Flat towing a modified 2005 Jeep (Rubicon Wrangler)
Previously a 2002 Fleetwood Pace Arrow 37A and a 1995 Safari Trek 2830.
vsheetz is offline   Reply With Quote
Old 08-10-2016, 11:23 AM   #4
Junior Member
 
Join Date: Aug 2016
Posts: 5
We don't know why it stops running, it just kind of putters out! Our dealership put in a new fuel pump a week ago and said the old one was definitely bad but it didn't help at all! Thanks for the link, I'll post there next!
__________________
Ryanandcolle is offline   Reply With Quote
Old 08-10-2016, 11:28 AM   #5
Junior Member
 
Join Date: Aug 2016
Posts: 5
The oil level was fine and the service department put in a new fuel pump, both Cummins and the service department were left scratching their heads! I'm really hoping it's not a wiring issue, I don't know how hard that would be to fix!
__________________
Ryanandcolle is offline   Reply With Quote
Old 08-10-2016, 01:46 PM   #6
Senior Member
 
George Schweikle's Avatar
 
Join Date: Apr 2004
Posts: 2,199
We had a similar problem after installing a new Onan Microquiet 4000 generator in our 28 ft. TREK. It ran fine when stationary, but would shut down when driving. An Onan tech in California said a known problem was that the generator was too far from the main gas tank for its fuel pump to work consistently. He recommended I install an auxiliary fuel pump near the main gas tank, and this cured the problem.

The generator fuel line had recently been replaced. Also, I sort of remember reading that the low oil sensor/cut off was no longer used on the Microquiet models.

Quote:
Originally Posted by Ryanandcolle View Post
My husband and I bought a new 2015 Greyhawk 29ME last October and have had too many problems to list here. Our main problem is that while the coach is in motion we are unable to use the generator to run the A/C to cool the back of the coach. We actually had to drive home from Colorado in the middle of the night so we wouldn't cook the kids in the 100 weather. We took our coach in to two different Cummins and into the service department of our dealership several times with nothing being resolved. I finally emailed Jayco and received a reply saying they were looking into it. I emailed again and asked to be kept informed because we have two more trips planned this summer and they replied that they would. I then decided to call so I could find out a timeline, because of our upcoming trip and was told that the technicians were working hard to solve these issues and that hopefully by September they would know something. I asked if this was a widespread problem and was told that honestly it was! Why on earth the dealership wasn't notified that these issues were happening elsewhere, I can't fathom! Does anyone out there have these same issues?
__________________
George Schweikle Lexington, KY
1999 Safari TREK 2830, FMCA 190830, Safari International chapter
1995 Safari TREK 2630, 1983 Winnebago Chieftain, 1976 Midas Mini
George Schweikle is offline   Reply With Quote
Old 08-10-2016, 05:48 PM   #7
Junior Member
 
Join Date: Aug 2016
Posts: 5
Thanks so much, that makes a lot of sense! I'll tell Jayco (if they ever call me back!) I'm hoping that they fix out problem, if not it doesn't sound like too expensive of a fix!
__________________
Ryanandcolle is offline   Reply With Quote
Old 08-15-2016, 07:06 PM   #8
Junior Member
 
Join Date: Mar 2013
Posts: 4
I have a similar problem with my new Jayco Alante 2016. I can run the generator until it gets to be about 90 degrees outside and then it stops. As you mentioned this makes the RV unusable in the summer and beyond as I live in Florida where it's 90 half the year!!!

We just returned from a miserable trip in 95 degree heat with kids and pets and no AC in the back of the coach!

A call to Jayco revealed they were aware of this and as they told you they are looking into it. No call back yet and I am not sure I am going to get one!!! Their only suggestion was to take the bin door off to give more air flow as they think it is overheating the gas line and causing a vapor lock.
__________________
lfloridays is offline   Reply With Quote
Old 08-15-2016, 07:12 PM   #9
Senior Member


 
Join Date: Apr 2015
Posts: 997
Fuel pump. Really, it's the fuel pump. Had the same problem. Took it into a Cummins certified center and they diagnosed and replaced the fuel pump. No problems since, even in AZ summer heat. Did I mention it is the fuel pump?
__________________
2014 Raptor 300MP, 2014 Cowboy Cadillac - Ram 3500 Crew Cab Long Bed Longhorn 6.7 Cummins Turbo Diesel DRW 4.10 Rear End, 5588 Payload, Firestone Airbags, Curt Q20, TST507
raineman is online now   Reply With Quote
Old 08-15-2016, 10:05 PM   #10
Member
 
LandN's Avatar
 
Jayco Owners Club
Join Date: Nov 2013
Location: near Austin, Texas
Posts: 37
Quote:
Originally Posted by vsheetz View Post
Two problem areas for a Oman generator that cause it to work ok when stationary but stop when in motion. Fuel pump bad and the low oil level cutoff. Ensure the oil is filled to the tippy top, not just the full mark.
What type/grade of oil is used for the generator, please?

Thanks.
__________________
Larry and Nancy
2016 Jayco Greyhawk 29MV
2013 GMC Sierra 1500 crew cab toad
LandN is offline   Reply With Quote
Old 08-16-2016, 05:07 PM   #11
Junior Member
 
Join Date: Aug 2016
Posts: 5
They replaced the fuel pump a couple of weeks ago and still the problem persists. We talked to a different customer service rep at Jayco a couple of days ago, he said it might be that the fuel line is collapsing and we might try a braided fuel line. Also he mentioned that it could be a bad capacitor on the A/C, he said the capacitor might be pulling too many amps. Jayco also suggested taking our RV into a different service department, it's there now and we have our fingers crossed!
__________________

__________________
Ryanandcolle is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2015 Jayco Greyhawk house battery theskippet Class C Motorhome Discussions 6 05-22-2017 08:48 PM
Slow/unusable campground wi-fi dkperez Technology: Internet, TV, Satellite, Cell Phones, etc. 161 09-10-2016 12:10 PM
What Do You Think About Night Time Driving During The Hot Summer Months? niceguy9605 iRV2.com General Discussion 50 01-12-2016 02:51 PM
2015 Jayco Greyhawk 31FS vs. 2015 NeXus Phantom 32P H-School Bus Class C Motorhome Discussions 3 08-07-2014 11:18 PM
Good RV Park for Summer Months? mytime Camping Locations, Plans & Trip Reports 11 02-13-2014 07:05 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:08 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.