Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-14-2009, 09:11 PM   #1
Member
 
Join Date: Jan 2007
Posts: 41
03 Windsor slide 5 amp fuse blowing

all of a sudden the 5 amp fuse located in the rear quarter panel area of my 03 Windsor keeps blowing leaving my slides a bust.

First.. What does this 5 amp fuse do?

Second... the only consistent thing other then levelling is that prior to trying to operate the slide I had backed up wiht rear, side and head lamps all on.. could they be releated.

Fix is easy but I need to figure this out.

Please help.
__________________

__________________
dobrien is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-16-2009, 12:35 PM   #2
"Formerly Diplomat Don"
 
Dutch Star Don's Avatar
 
Newmar Owners Club
Join Date: Apr 2005
Location: Moorpark, Ca.
Posts: 9,117
dobrien.......Some resistance may have built up in the wiring over the years (corroded connections, motor drag, etc) and causing the fuse to blow. Even when new, my front power shades blew a fuse everytime we operated both of them at the same time. It was also a 5 amp fuse and seemed small for the application. I changed it to a 7.5 amp fuse and never had the issue again. I also felt that bumping it by 2.5 amps wasn't going to fry anything if there was a larger problem.
__________________
Don & Mary
2014 Newmar Dutch Star - All Electric - 450 ISL
2016 GMC Canyon 4WD Crew Cab
Dutch Star Don is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ventana 30 amp in line fuse behind master kill switch and behind radiator. KarenEK Newmar Owner's Forum 2 11-15-2008 06:28 PM
Help with fuse blowing solution LandHo Winnebago Industries Owner's Forum 10 04-26-2008 06:39 PM
Blowing Fuse When Using Flashers CYOUL8R MH-General Discussions & Problems 12 04-02-2008 09:56 AM
HWH Blowing 250 Amp Fuse in Rear of Apex Marca Alpine Coach Owner's Forum 11 02-10-2008 08:51 PM
Blowing My Fuse!!! CYOUL8R MH-General Discussions & Problems 8 10-11-2007 06:18 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:57 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.