RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-17-2019, 11:30 AM   #1
Junior Member
 
Join Date: Oct 2018
Posts: 2
1996 Monaco dynasty generator

When Iím plugged into shore power or run my generator and engine my alt light comes on just flickered. But I went for a 500 mile trip all was fine. Stayed out a week picked up grandkids on the way back turned on generator, house batteries were down. Alt light came on the engine rev up to 2000rpm and had no control on throttle shut off engine restarted still at 2000 rpm,
Shut off both batteries and everything was normal, then turned back on generator same-thing all was fine .Now I was told from someone the isolators might be bad this is the only post that spoke about this so if you have any feedback please post I was on another site where then werenít friendly at all
__________________

Tare is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-17-2019, 11:59 AM   #2
Senior Member
 
vito.a's Avatar
 
Monaco Owners Club
Join Date: Oct 2009
Location: Tucson, AZ
Posts: 3,510
If I run the engine when the coach is plugged into shore power the alt light comes on. This is normal.

The engine revving up sounds like the cruise control was on. We use the cruse control for fast idle during warm up.
__________________

__________________
97 Monaco Windsor- Sold
07 Monaco Executive McKinley- Sold
04 Monaco Signature Chateau IV
vito.a is offline   Reply With Quote
Old 07-17-2019, 12:56 PM   #3
Senior Member/RVM #90
 
MSHappyCampers's Avatar


 
Monaco Owners Club
Join Date: Nov 2002
Location: Columbus, MS
Posts: 37,816
Hi ! Welcome to IRV2! We're sure glad you joined the gang!

Sorry, don't have a clue! Have fun and keep her between the ditches!

Good luck, happy trails, and God bless!
__________________
Joe & Annette

2002 Monaco Windsor 40PBT, 2013 Honda CRV AWD
MSHappyCampers is offline   Reply With Quote
Old 07-17-2019, 02:58 PM   #4
Senior Member
 
windsorbill's Avatar
 
Monaco Owners Club
Join Date: Jun 2011
Location: CA
Posts: 2,326
Quote:
Originally Posted by Tare View Post
When Iím plugged into shore power or run my generator and engine my alt light comes on just flickered. But I went for a 500 mile trip all was fine. Stayed out a week picked up grandkids on the way back turned on generator, house batteries were down. Alt light came on the engine rev up to 2000rpm and had no control on throttle shut off engine restarted still at 2000 rpm,
Shut off both batteries and everything was normal, then turned back on generator same-thing all was fine .Now I was told from someone the isolators might be bad this is the only post that spoke about this so if you have any feedback please post I was on another site where then werenít friendly at all
Tare,
As vito says above, the alt light on when plugged in and engine running seems to be normal on these things. I wouldn't worry about it.

Not sure about your engine at 2000 rpms. Are we talking about the main engine or the generator? Maybe elaborate a little on that issue.
__________________
06 Windsor PRQ, Cummins 400 ISL
2014 Honda CRV
windsorbill is offline   Reply With Quote
Old 07-18-2019, 04:37 AM   #5
Junior Member
 
Join Date: Oct 2018
Posts: 2
First off thank you for quick response. We’re talking main engine. Cruise was on I tried turning off
Tare is offline   Reply With Quote
Reply

Tags
generator, monaco, monaco dynasty



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Monaco Dynasty Barron III :: 1997 Monaco Dynasty Barron III ctmdr iRV2 Owners Registry 0 01-17-2018 09:52 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:50 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.