RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 01-11-2018, 08:44 AM   #1
Senior Member


 
Join Date: Sep 2011
Posts: 1,261
2011 Camelot electric step COVER malfunction

A friend and I are headed from the east coast to Q. Presently at a rest stop in MS.

While driving, his step cover unexpectedly deployed, covering the steps. It would not respond to either the DS or PS step cover switch. It is the electric type, with a motor (through some gear or belt reduction?) driving an Acme screw with a polyethylene nut that moves the step. It also has a gimpy mechanism that causes the step to move upward slightly before reaching the end of its travel, making it more nearly level with the fixed floor of the coach.

Wiring diagrams for this coach show only how the two switches are wired to allow either one to operate the step cover in either direction.

I have located a 2-wire Molex connector in the upper FRB that I am almost positive operates the motor. One side of the connector has two white wires that I assume are the output from the two switches. The other side has black and red wires, and it goes directly to the motor.

There are at least two problems at work here. 1) If indeed the Molex connector I have found is the correct one, I should be able to feed 12VDC directly into that connector and drive the motor either direction by reversing polarity. When I do that, I get a small spark (10 amp?), but no motor movement. That seems to indicate a motor problem, or mechanical binding. Rapping on the motor with a wrench did not change anything. 2) Although the fuse is good, when either of the two switches is operated, no voltage appears on the white-wire side of he Molex connector. This would seem to indicate a bad switch or no 12VDC to the circuit.

I could not get anything to cause the step cover to retract, so I just removed the wood screws holding it to the mechanism and my friends are just stepping over the parts of the mechanism that are still deployed. There appears to either be enough gear reduction that you cannot "back-drive" the screw, or something is bound up in the drive mechanism. The mechanism linkage is all free--no binding.

Since the step deployed unexpectedly, I suspect an electrical problem, but can't explain why "hot-wiring" the motor does not work.

We are headed out now, and I will check this forum again tonight. TIA for your help.
__________________

__________________
Van W 2000 Dynasty 36, pulling one Harley
Southeastern NC
Vanwill is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-11-2018, 09:01 AM   #2
Senior Member
 
10Boomer's Avatar


 
Join Date: May 2012
Posts: 2,604
I have heard of motor issues. When I rebuilt by stair area, I noticed that the cover had some loose screws and over extended its self causing the step to bind. I added walkers behind the lock collar which travels back and fourth. No more issues. Fuse on our 2008 in FRB. Iím sure you will check the obvious connectors and ground. You know how these coaches are wired.
__________________

__________________
Perry & Julie: 2008 Monaco Camelot 40PDQ, 400ISL, Toad; 2015 Chevy Equinox.
10Boomer is offline   Reply With Quote
Old 01-11-2018, 09:58 AM   #3
Junior Member
 
Join Date: Feb 2015
Location: Chandler, AZ
Posts: 12
Step cover

Not sure if you have the same step cover as in 2013 Diplomat but I had similar issues. I thought it was the motor or other electrical problem but mine was mechanical. It would jam because the design uses sloppily installed rivets to attach the moving parts. Additionally, the compartment was not well sealed so road dirt enters and fouls the slides.

I ended up removing the whole mechanism, replacing the slides as well as the rivets. I used nylon bushings and bolts with nylock washers to attach. Essentially, the whole mechanism was rebuilt.

The photo shows it reinstalled, fully extended before the cover was put on.

It works better than new and is much quieter than original.

Unfortunately it is not a task I would undertake on the road. It was time intensive and a lot of parts runs.
Attached Thumbnails
Click image for larger version

Name:	Stepcover.jpg
Views:	50
Size:	219.2 KB
ID:	188358  
43DFT is offline   Reply With Quote
Old 01-11-2018, 03:53 PM   #4
Senior Member


 
Join Date: Sep 2011
Posts: 1,261
Perry, it does not look like it is in bind, at least not on any of the slide mechanism. The screw and poly nut appear as if they were run hard against a stop. There do not appear to be any limit switches, so maybe it's like an auto window--run hard against a stop. In cars, there is a self-resetting CB. In this coach, there is a fuse. But both you and 10Boomer say you have had binding, so I'll check further. And yes, someone has repositioned the aft end of the angle iron bracket because of some binding issue.

Wish someone could verify that the 2-wire Molex near top center of FRB with the Black and Red wires is the one that goes to the motor.

It is pouring rain here at the rest area just inside the Texas border. Will have to wait until later...maybe even Q. We may have to drill out pop rivets to disassemble enough to allow easier access.

Thanks! Open to any other replies!!!
__________________
Van W 2000 Dynasty 36, pulling one Harley
Southeastern NC
Vanwill is offline   Reply With Quote
Old 01-11-2018, 03:55 PM   #5
Senior Member


 
Join Date: Sep 2011
Posts: 1,261
Sorry, got your names mixed up. 43DFT--the mechanism looks EXACTLY like yours. Thanks for the pix.
__________________
Van W 2000 Dynasty 36, pulling one Harley
Southeastern NC
Vanwill is offline   Reply With Quote
Old 01-11-2018, 04:29 PM   #6
Senior Member
 
96 Wideglide's Avatar
 
Holiday Rambler Owners Club
Join Date: Aug 2010
Posts: 3,992
Sounds like your gona need cookies !
__________________
Ben & Sharon
2008 43' Holiday Rambler Scepter PDQ
96 Wideglide is offline   Reply With Quote
Old 01-11-2018, 06:31 PM   #7
Senior Member


 
Join Date: Sep 2011
Posts: 1,261
Quote:
Originally Posted by 96 Wideglide View Post
Sounds like your gona need cookies !
Ben, are you going to be at Q? Looking forward to seeing you if you do!
__________________
Van W 2000 Dynasty 36, pulling one Harley
Southeastern NC
Vanwill is offline   Reply With Quote
Old 01-11-2018, 09:21 PM   #8
Senior Member
 
10Boomer's Avatar


 
Join Date: May 2012
Posts: 2,604
Cookies for you!
__________________
Perry & Julie: 2008 Monaco Camelot 40PDQ, 400ISL, Toad; 2015 Chevy Equinox.
10Boomer is offline   Reply With Quote
Old 01-11-2018, 09:53 PM   #9
Senior Member
 
10Boomer's Avatar


 
Join Date: May 2012
Posts: 2,604
Quote:
Originally Posted by 43DFT View Post
Not sure if you have the same step cover as in 2013 Diplomat but I had similar issues. I thought it was the motor or other electrical problem but mine was mechanical. It would jam because the design uses sloppily installed rivets to attach the moving parts. Additionally, the compartment was not well sealed so road dirt enters and fouls the slides.

I ended up removing the whole mechanism, replacing the slides as well as the rivets. I used nylon bushings and bolts with nylock washers to attach. Essentially, the whole mechanism was rebuilt.

The photo shows it reinstalled, fully extended before the cover was put on.

It works better than new and is much quieter than original.

Unfortunately it is not a task I would undertake on the road. It was time intensive and a lot of parts runs.


Looks similar to our 2008, but I see some differences with frame and bracing. We can look at when you get to QZ. FYI. Must be a coincidence, coming back from Sacramento today with coach I developed a rattle in my step cover something to check again. Last time it was a brace with a loose rivet.
__________________
Perry & Julie: 2008 Monaco Camelot 40PDQ, 400ISL, Toad; 2015 Chevy Equinox.
10Boomer is offline   Reply With Quote
Old 01-11-2018, 10:41 PM   #10
Senior Member
 
Happycarz's Avatar
 
Monaco Owners Club
Join Date: Sep 2007
Location: Scottsdale, AZ
Posts: 1,766
If the motor is bad, the following is the motor that fits my coach, same as Perryís coach.

Grainger 3LCH7 1/35 HP Motor

https://www.grainger.com/product/DAY...rchQuery=3LCH7
__________________
Harry

2008 Monaco Camelot 40' PDQ
Happycarz is offline   Reply With Quote
Old 01-12-2018, 06:21 AM   #11
Senior Member
 
96 Wideglide's Avatar
 
Holiday Rambler Owners Club
Join Date: Aug 2010
Posts: 3,992
Quote:
Originally Posted by Vanwill View Post
Ben, are you going to be at Q? Looking forward to seeing you if you do!
Unfortunately we wont. My vacation time starts mid Feb, so that will put us passing by Q probably early March.
Hopefully we will make it in a couple of years when we're done with working!
__________________
Ben & Sharon
2008 43' Holiday Rambler Scepter PDQ
96 Wideglide is offline   Reply With Quote
Old 01-13-2018, 04:09 PM   #12
Senior Member


 
Join Date: Sep 2011
Posts: 1,261
Ben & Perry--you both have said you had binding. On Tom's step, all the slide mechanism is loose and sloppy, so I don't think the binding, if any, is there. Did either of you mean that the polyethylene nut on the Acme screw was bound hard against its stop?

I'm going to Tom's coach and try to rotate that Acme screw enough to leave the poly nut loose on the screw, then see if "hot wiring" the motor will cause it to run. There will still be the problem of what caused it to deploy in the first place, but if we can get it retracted, that will do for the remainder of this trip to Q and back. They say they never used the step cover anyway, so if it stayed retracted, that would work for now.
__________________
Van W 2000 Dynasty 36, pulling one Harley
Southeastern NC
Vanwill is offline   Reply With Quote
Old 01-13-2018, 04:13 PM   #13
Senior Member
 
10Boomer's Avatar


 
Join Date: May 2012
Posts: 2,604
Iíll show you, mine was slow because of several issues, mine wasnít sloppy, now it is and I have a rattle now. The PO had it gummied up with who knows. Itís not s good design by no means.
__________________
Perry & Julie: 2008 Monaco Camelot 40PDQ, 400ISL, Toad; 2015 Chevy Equinox.
10Boomer is offline   Reply With Quote
Old 01-13-2018, 04:18 PM   #14
Senior Member
 
96 Wideglide's Avatar
 
Holiday Rambler Owners Club
Join Date: Aug 2010
Posts: 3,992
I'm almost afraid to say it, but I've had no problems with mine !

Like your friend, we rarely use it.
__________________

__________________
Ben & Sharon
2008 43' Holiday Rambler Scepter PDQ
96 Wideglide is offline   Reply With Quote
Reply

Tags
cover, electric



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ABS malfunction, ESP malfunction, and ASR malfunction. Now engine warning light. Marysia Sprinter Chassis Forum 6 02-28-2016 11:03 AM
Entry step malfunction.. RobRocks Monaco Owner's Forum 18 10-22-2014 04:12 PM
Step Cover Malfunction Mitchone Newmar Owner's Forum 7 09-26-2014 07:45 PM
Electric step malfunction LJJSRZ Monaco Owner's Forum 5 12-10-2013 03:50 PM
Help for electric step malfunction billt47 New Member Check-In 4 06-20-2012 06:14 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:12 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.