Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-17-2017, 01:26 PM   #1
Junior Member
 
Join Date: Jul 2016
Posts: 12
Alternator light

I have an 05 Monaco Windsor. My alternator light keeps coming on and voltage is fluctuating between 12.5 and 13.8. Problem is it is intermittent. After $2100, 3 different alternators, counting the original, two new chassis batteries, a relay for the alternator warning, I am still no better off. Spent 4 days at Freightliner, and when we thought we had it repaired, I would leave El Paso heading east on I-10. We had a long grade about 60 miles out of town. Engine temp would get to 210 right at the top. The alarm would go off and on. The third time, at almost the same spot and same conditions, it beeped a few times and went off. I kept going this time, and made it to Odessa, before it did it again as I was slowing and getting off the interstate. Wiring has been checked from front to back. What are we missing?Voltage is erratic on both the meter and Aladdin. Voltage at batteries reads what Aladdin reads.
__________________

__________________
TGibbons is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-17-2017, 02:08 PM   #2
Senior Member
 
Steve Ownby's Avatar
 
Join Date: Nov 2008
Location: Cosby, Tn
Posts: 6,341
Quote:
Originally Posted by TGibbons View Post
I have an 05 Monaco Windsor. My alternator light keeps coming on and voltage is fluctuating between 12.5 and 13.8. Problem is it is intermittent. After $2100, 3 different alternators, counting the original, two new chassis batteries, a relay for the alternator warning, I am still no better off. Spent 4 days at Freightliner, and when we thought we had it repaired, I would leave El Paso heading east on I-10. We had a long grade about 60 miles out of town. Engine temp would get to 210 right at the top. The alarm would go off and on. The third time, at almost the same spot and same conditions, it beeped a few times and went off. I kept going this time, and made it to Odessa, before it did it again as I was slowing and getting off the interstate. Wiring has been checked from front to back. What are we missing?Voltage is erratic on both the meter and Aladdin. Voltage at batteries reads what Aladdin reads.


Sounds like a minimum of 2 separate issues.
1. These forums have many posts detailing the problems with substituting different alternators for the OEM Leese Neville. If you still have the OEM, have a shop rebuild it with domestic parts. The problem now may be getting it hooked up as original. Monaco tech support should be able to help. If both the voltage at batteries & Aladdin are the same then, most likely, the alternator or the way it's hooked up are still the problem.
2. Long 6% or greater grades will stress your cooling package. Next time try down shifting to keep your rpms up around 2000. Send a sample of your coolant for analysis to JG Lube Services. If your coolant has issues or % of coolant to water is out of whack it can impact heat transfer.
__________________

__________________
Steve Ownby
Full time since 2007
2003 Monaco Signature
Steve Ownby is offline   Reply With Quote
Old 08-17-2017, 05:54 PM   #3
Junior Member
 
Join Date: Jul 2016
Posts: 12
The rest of the story, I had the radiator pulled and cleaned in Flagstaff, a new turbo and thermostat installed in Hurricane, UT. New coolant has been put in. I downshift to 4 the to keep RPM above 2000. We are towing a Jeep Liberty. Before rad cleaning, eng temp would get to 225, where I would pull over and let it cool down. Talked to Monaco today and was told he had no clue or who to even talk to. REV did good getting rid of all their knowledge
__________________
TGibbons is offline   Reply With Quote
Old 08-17-2017, 05:55 PM   #4
Junior Member
 
Join Date: Jul 2016
Posts: 12
I have the Leeds Neville alternator
__________________
TGibbons is offline   Reply With Quote
Old 08-19-2017, 12:57 AM   #5
YC1
Senior Member
 
YC1's Avatar


 
Holiday Rambler Owners Club
Join Date: Jun 2011
Posts: 5,481
Have you changed the voltage regulator??? Three alternators would not be intermittent. One regulator could be or a simple connection or fuse holder on it.

Have you taken any pictures of your alternator and wiring? If you have not, do so and then print them out. Then write down as many voltages as you can when it is working and when it is not. Should be easy to sort out with that information.

Throwing parts at a problem can actually inject problems into the mess. Nothing more fun than chasing down a wire that was not connected tightly or left off.

Think very hard too if you have left any slight clue out. Even if YOU do not think it is important.

For example. Were you climbing the long hill with high rpm's when the alternator acted up? Not likely but a wrong size belt could be slipping at high rpm.

Did you have headlights on or the Inverter on when you encounter alternator issues?

Some tiny tid bit or seemingly unimportant clue would often help me diagnose those miserable intermittents.

Often while discussing the issue I told my customers that it may seem I was asking the same question over and over, however it might be slightly different and then suddenly they would say, "oh yeah" this was happening too
__________________
Myron & Deborah
08 HR Endeavor 40 SKQ
2012 Ford Edge Limited FWD 3.5L
Aluminator tow bar, Demco base plate
YC1 is offline   Reply With Quote
Old 08-19-2017, 04:13 AM   #6
Senior Member
 
Join Date: Jul 2014
Posts: 9,508
Are you running the generator when this happens ?

A second charging source backfeeding thru your isolation relay can make the alternator light come on.

The warning light circuit senses higher then battery voltage at the alternator. If your charging source voltage is higher, the light can come on.

The next time it happens, turn on something, like dash air or headlight, to see it goes out.
__________________
twinboat is offline   Reply With Quote
Old 08-20-2017, 11:44 AM   #7
Junior Member
 
Join Date: Jul 2016
Posts: 12
When I have headlight switch on and dash lights, voltage drops but not enough for alarm. Turn off headlights and voltage returns to 13.8. With lights off I still get the warning. Not running the generator when this happens, but inverter is on.
__________________
TGibbons is offline   Reply With Quote
Old 08-21-2017, 03:20 PM   #8
Member
 
Join Date: Jul 2017
Location: Show Low, Arizona
Posts: 72
Following
__________________

__________________
offtosleep is offline   Reply With Quote
Reply

Tags
alternator, light



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Alternator belt and alternator replacement jimloeh Monaco Owner's Forum 7 08-15-2016 05:10 PM
False alternator light & chime Dancing Bear Monaco Owner's Forum 5 02-02-2013 10:05 AM
Alternator Light / Generator llbarfield RV Systems & Appliances 2 01-13-2011 08:08 AM
Alternator Light stays on but alternator charges augiedeg Spartan Motorhome Chassis Forum 1 10-20-2010 07:05 AM
Alternator light and chime BaldOldBob Monaco Owner's Forum 7 05-30-2010 06:34 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:29 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.