RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-17-2009, 07:04 AM   #1
Senior Member
 
SailDJ's Avatar
 
Join Date: Apr 2009
Posts: 123
Another hidden fuse question

My lights on my front drivers side slide suddenly quit. The halogen and coach lights, not the florescent ones. I checked the book and went to 51 and 52, but they were fine. This is a 2007 Holiday Rambler NeptuneXL 36. Anyone got any other ideas?

By the way Lippert Components shipped the step part I needed for $18 plus shipping. They were very helpful. I needed the part that connected the steps to the opening mechanism.

David Jarrard
__________________

__________________
David & Sharon with Tar the cat
2007 Holiday Rambler NeptuneXL 36 2002 Jeep Wrangler and 2002 HD Road King Classic Gulfport, MS
SailDJ is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-17-2009, 08:12 AM   #2
Senior Member
 
Jim Stewart's Avatar
 
Monaco Owners Club
Join Date: Nov 2008
Location: Melbourne & Marathon, Florida
Posts: 1,537
Hello,

If 51 &52 were marked front roadside slide and they appeared to be OK, test them with a tester of just replace them and see if it works. My fuse for the air dump appeared to fine, when I replaced it anyway, the air dump switch worked.
__________________

__________________
2005 Safari Cheetah 38PDQ - 2009 Ford Flex
Me (Gatogonow), The Boss (DW), Honey Bunny, Maggie May and Mollie Kay (The Gatos)!
Jim Stewart is offline   Reply With Quote
Old 06-17-2009, 09:09 AM   #3
Senior Member
 
gto19's Avatar
 
Join Date: May 2009
Posts: 132
all i can say is double check the fuses .there easy to look over
__________________
2011 tiffin 36qsp allegro bus
gto19 is offline   Reply With Quote
Old 06-17-2009, 10:44 AM   #4
Moderator Emeritus


 
Monaco Owners Club
Excel Owners Club
Join Date: Nov 2006
Location: Hangin' with Sacs and the Pins
Posts: 9,413
SailDJ...
We have a 2007 Diplomat but Fuses 50 & 51 are both spares on our coach... 49 is the correct fuse for our slide!



__________________
MM
*MonacoMama with the 2 Pins & SacsTC Nearby*
*2007 Monaco Diplomat 40' SFT<>2006 Chevy VortecMax Toad<>2006 Buick Lucerne Leading the Way*
MonacoMama is offline   Reply With Quote
Old 06-17-2009, 11:11 AM   #5
Senior Member
 
Robin_M's Avatar
 
Monaco Owners Club
Tiffin Owners Club
Join Date: May 2007
Location: SE Pennsylvania
Posts: 1,814
Blog Entries: 2
Quote:
Originally Posted by MonacoMama View Post
SailDJ...
We have a 2007 Diplomat but Fuses 50 & 51 are both spares on our coach... 49 is the correct fuse for our slide!
MM,

I'm stayin' out of this conversation. Otherwise, I'll owe you for another box of muffins. And I haven't even paid for the first box yet.
__________________
Rob.......Links to coaches below
New (to us) 2016 Tiffin Allegro Bus 45 OP
2017 & 2007 Monaco Diplomat Sites
Robin_M is offline   Reply With Quote
Old 06-17-2009, 11:16 AM   #6
Senior Member
 
bullydogs1's Avatar
 
Join Date: Apr 2007
Posts: 469
My lamps in my cable bedroom slide suddenly quit. Then when my wife pulled in the slide, it worked...Turned out to be a loose ground in the wire bundle going from coach into slide.
__________________
Stuart and Stella Denning
2016 Entegra Aspire 42RBQ
3 Bullies and a Diesel Pusher
bullydogs1 is offline   Reply With Quote
Old 06-18-2009, 11:19 PM   #7
Member
 
Join Date: Apr 2009
Posts: 41
Blog Entries: 1
Don't trust the labels. Check EVERY fuse!! If that does't work, pull the reostat down from the overhead cabinet and check the terminals for 12volt power. If there is power, start checking each light connection.
jethro is offline   Reply With Quote
Old 06-19-2009, 07:20 AM   #8
Senior Member
 
SailDJ's Avatar
 
Join Date: Apr 2009
Posts: 123
Thanks for the replies. I went to the unit yesterday and repaired the steps succeessfully but in the process, the generator stopped. When I cranked it back up there was no ac. All the outlets were hot and the charger was charging, but no power to the panel for ac or tank gauges. It was just too hot to continue so I will try to trace that and the above mentioned problem today.

I seem to be in the fix one thing, lose two more mode,

Thanks again
David Jarrard

2007 HR Neptune XL
__________________
David & Sharon with Tar the cat
2007 Holiday Rambler NeptuneXL 36 2002 Jeep Wrangler and 2002 HD Road King Classic Gulfport, MS
SailDJ is offline   Reply With Quote
Old 06-19-2009, 08:41 PM   #9
Senior Member
 
Join Date: Jul 2000
Posts: 2,724
Monaco loves to hide fuses. Like an Easter Egg hunt!! My drivers dorr awning was not working. The fuse was behind the front TV!!! The step has 3 fuses. One of them is inside the passenger armrest under the cup holder???
__________________
Moisheh
2008 Dynasty 42' Diamond IV
1988 Bluebird PT38
2009 Silverado Toad
moisheh is offline   Reply With Quote
Old 06-20-2009, 07:57 AM   #10
Senior Member
 
SailDJ's Avatar
 
Join Date: Apr 2009
Posts: 123
While adjusting the travel on the steps, I attempted to stop the steps in mid stride by hitting the battery cutoff. It didn't work, so I used the cutoof switch in the battery compartment. Later when I fired up the generator, I forgot that I had hit the original battery cutoff. When I finally realized how many things had quit I remeberred what I had done.

Now everything is working except the original lights in the slide which I have still been unable to trace down.

Thanks for the suggestions,
David
__________________
David & Sharon with Tar the cat
2007 Holiday Rambler NeptuneXL 36 2002 Jeep Wrangler and 2002 HD Road King Classic Gulfport, MS
SailDJ is offline   Reply With Quote
Old 06-20-2009, 08:24 AM   #11
Senior Member
 
Johnontheroad's Avatar
 
Monaco Owners Club
Join Date: Jan 2007
Location: Somewhere in TX/NM/AZ until spring '19
Posts: 646
My coach is new, and I'm new to it so there is a huge learning curve. Yesterday I was exploring under the panel above the speedometer and found at least two blade fuses. I have no idea what they are for (yet), but if this is typical I can see why it could be VERY hard finding a fuse if one blows....

At least on my old Travel Supreme they were all in several panels and marked.

John
__________________

__________________
2015 Entegra Aspire 44B https://my15aspire.wordpress.com/
2017 GMC Acadia Denali, M&G braking, Blue Ox
Full-timing since 2008
Johnontheroad is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Power Gear Fuse Panel Location and related question ecp3031 National RV Owner's Forum 20 03-06-2013 09:17 PM
HWH Fuse Link Q? Bounder94 MH-General Discussions & Problems 16 04-29-2008 03:24 AM
Help with fuse blowing solution LandHo Winnebago Industries Owner's Forum 10 04-26-2008 06:39 PM
Blown Fuse 15Amp in Park/Neutral Circuit paged Workhorse and Chevrolet Chassis Motorhome Forum 6 09-08-2006 05:35 AM
Dash Lights Fuse Problem infinity Workhorse and Chevrolet Chassis Motorhome Forum 4 08-15-2005 04:19 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:35 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.