RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-16-2019, 05:47 PM   #1
Member
 
Join Date: Jun 2019
Location: Detroit 60 Series 500 HP
Posts: 88
Auto leveling

I have 2008 Monaco Dynasty with Valid Air Leveling system. Never worked since we purchased it three years ago. Finally took it in to get fixed. Turns out auxiliary compressor not even there. New one installed. Coach held level for eight days before auxiliary compressor came on. Now it runs for approximately three minutes before turning off. Five minutes later it comes back on for another three minutes. Cycled like this five times before I started coach to air system up before neighbors complained. Is this normal?
__________________

2008DYN is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-16-2019, 05:58 PM   #2
Senior Member
 
96 Wideglide's Avatar
 
Holiday Rambler Owners Club
Join Date: Aug 2010
Posts: 5,237
This was leaving the system powered up, auto light flashing?

Neither sounds normal to me ... 8 days before first refilling tank, or refilling every 5 min.

Is this a Valid / Power Gear system?
__________________

__________________
Ben & Sharon
2008 43' Holiday Rambler Scepter PDQ
96 Wideglide is online now   Reply With Quote
Old 11-16-2019, 06:43 PM   #3
Senior Member
 
windsorbill's Avatar
 
Monaco Owners Club
Join Date: Jun 2011
Location: CA
Posts: 2,461
Quote:
Originally Posted by 2008DYN View Post
I have 2008 Monaco Dynasty with Valid Air Leveling system. Never worked since we purchased it three years ago. Finally took it in to get fixed. Turns out auxiliary compressor not even there. New one installed. Coach held level for eight days before auxiliary compressor came on. Now it runs for approximately three minutes before turning off. Five minutes later it comes back on for another three minutes. Cycled like this five times before I started coach to air system up before neighbors complained. Is this normal?
No, that's not normal. With coach sitting for 8 days, did the coach start to drop or did it stay level? If it stayed level, your system is pretty tight with very little leaking.

However, I'm betting the reason the compressor keeps cycling is it's plumbed wrong. I've seen several coaches, including mine, that was plumbed wrong from the factory. There is an inline check valve they put in separating the tank from the pressure sensor. it needs to be moved. It should be mounted immediately after the compressor. It's not a difficult job if you're handy.
__________________
Bill & Brigitte
06 Windsor PRQ, Cummins 400 ISL
2014 Honda CRV
windsorbill is online now   Reply With Quote
Old 11-16-2019, 08:30 PM   #4
Member
 
Join Date: Jun 2019
Location: Detroit 60 Series 500 HP
Posts: 88
Quote:
Originally Posted by 96 Wideglide View Post
This was leaving the system powered up, auto light flashing?



Neither sounds normal to me ... 8 days before first refilling tank, or refilling every 5 min.



Is this a Valid / Power Gear system?


Yes to keeping it in the auto mode with the auto light continually flashing. Valid system
2008DYN is offline   Reply With Quote
Old 11-16-2019, 08:39 PM   #5
Member
 
Join Date: Jun 2019
Location: Detroit 60 Series 500 HP
Posts: 88
Quote:
Originally Posted by windsorbill View Post
No, that's not normal. With coach sitting for 8 days, did the coach start to drop or did it stay level? If it stayed level, your system is pretty tight with very little leaking.

However, I'm betting the reason the compressor keeps cycling is it's plumbed wrong. I've seen several coaches, including mine, that was plumbed wrong from the factory. There is an inline check valve they put in separating the tank from the pressure sensor. it needs to be moved. It should be mounted immediately after the compressor. It's not a difficult job if you're handy.


Thanks for your reply. The coach did stay level. Over the past week you could hear a periodic sound of the system putting air in to keep it level. Currently we are 1600 miles from home and the Kenworth dealer who installed the new equipment. I am going to look for some help where Iím at. Thanks for the information.
2008DYN is offline   Reply With Quote
Old 11-16-2019, 09:13 PM   #6
Senior Member
 
96 Wideglide's Avatar
 
Holiday Rambler Owners Club
Join Date: Aug 2010
Posts: 5,237
Only thing I can think of, is if it was always releasing small amounts of air from select bags to keep level the first 8 days, then changed and began adding air.

Regardless, shouldn't be refilling the tank every 5 min.

Let us know if you / they, find anything.
__________________
Ben & Sharon
2008 43' Holiday Rambler Scepter PDQ
96 Wideglide is online now   Reply With Quote
Old 11-17-2019, 06:25 AM   #7
Senior Member
 
Join Date: Jun 2011
Location: USA
Posts: 432
I would bet it's the check valve installed in the wrong place. Monaco put the check valve at the tank where it does not belong, like the other poster said, move it to right at the pump and make sure the pressure switch is teed off that output line and above the pump.
__________________
Bill B
2007 Navigator, Series 60
Full-Timing since 2004
Bill767 is offline   Reply With Quote
Old 11-17-2019, 06:33 AM   #8
Senior Member
 
Monaco Owners Club
Join Date: Sep 2013
Posts: 1,623
What happens if you leave it in Manual or in Travel mode?
__________________
2007 Monaco Signature Noble III 45' ISX 600HP
hypoxia is offline   Reply With Quote
Old 11-17-2019, 08:18 AM   #9
Senior Member
 
Mr.Mark's Avatar
 
Join Date: Jun 2010
Location: CA and TN
Posts: 949
We had a 2008 Monaco Dynasty, 42 ft., Diamond IV floor-plan, air leveling and hydraulic jacks. I had never heard our pump until it was about 7 yrs. old. It was located somewhere near the front axle area.

Another thing to consider is that your airbags are probably original and might need replacing/inspecting. All of the air fittings should be inspected to make sure that they are tight.

On the Prevost site, it is recommended to replace all fittings to 'compression fittings' for a better fit (you might have those already). Chasing leaks can age a person 10 yrs.! The ole 'spray bottle with water mixed with Dawn' can be your friend.

If you ever get under your coach, make sure it is blocked so that it doesn't come down crushing you if it suddenly loses air.

Good luck,
Mark
__________________
2015 Prevost Liberty Coach, 45 ft, 4 slides, 1.5 baths, 500 hp Volvo with 1,750 lb. ft. of torque.
2017 Lincoln MKX, AWD, 2.7 V6 335 hp twin turbo
Mr.Mark is offline   Reply With Quote
Old 11-18-2019, 09:46 PM   #10
Member
 
Join Date: Jun 2019
Location: Detroit 60 Series 500 HP
Posts: 88
Quote:
Originally Posted by 96 Wideglide View Post
Only thing I can think of, is if it was always releasing small amounts of air from select bags to keep level the first 8 days, then changed and began adding air.



Regardless, shouldn't be refilling the tank every 5 min.



Let us know if you / they, find anything.


Thanks for your reply. I will post once I find out what the problem is.
2008DYN is offline   Reply With Quote
Old 11-18-2019, 09:51 PM   #11
Member
 
Join Date: Jun 2019
Location: Detroit 60 Series 500 HP
Posts: 88
Quote:
Originally Posted by hypoxia View Post
What happens if you leave it in Manual or in Travel mode?


I have had to turn the system off now to keep the auxiliary pump from acting up. Until I get this fixed I will just air it up manually periodically. Where Iím at is practically a level pad anyway. Thanks for responding.
2008DYN is offline   Reply With Quote
Old 11-18-2019, 10:04 PM   #12
Member
 
Join Date: Jun 2019
Location: Detroit 60 Series 500 HP
Posts: 88
Quote:
Originally Posted by Mr.Mark View Post
We had a 2008 Monaco Dynasty, 42 ft., Diamond IV floor-plan, air leveling and hydraulic jacks. I had never heard our pump until it was about 7 yrs. old. It was located somewhere near the front axle area.

Another thing to consider is that your airbags are probably original and might need replacing/inspecting. All of the air fittings should be inspected to make sure that they are tight.

On the Prevost site, it is recommended to replace all fittings to 'compression fittings' for a better fit (you might have those already). Chasing leaks can age a person 10 yrs.! The ole 'spray bottle with water mixed with Dawn' can be your friend.

If you ever get under your coach, make sure it is blocked so that it doesn't come down crushing you if it suddenly loses air.

Good luck,
Mark


I requested the Kenworth dealer my RV dealer takes coaches to for chassis work check all the fittings for leaks. They assured me they did. Before the latest work was done I was not willing to get up and under the coach for the exact reason you mentioned. I know exactly where the new pump is. I will check to see if the check valve was placed in the wrong location. Iím far away from home and all my tools. Probably will have to pay for on site repair. Just want to know what the problem is before looking for someone. Thanks for replying.
2008DYN is offline   Reply With Quote
Old 11-19-2019, 06:38 AM   #13
Senior Member
 
Monaco Owners Club
Join Date: Sep 2013
Posts: 1,623
Quote:
Originally Posted by 2008DYN View Post
I have had to turn the system off now to keep the auxiliary pump from acting up. Until I get this fixed I will just air it up manually periodically. Where Iím at is practically a level pad anyway. Thanks for responding.
The FRB should have a self resetting CB or fuse to turn the pump off. I haven't used my pump for quite some time as it always seems to come on at 2 AM.

Does the coach stay level when manual is selected? Travel Mode? I'm just wondering what is working and what is not.

__________________
2007 Monaco Signature Noble III 45' ISX 600HP
hypoxia is offline   Reply With Quote
Old 11-20-2019, 09:50 PM   #14
Member
 
Join Date: Jun 2019
Location: Detroit 60 Series 500 HP
Posts: 88
Quote:
Originally Posted by hypoxia View Post
The FRB should have a self resetting CB or fuse to turn the pump off. I haven't used my pump for quite some time as it always seems to come on at 2 AM.



Does the coach stay level when manual is selected? Travel Mode? I'm just wondering what is working and what is not.





Just got off the phone with the Kenworth dealer who installed the system. The reason the compressor doesnít turn off when I remove any one of my four auto leveling fuses is because the tech wired it by passing the drivers side fuse box. He installed a new dedicated wire with an in-line fuse directly behind the fuse box. I found it and will pull the fuse next time it goes on and wonít shut off.
The coach also doesnít stay level in travel mode. According to Kenworth I need a ride height control module. They tried twice to get Rev Group to return their calls in order to track down this part but never got a call back.
As far as in the manual mode Iím not sure. When the compressor was going off and wouldnít stop I put the system in the manual mode thinking it would stop. It didnít. I now have the system off and just waiting to see what happens. Thanks for responding. Any other advice would be welcomed.
__________________

2008DYN is offline   Reply With Quote
Reply

Tags
leveling



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
To auto-level or not to auto-level.....That is the question HatrackRV Class A Motorhome Discussions 39 05-12-2018 05:09 PM
Power Gear leveling system not AUTO leveling coach to true level ualdriver MH-General Discussions & Problems 6 08-17-2016 06:48 PM
Auto Park Light - Coach doesn't have auto park! bvaughn4 Workhorse and Chevrolet Chassis Motorhome Forum 14 04-04-2015 10:29 PM
Lippert Auto Leveling Power Pac. Follow on to Lippert Leveling pump Smoking. IMDSailor MH-General Discussions & Problems 4 06-22-2012 06:50 AM
Auto Leveling System Malfunction - Now Jacks Loud JavaJelly Spartan Motorhome Chassis Forum 10 12-16-2006 12:01 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:05 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×