RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-11-2019, 03:56 PM   #1
Senior Member
 
gnlandrus's Avatar
 
Monaco Owners Club
Join Date: May 2015
Location: Reno, NV
Posts: 316
Black tank sensors not reading

I have a 08 Camelot 42 PDQ. Suddenly, the sensors on the black tank have quit working. Grey tank sensors are working fine.
Donít think they are dirty because the were working on the last trip, and I just made a sprayer that I put down the toilet and sprayed it throughly without any luck.
Guess the next step is to remove The dreaded white wall in the wet bay and try to find and test the sensors.
As always, any ideas are appreciated!
Thanks,
Greg
__________________

__________________
Greg & Marsha
2008 Monaco Camelot 42PDQ
2016 Cadillac SRX Toad & 2014 Jeep Wrangler Sahara Unlimited Toad.
gnlandrus is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-11-2019, 07:32 PM   #2
Senior Member
 
Ray,IN's Avatar
 
Join Date: Aug 2001
Location: North America somewhere
Posts: 17,282
I'm not sure, but I seem to remember reading a thread that said there is a fuse and adjustment pots behind the readout panel, cannot remember what make/model.
__________________

__________________
2000 Winnebago Ultimate Freedom USQ40JD, ISC 8.3 Cummins 350, Spartan MM Chassis. USA IN 1SG 11B5MX retired;Good Sam Life member,FMCA." My fellow Americans, ask not what your country can do for you, ask what you can do for your country. John F. Kennedy
Ray,IN is online now   Reply With Quote
Old 09-11-2019, 08:04 PM   #3
Senior Member
 
gnlandrus's Avatar
 
Monaco Owners Club
Join Date: May 2015
Location: Reno, NV
Posts: 316
Ray, that would be great.
__________________
Greg & Marsha
2008 Monaco Camelot 42PDQ
2016 Cadillac SRX Toad & 2014 Jeep Wrangler Sahara Unlimited Toad.
gnlandrus is offline   Reply With Quote
Old 09-11-2019, 08:36 PM   #4
Senior Member
 
Jobert's Avatar
 
Monaco Owners Club
Fleetwood Owners Club
Join Date: Mar 2009
Posts: 304
Not to familiar with your unit, but our tanks have only one sensor made by CatCon, in the bottom of each tank, connected by a Telephone cable. If you empty the tank and then remove the sensor, try rinsing it out or flushing it. There is a very thin membrane in the sensor so be carefully not to stick anything down in there and rupture the membrane. If this is the setup you have, new sensors are available from Catcon on line in the $50 range. Like I said, you may or may not have this setup, not familiar with your rig. Hope this may help. Happy Trails Bert
__________________
2006 Monaco Dynasty Diamond IV 42' Tag, ISL 400, Residential Refrig, 10KW Onan, Bosch Washer/220V Dryer (previously 2003 American Tradition 40W)
Jobert is offline   Reply With Quote
Old 09-11-2019, 09:14 PM   #5
Senior Member
 
Join Date: Apr 2018
Posts: 330
Look at a garnet see level with blue tooth. Simple, way more accurate, mounts to the outside of the tanks.
shootist is offline   Reply With Quote
Old 09-11-2019, 10:15 PM   #6
Senior Member
 
vito.a's Avatar
 
Monaco Owners Club
Join Date: Oct 2009
Location: Tucson, AZ
Posts: 3,599
Jobert is correct. Find the gray RJ11 telephone cable in the wet bay and follow it to the sensor. The sensor will be near the bottom of the tank on either side. You will see the black sensor with the telephone cable plugged into it. The sensor is just over 1" dia on the hex and the threads are 3/4"npt.

I've tried to clean sensors, but the membrane is delicate and I've not been successful.
Link to new sensors:
https://shop.catconproducts.com/prod...5&categoryId=2
Northwest RV Supply carry's them also:
Aladdin Tank Sensor 16622728: nwrvsupply.com

The Aladdin system does not have adjustment pots. You will need to set the sensor calibration both with the tank empty, and then full. You do this on your Aladdin video display. See the attached guide.
Let me know if you have any questions?
Attached Files
File Type: pdf Aladdin Troubleshooting Guide[1].pdf (1.68 MB, 1 views)
__________________
97 Monaco Windsor- Sold
07 Monaco Executive McKinley- Sold
04 Monaco Signature Chateau IV
vito.a is online now   Reply With Quote
Old 09-12-2019, 01:03 AM   #7
Senior Member
 
Happycarz's Avatar
 
Monaco Owners Club
Join Date: Sep 2007
Location: Scottsdale, AZ
Posts: 1,939
What does the tank monitor in the wet read? Is it the same as the inside tank monitor?

I was the one that posted about adjusting the gray and black tank pots on the back of the monitor board. Two of us that did adjust the pots had only a short term fix, like very short.

If both monitors donít read the black tank, then look at tank sensors and wiring. If one reads OK, then it is a bad monitor board on the one that doesnít read the black tank.

Both the inside and outside monitor boards are the same, even though the monitors themselves are different.
__________________
Harry

2008 Monaco Camelot 40' PDQ
Happycarz is offline   Reply With Quote
Old 09-12-2019, 07:46 AM   #8
Senior Member
 
gnlandrus's Avatar
 
Monaco Owners Club
Join Date: May 2015
Location: Reno, NV
Posts: 316
Thank you all !!! Both monitors illuminate only the empty light so I guess itís a bad sensor. Now, I have to see if I can access the sensor without removing the white wall in the wet bay 🤞🤞.
I will report what I find.
Thanks!
__________________
Greg & Marsha
2008 Monaco Camelot 42PDQ
2016 Cadillac SRX Toad & 2014 Jeep Wrangler Sahara Unlimited Toad.
gnlandrus is offline   Reply With Quote
Old 09-12-2019, 09:48 AM   #9
Senior Member
 
vito.a's Avatar
 
Monaco Owners Club
Join Date: Oct 2009
Location: Tucson, AZ
Posts: 3,599
This is a picture of two bad sensors, and one new one on the left. They get clogged up with stuff. I now use blue Dawn dish soap to clean the tanks regularly and only use the Scott rapid disolving RV toilet paper from Walmart.

When you change the sensor, wrap it well with Teflon tape and put it in hand tight plus 1/4 turn.
Attached Thumbnails
Click image for larger version

Name:	Tank sensors.jpg
Views:	5
Size:	128.6 KB
ID:	260096  
__________________
97 Monaco Windsor- Sold
07 Monaco Executive McKinley- Sold
04 Monaco Signature Chateau IV
vito.a is online now   Reply With Quote
Old 09-12-2019, 11:44 AM   #10
Senior Member
 
gnlandrus's Avatar
 
Monaco Owners Club
Join Date: May 2015
Location: Reno, NV
Posts: 316
Thanks Vito ! Shall do. I have a tendency to over tighten EVERYTHING! I will be careful.
__________________
Greg & Marsha
2008 Monaco Camelot 42PDQ
2016 Cadillac SRX Toad & 2014 Jeep Wrangler Sahara Unlimited Toad.
gnlandrus is offline   Reply With Quote
Old 09-12-2019, 02:12 PM   #11
Senior Member
 
loranimal's Avatar
 
Join Date: Nov 2004
Location: Fallon - NV / St.Paul Island AK
Posts: 311
Quote:
Originally Posted by vito.a View Post
When you change the sensor, wrap it well with Teflon tape and put it in hand tight plus 1/4 turn.

When working with plastic fittings I have found it is better to use TFE Paste instead of tape. You are less likely to split the female fitting.


Carl
__________________

__________________
Carl & Barb - 2006 Monaco Signature - Commander
loranimal is offline   Reply With Quote
Reply

Tags
black tank, tank



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Holding tank sensors not reading Smaay Monaco Owner's Forum 5 03-22-2019 07:08 PM
Gray tank sensors reading incorrectly dnhxx Newmar Owner's Forum 14 12-01-2018 06:27 AM
Temperature Sensors/Tank Sensors bcruzen Alpine Coach Owner's Forum 7 08-29-2017 11:56 AM
Infrared sensors not reading signal from BluRay or Directv remotes mketron Technology: Internet, TV, Satellite, Cell Phones, etc. 2 10-31-2012 10:20 AM
Sensors reading Black Tanks Gypsies2 Monaco Owner's Forum 11 05-31-2007 11:06 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:32 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.