Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-28-2011, 08:09 PM   #1
Senior Member
 
crah's Avatar
 
Join Date: Sep 2011
Location: Las Vegas
Posts: 692
correct boost for ISC 350

What's the correct max boost for the stock ISC 350? Mine seems to max out at about 25psi on both my stock analog gauge as well as the banks analog gauge. I have a full banks system on mine and have no previous history to compare performance.
__________________

__________________
Craig 2003 Holiday Rambler Scepter 36PST
RR8S 350 Cummins ISC with Banks
2011 Buick Enclave Towed with Readybrute
crah is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-28-2011, 08:33 PM   #2
Senior Member
 
Mr_D's Avatar
 
Solo Rvers Club
iRV2 No Limits Club
Join Date: May 2011
Location: Vancouver, WA
Posts: 28,543
Stock is about 24-25 psi
On our ISC 350 with the Power Pack I see 34-35psi on the Banks gauge. My VMSpc I only show 24-25 even though the software is set for the Banks kit. Someone said I need to reset the max gauge reading in VMSpc but I haven't done it yet.
__________________

__________________
2009 45' Magna 630 w/Cummins ISX 650 HP/1950 Lbs Ft
Charter Good Sam Lifetime Member, FMCA, SKP
RV'ing since 1957, NRA Benefactor Life, towing '14 CR-V
Mr_D is online now   Reply With Quote
Old 11-28-2011, 09:55 PM   #3
Senior Member
 
crah's Avatar
 
Join Date: Sep 2011
Location: Las Vegas
Posts: 692
Quote:
Originally Posted by Mr_D View Post
Stock is about 24-25 psi
On our ISC 350 with the Power Pack I see 34-35psi on the Banks gauge. My VMSpc I only show 24-25 even though the software is set for the Banks kit. Someone said I need to reset the max gauge reading in VMSpc but I haven't done it yet.
Thanks for the info. I've never seen it beyond 25psi so I'm guessing I have some problems. I do know that my lights in the main box work, and my gauges are consistant, so I'm thinking my gauges work fine as well. Not sure where to even begin. I guess I could run the engine and check for leaks at the turbo area. Any suggestions on narrowing down the trouble shooting?
__________________
Craig 2003 Holiday Rambler Scepter 36PST
RR8S 350 Cummins ISC with Banks
2011 Buick Enclave Towed with Readybrute
crah is offline   Reply With Quote
Old 11-28-2011, 10:58 PM   #4
Senior Member
 
CJScepter's Avatar
 
Monaco Owners Club
Join Date: Sep 2008
Location: McCleary,wa
Posts: 316
boost leak

I would start by checking each clamp from the turbo to the intake. I had a boost leak on my previous 99 Monaco Banks equipted ISB, I went to Home Depot and got some pipe plugs that fit the hoses at the turbo output and at the intake to the engine, also went to auto store and got a steel air valve used in tubless tires. I drilled one plug and bolted the valve to it and put about 20 lbs. air to boost pipe. This ckecks from turbo thru cac to intake. You won't be able to hear anything with engine running and it won't make boost at an idle. I found a small leak at a clamp but only upped boost accuple of pounds. My trouble was the O-ring gasket from the turbo to the output housing, IT WAS NOT THERE! That was a 10-12 LB. loss. Also my exhaust temp would run high on all grades, had to always back off on the throttle, and would get some black smoke out the tailpipe when I floored it! If you are getting exhaust temps of more than 1250-1300 get it fixed ASAP, if staying below 1200 you probably won't burn a hole in a piston anyway. When fixed the boost went from 23 lbs. to 35 and EGT never to 1200 again!
Good Luck!
John G.
__________________
John and Cherrie
2003 Holiday Rambler Scepter 40DST
Pushed By 2003 Ford Explorer
CJScepter is offline   Reply With Quote
Old 11-28-2011, 11:10 PM   #5
Senior Member
 
Lug_Nut's Avatar


 
Join Date: May 2005
Location: British Columbia
Posts: 3,708
I had an '02 Newmar Dutch Star with a 350 ISC. I got a constant 23 PSI boost pressure for some 20k miles. I then changed my engine oil to Cummins recommended synthetic oil, Valvoline 100% syn. After running a thousand miles more or so, I got a contant 28 PSI. That remained for the duration of the coach.

Peter
__________________
'13 King Aire ISX 600
'16 Jeep Wrangler 75th Anniversary Edition
Lug_Nut is offline   Reply With Quote
Old 12-20-2011, 12:28 PM   #6
Member
 
mak1's Avatar
 
Monaco Owners Club
Join Date: Oct 2011
Location: Florence, Or.
Posts: 75
Setting up coach

This may sound lame but I need some firm info on the set up proceedure for my coach. I just purchased a 2002 Monaco Diplomat 38pst 3 slide(what does PST stand for?). While reading the manual, I find bits and pieces of info like, make sure key is off when opening the kitchen slide, but no others are apparent. So my question is: How do you do it...in and out, in order. Air bags, slides and levelers....I have always had a 5th wheel and it was simple.
__________________
mak1 is offline   Reply With Quote
Old 12-20-2011, 12:30 PM   #7
Member
 
mak1's Avatar
 
Monaco Owners Club
Join Date: Oct 2011
Location: Florence, Or.
Posts: 75
Sorry, didn't mean to post this here
__________________
mak1 is offline   Reply With Quote
Old 12-20-2011, 02:49 PM   #8
Moderator Emeritus
 
Mike Canter's Avatar


 
Join Date: Apr 2008
Location: Freeport, ME
Posts: 4,707
Crah, the perfect EGT for a diesel under max load is 1300* F. That means everything is OK especially with a Banks kit. A diesel is reversed to a gasoline motor in that if you increase the fuel to a diesel engine then the EGT will increase. A gasoline motor is opposite and this confuses people. Banks tries to set them up that if you are climbing and making max boost then 1300* and maybe 1330* if a real long steep hill for a short time. In that case you let up a little or downshift it. If too low of an EGT then you get too little of an exhaust flame and you will not spin up the turbo so no big increase in boost. I worked on one with a Banks kit MH and could not make boost and the EGTs remained at 1200*. Finally installed new fuel filters and suddenly got more fuel so more more boost. Can you read the EGT on your motor and tell us what the max is under max load? Banks is very helpful in troubleshooting the system if you give them a call. All the manuals and installation guides are on line and can be downloaded.
__________________
Mike Canter
"Gunner" USN Retired, Airdale
2004 Monaco Signature 44' Conquest. Detroit 60
Mike Canter is offline   Reply With Quote
Old 04-11-2012, 11:25 AM   #9
Senior Member
 
crah's Avatar
 
Join Date: Sep 2011
Location: Las Vegas
Posts: 692
Quote:
Originally Posted by Mike Canter View Post
Crah, the perfect EGT for a diesel under max load is 1300* F. That means everything is OK especially with a Banks kit. A diesel is reversed to a gasoline motor in that if you increase the fuel to a diesel engine then the EGT will increase. A gasoline motor is opposite and this confuses people. Banks tries to set them up that if you are climbing and making max boost then 1300* and maybe 1330* if a real long steep hill for a short time. In that case you let up a little or downshift it. If too low of an EGT then you get too little of an exhaust flame and you will not spin up the turbo so no big increase in boost. I worked on one with a Banks kit MH and could not make boost and the EGTs remained at 1200*. Finally installed new fuel filters and suddenly got more fuel so more more boost. Can you read the EGT on your motor and tell us what the max is under max load? Banks is very helpful in troubleshooting the system if you give them a call. All the manuals and installation guides are on line and can be downloaded.
Mike, it looks like I was a culprit of starting a thread and never getting back to it. I hate when that happens with OP's, but I've become one of them. I'm sorry I never got back to you on this. I must have not hit the send reminder email when someone else responds. As to your question, my temp gets to about 1300 on full throttle up long grades. The banks kit will shut it down if it exceeds that temp for any length of time. (my observation). I've checked all the connections as others have suggested, but never got to the point of hooking up an external pressure method (hate to have to do this if I don't have to). My annual oil/filter service is due this month so that will be done shortly. It could possibly be my air filter as I have not serviced that and don't know when it was done. I have another post over at rv.net on cleaning the AFE washable filter. My boost has never gone above 24-25 psi on both my analog boost gauges (stock and banks gauge). Perhaps air is the problem. My filter minder is too beat up to see what it says, but the actual gauge portion hasn't moved in over a year.
__________________

__________________
Craig 2003 Holiday Rambler Scepter 36PST
RR8S 350 Cummins ISC with Banks
2011 Buick Enclave Towed with Readybrute
crah is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Battery boost not working Den Monaco Owner's Forum 6 01-12-2010 11:01 AM
1999 isc 330 hp no boost pressure diceman1530 Cummins Engines 16 10-29-2009 08:47 AM
06' HR Ambassador ISC 330 Boost Alarm bredden Monaco Owner's Forum 5 09-06-2009 08:55 AM
loss of boost Sixpack98 Monaco Owner's Forum 5 07-05-2009 12:22 PM
Boost Gauge Toby Monaco Owner's Forum 5 05-20-2007 07:26 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:53 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.