Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-05-2017, 12:08 PM   #1
Junior Member
 
R Whit's Avatar
 
Monaco Owners Club
Join Date: Mar 2017
Location: Terrebonne Oregon
Posts: 6
Dash Gauges

Have a 93 Monaco Dynasty, when starting engine the dash gauges all start to jump around, also the power to leveling system and back up camera has stopped working, any help appreciated, R Whit
__________________

__________________
R Whit is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-05-2017, 12:35 PM   #2
Senior Member/RVM #90
 
MSHappyCampers's Avatar


 
Monaco Owners Club
Join Date: Nov 2002
Location: Columbus, MS
Posts: 24,956
Whit, since you say that ALL the gauges jump around, that sounds to me like a bad ground connection!
__________________

__________________
Joe & Annette

2002 Monaco Windsor 40PBT, 2013 Honda CRV AWD
MSHappyCampers is offline   Reply With Quote
Old 04-05-2017, 12:49 PM   #3
Senior Member
 
distaff's Avatar
 
Join Date: Dec 2009
Posts: 1,176
On my much later coach I once pulled the batteries and failed to connect one white wire to the ground side and all my gauges were wonky. The wire was actually labelled "Instrument Ground" - printed on the wire itself.

Connected it and everything went back to normal.
__________________
Paul
2006 Patriot Thunder C13 Allison 4000
2010 Ford Flex Ecoboost AWD
distaff is offline   Reply With Quote
Old 04-06-2017, 12:53 PM   #4
Senior Member
 
10Boomer's Avatar
 
Join Date: May 2012
Posts: 1,916
Sounds like a bad ground for sure.
__________________
Perry & Julie: 2008 Monaco Camelot 40PDQ, 400ISL, Toad; 2015 Chevy Equinox.
[SIGPIC][/SIGPIC]
10Boomer is offline   Reply With Quote
Reply

Tags
dash, gauges



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dash lights on, gauges jump. Low voltage to dash. bobioknight RV Systems & Appliances 3 05-11-2013 10:55 PM
Dash Gauges Inop haverly MH-General Discussions & Problems 4 04-20-2009 06:52 AM
dash gauges inop including tach Knot-Fly'n MH-General Discussions & Problems 7 10-28-2008 12:46 PM
dash gauges inop Knot-Fly'n Newmar Owner's Forum 4 10-28-2008 12:31 PM
Engine Shutdown - All Dash Gauges Dead Traveling Raven Alpine Coach Owner's Forum 2 07-20-2008 12:59 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:03 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.