RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-16-2019, 11:02 AM   #1
Member
 
bigjon42's Avatar
 
Join Date: Feb 2017
Posts: 85
Generator problems Help !!

Set out on a trip yesterday, stopped at a rest stop and it was getting warm so started the generator. after 1 minute it quit. restarted, after 1 min it quit. 99 Monaco executive, 10 kw onan. fuel tank is full, ran fine a month ago. When it quits I get a 3 blinking light sequence. ( needs service) No sub-code when I hold down stop button. Turned around and came home. No generator, no trip. Started it again this morning from the extended generator, same results. After 3rd or forth start, at 40 seconds if shakes and smokes, keeps running another 40 seconds, does it again, then 40 seconds later it dies. same 3 blinks, NO sub-code. I started it again, then shut the 45 amp breaker on the Gen. It continued running no problem for 10 min. I then turned the breaker on and 45 seconds later it dies. It appears the when the transfer switch engages that's when it pukes. Fuel filter ? Also, it starts instantly. New to Onan diesel generators. Jon..
__________________

__________________
Bigjon & Sandi
99 Monaco Executive M-450
2002 Suzuki Toad.
bigjon42 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-16-2019, 11:06 AM   #2
Senior Member
 
distaff's Avatar
 
Join Date: Dec 2009
Posts: 1,718
Big Jon,

Sorry for your problems, but post your generator model. Better info = better help.
__________________

__________________
Paul
2006 Patriot Thunder C13 Allison 4000
2010 Ford Flex Ecoboost AWD
distaff is offline   Reply With Quote
Old 08-16-2019, 11:10 AM   #3
Member
 
bigjon42's Avatar
 
Join Date: Feb 2017
Posts: 85
Did say 10 kw Onan, but model # is HDCAA. Jon
__________________
Bigjon & Sandi
99 Monaco Executive M-450
2002 Suzuki Toad.
bigjon42 is offline   Reply With Quote
Old 08-16-2019, 11:11 AM   #4
Senior Member
 
gpounder's Avatar


 
Join Date: Nov 2017
Location: Oakhurst, CA
Posts: 356
Someone else had similar problem, I think if was fixed by reconnecting the wiring harness.
__________________
2007 Country Coach Tribute 260 Sequoia
40' DP w/Cat400, F494513
Live next to Yosemite
Tror Fourwinds Class C, 1961 American Eagle 01 Bus
gpounder is offline   Reply With Quote
Old 08-16-2019, 11:22 AM   #5
Senior Member
 
Join Date: Jul 2014
Posts: 19,099
If it runs with the breaker off and dues out when you add any kind of load, I would suspect and replace the fuel filter.
twinboat is online now   Reply With Quote
Old 08-16-2019, 11:42 AM   #6
Member
 
bigjon42's Avatar
 
Join Date: Feb 2017
Posts: 85
Thanks guys, I am going to replace the fuel filter today, will report back.
__________________
Bigjon & Sandi
99 Monaco Executive M-450
2002 Suzuki Toad.
bigjon42 is offline   Reply With Quote
Old 08-16-2019, 12:08 PM   #7
Senior Member
 
distaff's Avatar
 
Join Date: Dec 2009
Posts: 1,718
Quote:
Originally Posted by bigjon42 View Post
Did say 10 kw Onan, but model # is HDCAA. Jon
That is what I was looking for - lots of models under the "10K" name. Sorry can't help with manuals, I have the HDKCA manuals. I did find an HDCAA manual on line and the code reading procedure is the same as the HDKCA - three blinks indicate a service fault. The manuals says to "Press Stop Once" and note the next sequence of blinks pause blinks. You can press "Stop" 3 times within 3 seconds to restore the fault reporting.

Since you say "no sub-code reported when I hold down stop button" you tried this, but I note that you said "hold stop down", which is not the procedure in the manual. Not sure if you actually did that, or if you just pressed it and released it.
__________________
Paul
2006 Patriot Thunder C13 Allison 4000
2010 Ford Flex Ecoboost AWD
distaff is offline   Reply With Quote
Old 08-16-2019, 12:17 PM   #8
Senior Member
 
znt1186's Avatar
 
Join Date: Nov 2014
Posts: 774
Please note that some manufacturers also added an inline fuel filter in addition to the filter on the generator itself. I would trace the fuel line from the generator to determine if there is an additional inline filter or not.
__________________
Zeb and Teena
2005 Mandalay, 2013 Ford Edge
znt1186 is online now   Reply With Quote
Old 08-16-2019, 01:32 PM   #9
Community Moderator
 
barmcd's Avatar


 
Monaco Owners Club
Texas Boomers Club
Join Date: Nov 2015
Location: Central Texas
Posts: 10,413
I have the Onan filter in the bottom of the generator and a Parker filter on the back of the generator.
__________________
Dennis and Katherine
2000 Monaco Dynasty
barmcd is online now   Reply With Quote
Old 08-16-2019, 01:41 PM   #10
Senior Member
 
RamiDav's Avatar
 
Join Date: Jan 2016
Posts: 1,305
My 7.5 Onan acted similarly and the water pump belt was broken .
It ran a few min at first then would start and die from over heating

Ray
03 Windsor
RamiDav is offline   Reply With Quote
Old 08-16-2019, 02:00 PM   #11
Registered User
 
tomgagne's Avatar
 
Join Date: Mar 2009
Location: Abington, Ma
Posts: 170
Here is a good video for reading the code.
__________________
2002 Diplomat 38 PDD ISC330
tomgagne is offline   Reply With Quote
Old 08-16-2019, 02:28 PM   #12
Member
 
bigjon42's Avatar
 
Join Date: Feb 2017
Posts: 85
Good Video ! I had called Cummins when it happened and he said to 'hold' the stop button down for 3 seconds. I got nothing. I will try the procedure in the video and see what happens. Thanks !
__________________
Bigjon & Sandi
99 Monaco Executive M-450
2002 Suzuki Toad.
bigjon42 is offline   Reply With Quote
Old 08-16-2019, 02:42 PM   #13
Senior Member
 
distaff's Avatar
 
Join Date: Dec 2009
Posts: 1,718
Quote:
Originally Posted by bigjon42 View Post
Good Video ! I had called Cummins when it happened and he said to 'hold' the stop button down for 3 seconds. I got nothing. I will try the procedure in the video and see what happens. Thanks !
Do you have the manual? You'll need it to decipher the code. Here is a link to one online - see page 20. Very clear - while the first level code is blinking press stop once and release.

Once the code has stopped (it stops after 5 minutes and here is where I think you and Cummins crossed wires) press stop THREE TIMES in five seconds to start it again, then press stop once to read the second level code.
__________________
Paul
2006 Patriot Thunder C13 Allison 4000
2010 Ford Flex Ecoboost AWD
distaff is offline   Reply With Quote
Old 08-16-2019, 02:50 PM   #14
Senior Member
 
vito.a's Avatar
 
Monaco Owners Club
Join Date: Oct 2009
Location: Tucson, AZ
Posts: 3,699
Onan 10.0 and 12.5KW diesel generators use the same fuel filter as the old 1988 GMC 6.2L diesel.
It looks like a rectangular box. Make sure you break the fuel lines loose before you unbolt the filter. Then, make sure you start the fuel line fittings before you bolt down the new filter.
https://www.rockauto.com/en/moreinfo...145258&jsn=742
I also have the NGK glow plug part number if anyone needs it. They are 1/4 the cost of the Cummins Onan glow plug.
__________________

__________________
97 Monaco Windsor- Sold
07 Monaco Executive McKinley- Sold
04 Monaco Signature Chateau IV
vito.a is offline   Reply With Quote
Reply

Tags
ems, generator, problem, problems



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
A/C Problems with heavy condensation problems Help Please!! Tevans Newmar Owner's Forum 6 06-21-2015 08:26 AM
Help, need your wisdom!! Onan Generator problems, code 31 revolution MH-General Discussions & Problems 11 12-17-2014 10:47 PM
Generator problems. Need some help please. Hunted Duck RV Systems & Appliances 15 07-25-2014 09:00 AM
Help, Help, Help, Oh Please Help. Possum RV Systems & Appliances 11 04-23-2012 10:35 PM
Leaking problems with Hybrid anyone else have problems? Barrie Expandables, Hybrids, & Lightweights Discussion 2 11-20-2005 08:08 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:02 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×