RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-14-2013, 09:36 AM   #1
Senior Member
 
itdave's Avatar
 
Monaco Owners Club
Holiday Rambler Owners Club
Join Date: Jul 2006
Location: Cornville, AZ
Posts: 1,079
Intellitec 50 amp Smart EMS Failure

My front roof AC quit working so I traced the problem and found that there was no power coming from the EMS board. I opened the circuit breaker panel and found that power was getting to the EMS board but the relay was not engaging so no output. I know I can find a replacement board at about $350 but I am hoping I can find a relay. Has anyone replaced a relay on the Smart EMS board if so where did you find a replacement relay.
__________________

__________________
Dave & Jeri
06 Holiday Rambler Endeavor
TOAD 11 Honda CRV
itdave is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-14-2013, 09:46 AM   #2
Senior Member/RVM #90
 
MSHappyCampers's Avatar


 
Monaco Owners Club
Join Date: Nov 2002
Location: Columbus, MS
Posts: 39,744
Hi Dave! Sorry but I can't help you on that one. The display that shows the current being drawn doesn't work part of the time on my unit. So far no problem on getting power out of it though!
__________________

__________________
Joe & Annette

2002 Monaco Windsor 40PBT, 2013 Honda CRV AWD
MSHappyCampers is online now   Reply With Quote
Old 11-14-2013, 09:58 AM   #3
YC1
Senior Member
 
YC1's Avatar


 
Holiday Rambler Owners Club
Join Date: Jun 2011
Posts: 7,089
Get a flashlight and magnifying glass to see if there is a number on the relay. Then try Digi Key for a replacement,.
__________________
Myron & Deborah
08 HR Endeavor 40 SKQ
2012 Ford Edge Limited FWD 3.5L
Aluminator tow bar, Demco base plate
YC1 is offline   Reply With Quote
Old 11-17-2013, 09:14 PM   #4
Senior Member
 
observer's Avatar
 
Monaco Owners Club
Join Date: Dec 2008
Posts: 161
I had a similar problem with my '07 Endeavor. If you remove the circuit boards from the EMS unit and inspect the backside of the relay board you will probably find that the circuit board traces have overheated and no longer contact the pins of the relay. I soldered some 14ga. wire in parallel with the trace and fixed my problem.
__________________
Dennis Codella
2007 HR Endeavor 40PDQ
observer is offline   Reply With Quote
Old 11-18-2013, 07:24 AM   #5
Senior Member
 
Join Date: Jul 2000
Posts: 2,904
Intellitec does not provide any parts nor will they give you any part numbers. I had the cover off my EMS and I remember seeing part #'s on the relays. We were in a CG in Q and I had no power. One of my neighbors was an electrical engineer and he wired around the relays. Turns out that the EMS was simply doing it's job. Something was wrong with the incoming power and it tripped the relays. Never had that problem again. If mine goes I will install the equivalent surge guard. Lifetime warranty and a far better built device. They even have tech support.
__________________
Moisheh
2008 Dynasty 42' Diamond IV
1988 Bluebird PT38
2009 Silverado Toad
moisheh is online now   Reply With Quote
Old 11-18-2013, 07:38 AM   #6
Senior Member
 
mdc99's Avatar
 
Join Date: Apr 2011
Location: Florida
Posts: 277
I had a similar problem when a lightning strike hit the transformer right next to my rig. In my case, as I recall, one circuit controlled both A/Cs. Since I am always on 50amp or generator service, I just bypassed the board while I keep my eye out for a replacement.
__________________
"weekend tailgater" 2003 Fleetwood Revolution 40C, 2Vino Scooters hitch rack or H-D FLSTC & XL1200 So. Ga. Cargo Enclsd Trailer-Prodigy wireless brake controller
mdc99 is offline   Reply With Quote
Old 11-19-2013, 09:21 PM   #7
Senior Member
 
Gordon66's Avatar
 
Monaco Owners Club
Thor Owners Club
Ford Super Duty Owner
Join Date: Dec 2006
Location: Victoria, Texas
Posts: 241
I replaced my 4 relays last year. Got them from Mouser Electronics Mouser Electronics - Electronic Components Distributor. Part number 635-G8P1A4PVDDC12OZ Power PCB Relay $2.91 each. Also ordered the the 2 on the opposite side Part number 653-G5LE-14-DC12 $1.90 each. The secret to replacing is to remove them with a de-soldering iron from Radio shack.
__________________
Larry & Doni
2015 Four Winds 31W E-450
South Texas Renegades FMCA F376075
Gordon66 is offline   Reply With Quote
Old 11-20-2013, 09:37 AM   #8
Senior Member
 
itdave's Avatar
 
Monaco Owners Club
Holiday Rambler Owners Club
Join Date: Jul 2006
Location: Cornville, AZ
Posts: 1,079
Thanks Larry,
I order 4 and 2 just like you. There is an error in the first part number it should be 653 not 635. So the correct part number is 653-G8P1A4PVDDC12OZ. Did you do all 4 because they had failed or just out of caution?
__________________
Dave & Jeri
06 Holiday Rambler Endeavor
TOAD 11 Honda CRV
itdave is offline   Reply With Quote
Old 11-20-2013, 08:49 PM   #9
Senior Member
 
Gordon66's Avatar
 
Monaco Owners Club
Thor Owners Club
Ford Super Duty Owner
Join Date: Dec 2006
Location: Victoria, Texas
Posts: 241
I thought since they were all in service the same length of time I would change them all. Easier to do while I had the board out. My luck, I'd replace one then the next time out another would fail.
__________________
Larry & Doni
2015 Four Winds 31W E-450
South Texas Renegades FMCA F376075
Gordon66 is offline   Reply With Quote
Old 12-18-2013, 07:33 PM   #10
Senior Member
 
Gordon66's Avatar
 
Monaco Owners Club
Thor Owners Club
Ford Super Duty Owner
Join Date: Dec 2006
Location: Victoria, Texas
Posts: 241
Dave, Have you replaced them yet?
__________________
Larry & Doni
2015 Four Winds 31W E-450
South Texas Renegades FMCA F376075
Gordon66 is offline   Reply With Quote
Old 12-19-2013, 07:18 AM   #11
Senior Member
 
mdc99's Avatar
 
Join Date: Apr 2011
Location: Florida
Posts: 277
I bought a new board on ebay from seller mikes_garage_sale. He apparently bought several from the Monaco sale. I paid $50. + $9. shipping. I am under the impression that he has more he would like to sell. Let me know if anyone is interested and I'll track down his phone #.
__________________
"weekend tailgater" 2003 Fleetwood Revolution 40C, 2Vino Scooters hitch rack or H-D FLSTC & XL1200 So. Ga. Cargo Enclsd Trailer-Prodigy wireless brake controller
mdc99 is offline   Reply With Quote
Old 12-20-2013, 08:00 AM   #12
Senior Member
 
itdave's Avatar
 
Monaco Owners Club
Holiday Rambler Owners Club
Join Date: Jul 2006
Location: Cornville, AZ
Posts: 1,079
I got the relays but their replacement has not reached the top of the to do list.
__________________
Dave & Jeri
06 Holiday Rambler Endeavor
TOAD 11 Honda CRV
itdave is offline   Reply With Quote
Old 12-23-2013, 06:24 PM   #13
Senior Member
 
fastcat's Avatar
 
Monaco Owners Club
Join Date: Dec 2011
Location: Oregon
Posts: 460
On my 07 Endeavor I had this same problem. The 12 Volt blade fuse marked F13 - Furnace/Roof AC had become loose and the entire monitor panel quit. That fused circuit supplies the power for the EMS.

I figured it out accidentally by bumping this fuse and everything came back on.

Turns out the connector gets loose where the fuse plugs in. I crimped the terminals a little tighter with needle nose pliers and no all is good.
__________________

__________________
Dick & Theresa
2007 HR Endeavor 36 PDQ
Lots of power to pull the toys I don't have time to use!!
fastcat is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:43 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×