Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-18-2012, 02:40 PM   #1
Senior Member
 
Join Date: Jul 2000
Posts: 2,451
Mirror Camera System

08 Dynasty is equipped with Ramco mirrors and a camera in both mirrors. The image is viewed on a Sony monitor which is also the monitor for the Alladin system. I am having a problem with the RH mirror. I do not see any image in the monitor, only a black sceen with some "static" on the screen. All the other cameras work fine. There is also a monitor in the bedroom and it also has no RH mirror image. I checked the cable going to the mirror and it appears fine. The Sony monitor is built into the dash and it looks like I would have to remove the radio to access the back of the monitor. Anyone else had this problem and what was the cure?

Thanks
__________________

__________________
Moisheh
2008 Dynasty 42' Diamond IV
2009 Silverado Toad
moisheh is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-18-2012, 05:27 PM   #2
Senior Member
 
Monaco Owners Club
Join Date: Feb 2011
Location: Signal Hill, California
Posts: 3,289
I believe the RH image comes on when the right hand turn signal is activated. Other then that .......maybe the camera is bad in the RH mirror. Sorry I don't have a better answer. deSanford
__________________

__________________
Sanford, Linda & R cats: Molly, Levi, Cody
2011 Monaco by Navistar RV
Good Sam Life Member Good Sam Hams Chapter
deSanford is offline   Reply With Quote
Old 09-23-2012, 09:37 AM   #3
Senior Member
 
Dupdyke's Avatar
 
Join Date: May 2012
Location: Roseville MN sum / La Feria Tx winter
Posts: 701
In my dynasty you can get flashlight to look at the back of the monitor to see if the cable from the rh camera has come loose. My cable comes loose from the wonderfull interstates about every year. Push it in and it works for a few months.
__________________
Dupdyke is offline   Reply With Quote
Old 09-23-2012, 06:24 PM   #4
Senior Member
 
Join Date: Jul 2000
Posts: 2,451
dupdyke: Thanks. I slid out the genset and I think the mirror camera cables are long enough that I can switch them from side to side. This will help with my diagnosis.
__________________
Moisheh
2008 Dynasty 42' Diamond IV
2009 Silverado Toad
moisheh is offline   Reply With Quote
Reply

Tags
camera



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:10 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.