RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-23-2018, 09:30 AM   #1
Junior Member
 
Join Date: Oct 2018
Posts: 1
Monaco Safari fuel gauge

Own a 2005 Cheetah Safari pusher and have problems with fuel gauge, works sometime and not others. Fuel sender has been changed twice but doesn't seem to matter. Any help would be greatly appreciated.
__________________

az race fan is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-23-2018, 11:07 AM   #2
Senior Member
 
BFlinn181's Avatar


 
Gulf Streamers Club
Join Date: Jan 2012
Location: Cincinnati
Posts: 19,907


Intermittent electrical problems can be very difficult to find. Since you've had the sender replaced, I'd look for connections to the sender to ground and/or the wires to the gauge.
__________________

__________________

Bob & Donna
'98 Gulf Stream Sun Voyager DP being pushed by a '00 Beetle TDI
BFlinn181 is offline   Reply With Quote
Old 10-23-2018, 03:50 PM   #3
Senior Member
 
walt2137's Avatar
 
Monaco Owners Club
Join Date: Sep 2003
Location: Quitman MS
Posts: 2,923
Quote:
Originally Posted by az race fan View Post
Own a 2005 Cheetah Safari pusher and have problems with fuel gauge, works sometime and not others. Fuel sender has been changed twice but doesn't seem to matter. Any help would be greatly appreciated.
Its not much help anyone can offer with the Monaco type fuel gauge except try running a new ground wire, my soulition was Silverleaf VMspc
__________________
Walt & Will
2000 Dynasty
2017 Ram Big Horn Crew C 4X4 w/ M&G
walt2137 is offline   Reply With Quote
Old 10-23-2018, 04:45 PM   #4
Senior Member
 
vito.a's Avatar
 
Monaco Owners Club
Join Date: Oct 2009
Location: Tucson, AZ
Posts: 2,666
Try adding a new ground to the sending unit. Even if it's just temporary to see it that fixes it.
You can also add a new ground to the gauge.
Hope you get it!
__________________
97 Monaco Windsor- Sold
07 Monaco Executive McKinley- Sold
04 Monaco Signature Chateau IV
vito.a is offline   Reply With Quote
Old 10-23-2018, 04:45 PM   #5
Senior Member/RVM #90
 
MSHappyCampers's Avatar


 
Monaco Owners Club
Join Date: Nov 2002
Location: Columbus, MS
Posts: 33,456
Hi ! Welcome to IRV2! We're sure glad you joined the gang!

I would suspect a bad ground on the sending unit! Have fun and keep her between the ditches!

Good luck, happy trails, and God bless!
__________________
Joe & Annette

2002 Monaco Windsor 40PBT, 2013 Honda CRV AWD
MSHappyCampers is offline   Reply With Quote
Old 10-29-2018, 04:50 PM   #6
Junior Member
 
Dixidoodle's Avatar
 
Join Date: Jul 2018
Posts: 14
May not be any help but does you Adladen system show proper fuel quantity. If yes then wiring to gauge or gauge may be wrong type for sender.
Dixidoodle is offline   Reply With Quote
Old 10-29-2018, 10:11 PM   #7
Member
 
Monaco Owners Club
Join Date: Aug 2015
Posts: 63
I'm going through the same thing now. I called centroid and they gave me an e-mail address for Joel. He e-mailed a trouble shooting form and worked closely with me. It seems that I have an algae problem although I don't have any driveabilty issues. I pulled the sender and let it dry out for a day, rechecked voltages from the inside tube to the outside tube and it came back up to the specification which is 4.5 volts. I reinstalled the sender and it registered fine. After a day or so it read a little lower. I did install an algae killer put that can take a couple of tanks of fuel to really clean it out. I do believe that is the problem however I'm parked until January.

Centroid E-mail joelbahner@gmail.com>

Good luck
Jim
__________________

__________________
2006 Monaco 40 foot Windsor PDQ
ISL 400 Cummins
2015 Ford F-150 Lariat Toad W/Air Force one Toad Brake
66gt350 is offline   Reply With Quote
Reply

Tags
fuel, monaco



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Safari Cheetah 39 PDQ :: 2005 Safari Cheetah 39 PDQ philand iRV2 Owners Registry 0 09-25-2016 08:56 AM
Faulty Fuel Gauge.......is Scan Gauge a good alternative? DGBPokes Spartan Motorhome Chassis Forum 9 07-06-2015 09:43 PM
Fuel Gauge & Volt Gauge not working Deerhunter Freightliner Motorhome Chassis Forum 9 07-20-2010 03:22 PM
temp gauge & fuel gauge indicators antlerz MH-General Discussions & Problems 9 02-16-2006 06:34 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:06 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.