RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-20-2014, 04:04 PM   #1
Member
 
Join Date: Oct 2010
Location: Rock Hill SC
Posts: 72
Need Help with Inverter control

Today I had all power off of the coach to replace the "BIG BOY". Now the house batteries will again charge with the engine alternator as it should. While checking systems out inside the coach I found that the inverter is not working. I used the inverter power prior to the disconnect. I have pushed the ON-OFF button many times to no avail. I even started the ONAN and tried as stated in the manual and nothing happens. I also noticed that the "Battery State of Charge" is at 0%. (the batteries are about 12.5 volts) I can scroll up and down the menu items but can't get the inverter to restore service.

Hope someone can guide me in the right direction

PAPA "J"
2004 Dynasty Chancellor
__________________

PAPA J is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-20-2014, 05:34 PM   #2
Senior Member
 
Join Date: May 2010
Posts: 1,059
If its an inverter/charger and you only have 12.5V when on generator or shore power, then the charger isn't working either. Can you verify that you actually have battery voltage at the inverter with no shore or generator power?

Although with the same make and model RV will know what inverter you have, you'll get more help if you can tell everyone what make/model your inverter is.
__________________

__________________
Gil
03 Prevost H3-45
Hoffman Conversion
ImagineIF is offline   Reply With Quote
Old 09-20-2014, 08:58 PM   #3
Senior Member
 
bgbranch's Avatar
 
Join Date: Apr 2013
Location: Lake City, Florida
Posts: 107
Sounds like you either have a battery disconnect switch still turned off or a bad disconnect switch.
__________________
Ron, Bonnie and Tazman
2007 Camelot 42PDQ
Lake City, Florida
bgbranch is offline   Reply With Quote
Old 09-20-2014, 09:11 PM   #4
Senior Member
 
mccrob's Avatar
 
Join Date: Feb 2012
Posts: 502
Unplug both the telephone type wires on the inverter that resets it that should cure your problem
__________________
Bob & Elaine McClelland and the spoiled pup Izzie
2008 Monaco Diplomat
Desert Hills & Parker Az
mccrob is offline   Reply With Quote
Old 09-20-2014, 09:50 PM   #5
Member
 
Join Date: Oct 2010
Location: Rock Hill SC
Posts: 72
The inverter control is RC7 GS. The battery switch is working as I have plenty of 12V inside of the coach. I only mentioned the battery voltage to indicate that the batteries were not discharged.

Where would I find the inverter to unplug the phone type cables?

The batteries are recharged with either ONAN, Cummings, or by shore power. All of the 12V lights etc. work fine. I only have 110V with generator or shore power. The suggested unplugging sounds like a good idea if only I can find it and I have no clue of what it looks like.

Thanks for the replys.


PAPA "J"
2004 Dynasty Chancellor
PAPA J is offline   Reply With Quote
Old 09-20-2014, 09:57 PM   #6
Registered User
 
Monaco Owners Club
Join Date: Oct 2009
Location: Varies Depending on The Weather
Posts: 8,517
It looks similar to this photo.

The two data cables are the ones that plug into what looks like telephone plug/cables at the top/middle of the Inverter.

Dr4Film ----- Richard
Attached Thumbnails
Click image for larger version

Name:	rvgs2012.jpg
Views:	66
Size:	22.3 KB
ID:	74441  
Dr4Film is offline   Reply With Quote
Old 09-20-2014, 10:08 PM   #7
Senior Member
 
GregOk80's Avatar
 
Join Date: Dec 2012
Location: Glenpool, Oklahoma
Posts: 326
The inverter should be within a 10 feet or less from your batteries. If you only changed the Big Boy relay I might think the relay might be in the wrong direction as in the coach working off the chassis batteries and not the coach batteries. I have tested my Fleetwood Revolution BCC and found the replacement BCC board thru Fleetwood and will replace it when it comes in. For now I can use a jumper wire from the big boy to the hot side of the relay and everything works. I think it is the purple wire coming from the relay. But as I understand the BCC board it controls 12 volt on both sides and also the AUX START button. Have some one stand by the right rear were your big boy is and have someone in driver side turn key on NOT START and hit the AUX START button and see if you have a loud click. If not something is still wrong and more testing needed. All batteries should show 14.4 volts with engine , genny, or shore power plugged in. Just be sure when testing coach batteries if you have 6 volt batteries like I do test in 12 volt series
GregOk80 is offline   Reply With Quote
Old 09-20-2014, 10:09 PM   #8
Senior Member
 
jacwjames's Avatar
 
Monaco Owners Club
Join Date: Jun 2014
Posts: 5,900
Same thing happen to me once, I had accidently hit the on/off button on the inverter while I was working around it earlier before the trip. Got down to Florida and the first time we hit the inverter button it did nothing. I posted for help on another forum and someone suggested I check the switch.
__________________
Jim J
2002 Monaco Windsor 38 PKD
2005 Jeep Grand Cherokee w/5.7 Hemi
jacwjames is offline   Reply With Quote
Old 09-20-2014, 10:16 PM   #9
Member
 
Join Date: Oct 2010
Location: Rock Hill SC
Posts: 72
Dr4Film, Thanks for the reply. I will go looking for the inverter tomorrow. Something that big should not be hard to find. I would expect to find them somewhere close to the house batteries.

Thanks again to all for the replys. Good Night.


PAPA "J"
2004 Dynasty Chancellor
PAPA J is offline   Reply With Quote
Old 09-20-2014, 10:21 PM   #10
Senior Member
 
texnet's Avatar
 
Monaco Owners Club
Join Date: Apr 2009
Location: Granbury, Texas
Posts: 1,384
Look in the large double wide bay at the top of the bay for a door... Lay down in the bay, looking up and you should find a removable door. Inside that compartment should be your inverter/converter
__________________
Ronnie (WD5GIC) & Jan (WD5IHU)
2003 Monaco Dynasty Countess 42' w/tag, 2012 Ford Flex
http://www.ronniesphotos.com

texnet is offline   Reply With Quote
Old 09-21-2014, 05:15 AM   #11
Senior Member
 
bruceisla's Avatar
 
Join Date: Oct 2012
Location: Foley AL
Posts: 7,124
Quote:
Originally Posted by PAPA J View Post
Dr4Film, Thanks for the reply. I will go looking for the inverter tomorrow. Something that big should not be hard to find. I would expect to find them somewhere close to the house batteries.

Thanks again to all for the replys. Good Night.


PAPA "J"
2004 Dynasty Chancellor
Although it's a good idea to find your inverter, you can unplug the communication cable at the control panel end. Unscrew the 4 screws and the panel should pull straight out ... as mentioned, the communication cable resembles a telco cable.

BTW, your inverter is fused ... and the panel may be separately fused.
__________________
2005 Newmar Essex 4502, 2013 Caddy SRX
1997 HR Endeavor 37, CAT, 1996 Geo Tracker
bruceisla is offline   Reply With Quote
Old 09-21-2014, 10:00 AM   #12
Member
 
Join Date: Oct 2010
Location: Rock Hill SC
Posts: 72
OK Guys, The response has been well received and I did find the inverter and have disconnected the phone type plugs at the inverter and at the remote controller. Still no AC power from the inverter. After the disconnect at the back of the remote controller, the display reads "SYSTEM STATUS" (Waiting for AC)
When I push the ON/OFF button, I hear a ticking noise from within the controller.

I have cut off and on all of the 110V breakers in the bedroom and none of them appeared to have been tripped. I don't know of any other 110V breakers any where else.

Understand, all of the 110V works when plugged into 50-AMP or running the generator. The battery charging side of the inverter is charging the batteries when 110V power is present.

Hope someone will chime in with some help.

Again, I am thankful for the response received about my problem. I stay in touch with this forum to learn as much as I can about this coach. The technology with this coach is way over my head and I need the help.

PAPA "J"
2004 Dynasty Chancellor
PAPA J is offline   Reply With Quote
Old 09-21-2014, 10:12 AM   #13
Senior Member
 
GregOk80's Avatar
 
Join Date: Dec 2012
Location: Glenpool, Oklahoma
Posts: 326
Breakers on the inverter check them
GregOk80 is offline   Reply With Quote
Old 09-21-2014, 10:17 AM   #14
Senior Member
 
Join Date: Jun 2003
Location: Northern Illinois
Posts: 116
If you have a Magnum Energy Inverter/Charger, call their Tech Support Group 425 353-8833. They are very helpful and have helped me through several problem over the phone. If it can be resolved remotely, they can figure it out.
__________________

__________________
2006 Diplomat 40DST
2014 Honda CR-V
justlou is online now   Reply With Quote
Reply

Tags
inverter, need help



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Res. Fridge and inverter wiring confirmation plz akeyzoo MH-General Discussions & Problems 47 08-01-2014 09:26 PM
Researching adding an inverter AZCactus RV Systems & Appliances 2 07-08-2014 03:45 PM
Inverter wingguy iRV2.com General Discussion 6 04-07-2014 05:41 AM
Inverter Issue Winepress RV Systems & Appliances 5 01-16-2014 12:21 PM
Pix of control panel and inverter?? 2013 Discovery Statgeek Fleetwood Owner's Forum 0 12-18-2013 11:51 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:35 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×