RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login

Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-12-2019, 12:03 PM   #1
Junior Member
 
Join Date: Oct 2018
Posts: 17
WARNING and STOP lights and TRANNY code 6600

Hi Everyone,

2001 Monaco Knight 36R diesel pusher

I fixed my headlights but know more major concerns. I took the RV to the diesel shop for a pre-trip inspection. They said everything looked good. All the shop did was check fluids brakes ect. When I picked it up and started it, I got a WARNING light. Thats what the light says warning and then after a couple of minutes the STOP light came on. The book says it is an engine issue but doesnít say what. The shop is a big truck shop so they are not familiar with the lights.

I left it at the diesel shop and they are looking into it. I am going from bad to worse. My other major issue is the transmission is showing a code 6600. That is some kind of communication issue. The Allison shop is booked out until at least next week. When at the diesel shop, I cleared the code but did not drive it to see if it reappeared. Is it save to drive the RV with this code?

We are planning on leaving for out west, 2200 miles one-way, next week. I sure donít feel comfortable driving the rig with these issues. I hope the trip is not going to be canceled.

Any help or insight on these problems will be helpful.

Thanks,
Phil
__________________

Lurker60 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-12-2019, 01:55 PM   #2
Senior Member
 
nukerj's Avatar
 
Fleetwood Owners Club
Freightliner Owners Club
Join Date: Sep 2016
Location: Monument, CO
Posts: 216
Check the connectors for the tranny for water intrusion. Sometimes the seals fail on the older systems and you need to replace the gaskets. Corrosion or water can cause the communication problems. Other issue could be wire chafing, a bad ground, or a failing control unit
__________________

__________________
2014 Fleetwood Discovery 40G -> '16 Yukon Denali
Mechanical and Electrical Engineer
"De Opresso Liber"
nukerj is offline   Reply With Quote
Old 06-13-2019, 07:02 AM   #3
Junior Member
 
Join Date: Oct 2018
Posts: 17
The shop says the warning and stop lights are from one of the two oil sending units. They are getting a replacement. I hope that takes care of that part.

If anyone can answer my question about running with the 6600 code it would be a big help. I have read where others have had this issue and still where able to drive their RV without issue.

Thanks
Lurker60 is offline   Reply With Quote
Old 06-13-2019, 11:20 AM   #4
Senior Member
 
RustyTools's Avatar
 
Monaco Owners Club
Join Date: Feb 2008
Posts: 1,749
Have you run that code by the Allison Mfgr?
__________________
2008 Camelot 40í PDQ
RustyTools is online now   Reply With Quote
Old 06-16-2019, 09:12 PM   #5
Junior Member
 
Join Date: Apr 2018
Posts: 16
I had the warning and stop engine light in my 01 Windsor. Was the oil pressure switch on passenger side that the ecm reads.
F7nsnp12 is offline   Reply With Quote
Old 06-18-2019, 08:31 AM   #6
Junior Member
 
Join Date: Oct 2018
Posts: 17
Thanks everyone for the help.

The tranny code cleared and Allison said it should not be a problem even if it reoccurs. The warning stop lights was the oil sending sensor. New sensor and updating the ECU. Hopefully no more issues on our trip. Leaving out Thursday.
__________________

Lurker60 is offline   Reply With Quote
Reply

Tags
light, lights



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Generac generators 6600 watt allenfri Vintage RV's 2 03-26-2019 11:09 PM
6600 code Pusherpilot Allison Transmission Forum 1 11-14-2017 05:22 PM
Fantastic Vent Model 6600 Upgrade w/ Wireless Remote Control DriVer Gear and Product Discussions 32 05-01-2009 06:37 AM
Choosing a Powered Fan (MaxxAir MaxxFan vs. Fan-Tastic Vent 6600 + MaxxAir Fan/Mate) TrailerFool iRV2.com General Discussion 6 11-22-2008 05:06 AM
Projects, Sirrus, GPS Antenna, Fan-Tastic Model 6600 w/ Wireless Remote DriVer Winnebago Industries Owner's Forum 14 07-04-2007 10:48 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:19 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.