Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-14-2009, 09:16 PM   #1
Member
 
Join Date: Jan 2007
Posts: 41
Water heater gremlin

On a bit of a bad luck run here.

My water heater does not produce hot water.. All indicator lights seem to be working..

Electric side
Electirc switch light comes on.
Switch on heater is on.
Fuse's all look good.
Breaker looks good.
Element looks good

On the gas side...
Inside coach I hit the swithch on.... red light comes on then goes off.. come on then goes off... at the same time the igniter is sparking but no gas appears to be being released.

Could this be a bad panel.

Is the a GFI for the panel that I am missing up in some cupboard... I heard a rumor of this?

Thanks,

Don
__________________

__________________
dobrien is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-14-2009, 09:55 PM   #2
Senior Member
 
bullydogs1's Avatar
 
Join Date: Apr 2007
Posts: 467
Step 1 is your DSI fault is going off either because of no gas or no water in the heater...

1. Check your bypass valve and make sure that it is allowing water to get into the heater..Mine is behind a panel in the bedroom closet...Once you verify that water is going into the heater and not being bypassed, then I would check the propane flow to the tank (make sure propane is on), there is also a tube which gets nests in it and you will see this tube when you open the water panel door from outside...hopefully it's the bypass valve....
__________________
Stuart and Stella Denning
2016 Entegra Aspire 42RBQ
3 Bullies and a Diesel Pusher
bullydogs1 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
If you have not replaced your Hot Water Heater check valves, read this. LK23 Winnebago Industries Owner's Forum 28 05-07-2010 01:51 PM
Electric Water Heater MP National RV Owner's Forum 9 02-13-2009 12:24 PM
Water Heater and Winterizing bsellers Winnebago Industries Owner's Forum 5 01-07-2008 12:43 PM
Water heater plumbing leak jimandsue60 Winnebago Industries Owner's Forum 2 05-26-2007 08:16 AM
Hot Water Heater criscriscola RV Systems & Appliances 3 01-05-2005 06:07 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:35 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.