Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-01-2008, 03:10 PM   #1
Junior Member
 
Col.G.'s Avatar
 
Join Date: Jul 2008
Location: Far out in N.W. KS
Posts: 3
This is my first time on the forum. I have read most of the discussions on the rear Weldex camera problems. Mine started fading in/out and off right after the 1 yr warranty expired.
Calling the Weldex company is worthless. All they can suggest is selling me a new one for $ 269.00. They did not even offer to provide a repair service. Has Monaco changed to a new system since 2006?
__________________

Col.G. is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-01-2008, 03:10 PM   #2
Junior Member
 
Col.G.'s Avatar
 
Join Date: Jul 2008
Location: Far out in N.W. KS
Posts: 3
This is my first time on the forum. I have read most of the discussions on the rear Weldex camera problems. Mine started fading in/out and off right after the 1 yr warranty expired.
Calling the Weldex company is worthless. All they can suggest is selling me a new one for $ 269.00. They did not even offer to provide a repair service. Has Monaco changed to a new system since 2006?
__________________

Col.G. is offline   Reply With Quote
Old 07-01-2008, 03:49 PM   #3
Moderator Emeritus


 
Monaco Owners Club
Excel Owners Club
Join Date: Nov 2006
Location: Hangin' with Sacs and the Pins
Posts: 9,413
Col.G.
...Welcome to iRV2 and the Monaco Forum!
I am sure you will find lots of friendly & knowledgeable folks willing to help with many RV related questions anywhere on the iRV2 forum..so make sure you look all over ...not just the Monaco Forum.

I'm also going to invite you to introduce yourself over at the New Member Check-In forum while you are waiting for folks to respond to your question. Just tell them who you are and what broought you here... or how long you have been camping..
You may also put your rig type in your signature...as it can make a difference to the answer you may get. (I believe I saw it is a 2006 Cayman..correct?)
I would also like to add some "Monaco Karma" to your signature on the left...if that is ok...Just say "Karma please" and it is yours!!
Again...welcome to iRV2...we hope you visit & Post often!


MM



__________________
MM
*MonacoMama with the 2 Pins & SacsTC Nearby*
*2007 Monaco Diplomat 40' SFT<>2006 Chevy VortecMax Toad<>2006 Buick Lucerne Leading the Way*
MonacoMama is offline   Reply With Quote
Old 07-01-2008, 04:37 PM   #4
Senior Member
 
Toby's Avatar
 
Join Date: Oct 2004
Location: Tallahassee
Posts: 521
Col G

We are on our 4th or 5th Weldex. Thought they fixed it in April at Wildwood, but still actng up. Going in to a dealer in Georgia next Monday to get a "relay" installed. The service rep thinks Wildwood left it off when they replaced last time. We will see. Supposedly they have a fix, but again, thats what they told me in Wildwood. I suggest you call Monaco service and report it and see what they will do. DO NOT call the Oregon Service center, they don't even return calls. s/Toby
__________________
2006 Holiday Rambler Ambassador 38PDQ
Click on SHIP to enlarge CGC Sagebrush
Toby is offline   Reply With Quote
Old 07-01-2008, 05:48 PM   #5
Senior Member
 
Camelot Camper's Avatar
 
Monaco Owners Club
Join Date: Jan 2008
Location: Fort Worth, TX
Posts: 284
The rear camera in our 2007 Camelot is also a Voyager Color Outdoor Camera, Model #VCCT130.

CC
__________________
2007 Monaco Camelot 36PDQ
2009 Hyundai Sante Fe Toad
Camelot Camper is offline   Reply With Quote
Old 07-02-2008, 06:26 AM   #6
Senior Member
 
Sixpack98's Avatar
 
Monaco Owners Club
Texas Boomers Club
Join Date: Oct 2006
Location: Central Florida
Posts: 1,264
I've spent many hours working through Weldex issues. I have found that the camera cable assemblies are the chief cause of intermittent operation. Specifically, the camera connectors are crap, especially the center camera connector. If you look under the dash, up above the radio, you will see some gray cables with plated connectors that unscrew. Take each one apart, clean with contact cleaner (Radio Shack), apply some electrical grease and reassemble. This will help for a while. Simply unscrewing the connector and reconnecting will usually restore the video. The female part of the connector has very little tension and any little bit of oxidation results in loss of video or fluctuating video. I've since wired the rear camera video around the connector. Too soon to tell if that solved the problem but so far it seems to work.

mark
__________________

__________________
Dawn and Mark

06 HR Endeavor 40 PET
Sixpack98 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Weldex camera out in the Southwind 32V Jimco Fleetwood Products Owner's Forum 18 05-25-2010 10:58 AM
Rear Camera JohnB Monaco Owner's Forum 1 01-09-2009 05:50 PM
Weldex camera stopped working in my Bounder Dan_Lorenze MH-General Discussions & Problems 3 01-17-2008 12:25 PM
Weldex Camera to PC Flyer Monaco Owner's Forum 7 01-08-2008 06:34 PM
Weldex Camera kcir MH-General Discussions & Problems 1 12-14-2007 02:22 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:38 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.