Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Excel Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-09-2014, 01:07 PM   #1
JDT
Senior Member
 
JDT's Avatar
 
Join Date: Dec 2006
Location: Oklahoma
Posts: 1,323
Carbon Monoxide Detector

The Atwood detector in the bedroom is chirping and telling me it needs new batteries. The AA batteries are supposed to be a certain model number according to Atwood or the detector will not work. I have tried both Energizer and Duracell with the correct numbers but it will not fire up with them in it. It came with Kidde batteries who I assume is the manufacturer but Wal-Mart doesn't carry them, of course. Anyone changed out their batteries with success and what were they? My next step is get another detector. Kind of hate to be without it as we need the furnace every morning since we are parked at 7800 feet.
__________________

__________________
Jim,
2013 Excel Winslow 34RKM
2017 Ford King Ranch dually, PowerStroke, 4X4
JDT is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-09-2014, 02:51 PM   #2
Senior Member
 
Workshop's Avatar
 
Join Date: Sep 2007
Posts: 1,334
Jim I read the manual for your detector, or at least the one than came up on a google search looking for an Attwood CO Alarm. Appears to be the same that I bought at Home Depot for running our generator at home during emergencies. Mine is a Kidde and appears the same. As I normally don't keep batteries in the detector when not is use, I installed the batteries and it worked fine. One of the things I needed to do was put on my glasses and get in good lighting to ensure the batteries when in correctly.

When you said it didn't fire up...assume you didn't get any audio or light. Did you put the old batteries back in and get any indications just to verify it worked again with the old batteries?

Don't know why it wouldn't work with new batteries, I've never considered anything other than standard AA's and believe the Kidde brand is something mfg'ed for Kidde as a branding thing.

Sticking it out there...I'd verify the correct placement of the batteries. Mine could easily be placed backwards without glasses and good lighting.

workhorse
__________________

__________________
2000 Alpenlite, 29 ft Valhalla - 2014 F350
Workshop is offline   Reply With Quote
Old 08-09-2014, 04:19 PM   #3
JDT
Senior Member
 
JDT's Avatar
 
Join Date: Dec 2006
Location: Oklahoma
Posts: 1,323
Quote:
Originally Posted by Workshop View Post
Jim I read the manual for your detector, or at least the one than came up on a google search looking for an Attwood CO Alarm. Appears to be the same that I bought at Home Depot for running our generator at home during emergencies. Mine is a Kidde and appears the same. As I normally don't keep batteries in the detector when not is use, I installed the batteries and it worked fine. One of the things I needed to do was put on my glasses and get in good lighting to ensure the batteries when in correctly.

When you said it didn't fire up...assume you didn't get any audio or light. Did you put the old batteries back in and get any indications just to verify it worked again with the old batteries?

Don't know why it wouldn't work with new batteries, I've never considered anything other than standard AA's and believe the Kidde brand is something mfg'ed for Kidde as a branding thing.

Sticking it out there...I'd verify the correct placement of the batteries. Mine could easily be placed backwards without glasses and good lighting.

workhorse
Thanks, wh. I got out my flashlight to make sure I had them in the right direction and no luck, no lights or chirping. I even waited about 10 minutes and tried the test button and still nothing. Put the old ones back in and it starts chirping immediately. The Duracell's are MN 1500 which are on the list of batteries to use, as were the E91 Energizer's I tried a few weeks ago. Makes no sense. I'm beginning to think it may be defective.
__________________
Jim,
2013 Excel Winslow 34RKM
2017 Ford King Ranch dually, PowerStroke, 4X4
JDT is offline   Reply With Quote
Old 08-09-2014, 04:24 PM   #4
Senior Member
 
drfife's Avatar
 
Excel Owners Club
Join Date: Jan 2001
Location: Dallas, Texas, USA
Posts: 2,165
Try some different batteries.
__________________
Russell
'13 Excel Winslow 34IKE

'16 GMC Sierra 3500HD
drfife is offline   Reply With Quote
Old 08-09-2014, 04:32 PM   #5
Senior Member
 
Workshop's Avatar
 
Join Date: Sep 2007
Posts: 1,334
Your right, makes no sence. Two different battery sets and still doesn't work. Might try as Russell said and try another set. No harm trying. Just looked at the batteries I keep with the CO alarm, two Ray O Vacs dated 2011 and a Duracell that had a current date.

Did mark my Plus side on the case this time...removes the guess work trying to do it in the dark when the power goes out. Next time it doesn't work with a new set of batteries...hit the reset button....ran out of ideas. Try mixing old and new to see what it does....Might confuse it the next time around.

workhorse
__________________
2000 Alpenlite, 29 ft Valhalla - 2014 F350
Workshop is offline   Reply With Quote
Old 08-09-2014, 09:19 PM   #6
JDT
Senior Member
 
JDT's Avatar
 
Join Date: Dec 2006
Location: Oklahoma
Posts: 1,323
This is actually the third set I have tried. The first were an off brand I got at a Dollar General because I didn't have anything else at the time. I'm thinking I'll just replace it. They are not expensive.
__________________
Jim,
2013 Excel Winslow 34RKM
2017 Ford King Ranch dually, PowerStroke, 4X4
JDT is offline   Reply With Quote
Old 08-10-2014, 06:32 AM   #7
Senior Member
 
wa8yxm's Avatar
 
Damon Owners Club
Workhorse Chassis Owner
Join Date: Mar 2009
Posts: 24,022
Make sure you install the batteries properly... Duracell, EverReady or Ray-o-Vac all will work.
__________________
Home is where I park it!
wa8yxm is offline   Reply With Quote
Old 08-11-2014, 12:57 PM   #8
JDT
Senior Member
 
JDT's Avatar
 
Join Date: Dec 2006
Location: Oklahoma
Posts: 1,323
New one on the way from Amazon. I got some Ray-O-Vac's yesterday and tried them with the same results so I'm done. I did manage to get a single chirp from the Energizers but nothing more. And, yes, I did double check the positive/negative placement each time.
__________________
Jim,
2013 Excel Winslow 34RKM
2017 Ford King Ranch dually, PowerStroke, 4X4
JDT is offline   Reply With Quote
Old 08-11-2014, 01:32 PM   #9
Senior Member
 
ImagineIF's Avatar
 
Join Date: May 2010
Posts: 1,045
Some of these detectors will not work after a predetermined life. I think it's 7 years. Could this be the problem?
__________________
Gil
99 Country Coach
Prevost XL 45 Conversion
ImagineIF is offline   Reply With Quote
Old 08-11-2014, 03:32 PM   #10
JDT
Senior Member
 
JDT's Avatar
 
Join Date: Dec 2006
Location: Oklahoma
Posts: 1,323
I didn't think to look for a date before I trashed it but the Winslow was only 2 years old last June. I wouldn't think one that old would be used. I really think it was just defective.
__________________

__________________
Jim,
2013 Excel Winslow 34RKM
2017 Ford King Ranch dually, PowerStroke, 4X4
JDT is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Carbon monoxide alarm ben8026 Entegra Owner's Forum 28 03-22-2015 09:12 AM
Beware of expired Carbon Monoxide Alarms Brockx RV Systems & Appliances 1 07-08-2014 06:27 AM
Carbon Monoxide Alarm wildman iRV2.com General Discussion 5 11-26-2013 05:54 PM
Carbon Monoxide detector going crazy Ragman MH-General Discussions & Problems 17 10-01-2013 12:18 PM
Portable Generator source of Carbon Monoxide Poisoning... RV1974 iRV2.com General Discussion 3 08-12-2013 05:07 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:49 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.