RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Thor Industries Owner's Forum > Damon
Click Here to Login

Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-01-2019, 07:59 PM   #1
Junior Member
 
Ramairiii's Avatar
 
Join Date: Apr 2016
Posts: 19
2008 Damon Astoria 7way Socket Woes

I was checking my lights on my Jeep toad after hook-up and noticed that my right turn signal stayed lit (constant instead of flashing). However my running lights were on and when I turned them off the right turn signal would flash normally. I unplugged the cord between the coach and Jeep and my Jeep lights all work as normal. I took a 12v tester and found the problem at the socket of the coach. As before when the running lights are on, the right plug prong shows steady power but starts flashing the tester with the lights out. I checked the left rear compartment Areans box and all the fuses are ok. All lights are working on the coach. The 7way has Chrysler on it and the back plug feeding it is a rectangle with small female pins. For some reason my tester doesnít work on the plug pins. Took the loom off of the wires to the plug up until they disappear forward on the inside of the frame in case two wires were bare to each other. They looked perfect. Iím stumped and would appreciate a nudge in the right direction!
Thanks, Ken
__________________

Ramairiii is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-01-2019, 08:25 PM   #2
Senior Member
 
powerboatr's Avatar
 
Damon Owners Club
Freightliner Owners Club
Join Date: Mar 2006
Location: North East Texas
Posts: 4,262
you may have to run test the sires from the arens unit to the 7 way plug.


my tuscany has a secondary connection from the 7 pin connection, maybe your is loose or corroded.

try calling f/l 800 line....they may have some guidance
__________________

__________________
USN Retired, Life time member of the DAV.
Enjoying the 2008 Damon Tuscany 4056, no your eyes are fine, there are really 6 slides
2016 Expedition or 2012 Edge toads

powerboatr is offline   Reply With Quote
Old 05-02-2019, 07:46 AM   #3
Junior Member
 
Ramairiii's Avatar
 
Join Date: Apr 2016
Posts: 19
I will check that today. Was wondering if a bad relay in that box would cause my problem? Also are there other fuse blocks on the coach that the wiring goes to?
Ramairiii is offline   Reply With Quote
Old 05-02-2019, 04:08 PM   #4
Junior Member
 
Ramairiii's Avatar
 
Join Date: Apr 2016
Posts: 19
Problem Fixed- found that the right turn signal relay was bad in the Areans box. Traced the wires from the 7 way receiver plug to the top right plug in the picture. Unplugged it and tested the prongs on the box and found that the right signal prong had constant power with the running lights on. These two prongs are side by side so I took the box cover off and switched the left signal relay with the right and the problem was solved. Tried to find the original relay here locally but had to cross reference it to a Napa relay. $9.89. The original relay can be ordered online from $6 to $18.
These are the part nos. in case anyone else comes across this issue:
Original: Song Chuan
301-1C-C-R1 U01
12VDC

Napa: AR172SB

Thanks for replies

Attachment 244471
Ramairiii is offline   Reply With Quote
Reply

Tags
damon



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Damon :: 2008 Damon Astoria Carel iRV2 Owners Registry 0 08-14-2018 11:52 PM
Damon astoria :: 2006 Thor Damon Astoria 3465 rotorflying iRV2 Owners Registry 0 12-25-2016 11:49 AM
2008 Damon Astoria Pacific 3770 targaboat Damon 3 12-19-2011 03:30 PM
2008 Damon Astoria - Input please DWM MH-General Discussions & Problems 13 04-05-2007 02:03 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:53 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.