RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Thor Industries Owner's Forum > Damon
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-28-2007, 08:11 PM   #1
Member
 
kuldaddy's Avatar
 
Thor Owners Club
Join Date: Mar 2007
Location: Magnolia, TX
Posts: 84
Looks like we are having our first major problem. The rear A/C starting humming loudly the first time we went to use it and it did not blow any cold air. The front A/C worked great.

Went to try it again this past weekend off of the generator and it tripped the breaker on the generator (front, identical, A/C work fine from the generator).

Off to call the repair guy in the morning. Hopefully we can get it fixed before next weekend as we are heading out on the road.
__________________

__________________
2009 Mandalay Presidio 38D
2009 Jeep Wrangler Unlimited Rubicon (Toad)
kuldaddy is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-28-2007, 08:11 PM   #2
Member
 
kuldaddy's Avatar
 
Thor Owners Club
Join Date: Mar 2007
Location: Magnolia, TX
Posts: 84
Looks like we are having our first major problem. The rear A/C starting humming loudly the first time we went to use it and it did not blow any cold air. The front A/C worked great.

Went to try it again this past weekend off of the generator and it tripped the breaker on the generator (front, identical, A/C work fine from the generator).

Off to call the repair guy in the morning. Hopefully we can get it fixed before next weekend as we are heading out on the road.
__________________

__________________
2009 Mandalay Presidio 38D
2009 Jeep Wrangler Unlimited Rubicon (Toad)
kuldaddy is offline   Reply With Quote
Old 05-29-2007, 07:01 AM   #3
Senior Member
 
Workhorse Chassis Owner
Join Date: Jan 2007
Location: Roving, Datastorm users 3192
Posts: 755
The problem is a frozen shaft on one of the two motors in the AC OR... A bad start capacitor on one of them. If it's the blower or a cap, it's easy to fix, if it's the compressor the repair is even easier, though more costly (Replace the unit)
__________________
Nothing adds excitement like something that is none of your business.
2005 Damon Intruder 377W Radio Active as WA8YXM
John-D is offline   Reply With Quote
Old 05-30-2007, 05:48 PM   #4
Member
 
kuldaddy's Avatar
 
Thor Owners Club
Join Date: Mar 2007
Location: Magnolia, TX
Posts: 84
Thanks, it is under warranty so either way it should not cost us.
__________________
2009 Mandalay Presidio 38D
2009 Jeep Wrangler Unlimited Rubicon (Toad)
kuldaddy is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
At Disney and the Coach is Humming Just Fine Thank You Very Much JavaJelly Newmar Owner's Forum 7 11-08-2007 01:31 PM
Inverter humming with all power off DaveOhio Winnebago Industries Owner's Forum 6 05-30-2007 03:45 PM
humming/drone/whistle at 60-65 mph bullydogs1 Workhorse and Chevrolet Chassis Motorhome Forum 9 04-05-2007 09:53 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:11 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×