RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Thor Industries Owner's Forum > Damon
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-31-2011, 04:39 AM   #1
Senior Member
 
Shellback1's Avatar


 
Damon Owners Club
Ford Super Duty Owner
Join Date: Jul 2008
Location: Nashua, NH
Posts: 721
Send a message via AIM to Shellback1
Back up camera died

About 2 months ago the ADTH camera monitor went white and flickering. As I drove at times it would work for a few seconds. Now that I'm home I tried another monitor same problem. Checking continuity from the camera back to the monitor plug, showed 2 of the 4 wires open. I pulled the camera wire out from top where it feeds into the RV and after about 4' there was a plug that was taped. I removed the tape and cleaned the connections, re taped and the monitor works fine. Glad I didn't have to trace or try to re-feed a new cable.
Attached Thumbnails
Click image for larger version

Name:	0330111426a.jpg
Views:	68
Size:	283.6 KB
ID:	9113  
__________________

__________________
2006 Damon Daybreak 3274 35' Ford F53 V-10
2006 Ion Retired Navy, FAA and PASS Union VP
Shellback1 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-01-2011, 05:22 PM   #2
Member
 
195pilot's Avatar
 
Join Date: Mar 2010
Location: St Charles, IL
Posts: 76
I had the same issue on mine. Reconnected the cable and the camera returned to operation but the microphone is still missing in action. I've double-checked the cable's connection at the camera pigtail and at the monitor to no benefit. I can live without it I guess.
__________________

__________________
Coyle & Sue
Cassity (Labrador) and Rylee (Standard Poodle)
2007 Damon Challenger 355; 2003 Element toad
195pilot is offline   Reply With Quote
Old 04-04-2011, 02:25 PM   #3
Senior Member
 
KC1BUD's Avatar
 
Winnebago Owners Club
Join Date: May 2008
Posts: 497
Hmmmm, I wonder if that is why my microphone does not work anymore?
KC1BUD is offline   Reply With Quote
Old 04-04-2011, 03:38 PM   #4
Senior Member
 
Shellback1's Avatar


 
Damon Owners Club
Ford Super Duty Owner
Join Date: Jul 2008
Location: Nashua, NH
Posts: 721
Send a message via AIM to Shellback1
Quote:
Originally Posted by KC1BUD View Post
Hmmmm, I wonder if that is why my microphone does not work anymore?

Most likely yes. First my camera went and would work sometimes, the audio would work all the time until about 3 days after and then nothing worked. The pins on the connector are really thin and not long at all, a really poor connection. Try pulling out the connector and reconnect it to see if your audio returns.

Good luck.

Ron
__________________
2006 Damon Daybreak 3274 35' Ford F53 V-10
2006 Ion Retired Navy, FAA and PASS Union VP
Shellback1 is offline   Reply With Quote
Old 04-04-2011, 04:23 PM   #5
Junior Member
 
Join Date: May 2008
Posts: 2
Had the same problem it would go all fuzzy then I would turn off then on it would work for awhile found wire loose back at the camera hard wired it no problems as of yet over one year

R. Homeier
homey54 is offline   Reply With Quote
Old 04-05-2011, 12:04 PM   #6
Senior Member
 
KC1BUD's Avatar
 
Winnebago Owners Club
Join Date: May 2008
Posts: 497
Quote:
Originally Posted by Shellback1 View Post
Most likely yes. First my camera went and would work sometimes, the audio would work all the time until about 3 days after and then nothing worked. The pins on the connector are really thin and not long at all, a really poor connection. Try pulling out the connector and reconnect it to see if your audio returns.

Good luck.

Ron
I really don't want to fool with it till I can replace it. I bought a 7 inch color monitor to replace the too small 5 inch black and white. When I can find a new color camera for the right price, I will replace the whole shebang.
KC1BUD is offline   Reply With Quote
Old 04-06-2011, 12:17 PM   #7
Senior Member
 
powerboatr's Avatar
 
Damon Owners Club
Freightliner Owners Club
Join Date: Mar 2006
Location: North East Texas
Posts: 4,295
when they replaced our system due to failure, the microphone was lost.
WOW what a great thing to loose. it would come on if i turned on a blinker and help your ears if the radio happened to be on, it would blow your ears out

plus i prefer not to hear what my director is saying as i back up, hand and facial expressions are enough
__________________
USN Retired, Life time member of the DAV.
Enjoying the 2008 Damon Tuscany 4056, no your eyes are fine, there are really 6 slides
2016 Expedition or 2012 Edge toads

powerboatr is offline   Reply With Quote
Old 04-10-2011, 08:20 PM   #8
Senior Member
 
KC1BUD's Avatar
 
Winnebago Owners Club
Join Date: May 2008
Posts: 497
Quote:
Originally Posted by powerboatr View Post
when they replaced our system due to failure, the microphone was lost.
WOW what a great thing to loose. it would come on if i turned on a blinker and help your ears if the radio happened to be on, it would blow your ears out

plus i prefer not to hear what my director is saying as i back up, hand and facial expressions are enough
Too bad we can't replace it with a speaker so we can bark orders from the driver's seat and actually be heard.
KC1BUD is offline   Reply With Quote
Old 04-11-2011, 12:30 PM   #9
Senior Member
 
powerboatr's Avatar
 
Damon Owners Club
Freightliner Owners Club
Join Date: Mar 2006
Location: North East Texas
Posts: 4,295
Quote:
Originally Posted by KC1BUD View Post
Too bad we can't replace it with a speaker so we can bark orders from the driver's seat and actually be heard.
then an auto door lock as she walks back up to get your attention with a baseball bat
I am very lucky
my dw uses great signals and if she cant see me in the mirror ...she moves so i can.
i don't need a low speed bump as i back up, followed by a loud scream as the legs withdraw under the coach
__________________
USN Retired, Life time member of the DAV.
Enjoying the 2008 Damon Tuscany 4056, no your eyes are fine, there are really 6 slides
2016 Expedition or 2012 Edge toads

powerboatr is offline   Reply With Quote
Old 04-12-2011, 11:20 AM   #10
Senior Member
 
KC1BUD's Avatar
 
Winnebago Owners Club
Join Date: May 2008
Posts: 497
Quote:
Originally Posted by powerboatr View Post
then an auto door lock as she walks back up to get your attention with a baseball bat
I am very lucky
my dw uses great signals and if she cant see me in the mirror ...she moves so i can.
i don't need a low speed bump as i back up, followed by a loud scream as the legs withdraw under the coach
In my case I ran across a good deal on one of those cheap backup cameras that mount to the license plate, now I can hook up without help.
__________________

KC1BUD is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
back up and side camera powerboatr Damon 2 04-23-2009 09:10 PM
Back up Camera Rusty Bear Alpine Coach Owner's Forum 2 01-22-2009 05:50 PM
Backup Camera 12v power cuts off then back on. Ed-Sue Alpine Coach Owner's Forum 4 11-05-2008 04:00 AM
Monitoring the back up camera through a PC Tom and Patty Alpine Coach Owner's Forum 4 07-30-2006 01:22 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:21 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.