RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Thor Industries Owner's Forum > Damon
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-18-2010, 01:57 AM   #1
Junior Member
 
Pete Rogers's Avatar
 
Join Date: Apr 2010
Location: Nottingham
Posts: 2
Question Damon 120v Mains supply system problem

Good morning to all.

I need to pick your combined brains as I have a problem with the mains supply on my 2004 Daybreak 3270. I have lost 120v supply to my fridge rear TV and socket on the side of the bed casing. all of the other circuits are good and working fine. Being in the UK there is limited information and expertise with these vehicles and so I find myself on bended knee. Does anyone have a wiring diagram for this coach or knows where I can source one from or even the better the answer to my quest. I have my coach in many pieces at the moment and if i scratch my head any more all of the saw dust will come out.

Many thanks in anticipation

Pete
__________________

Pete Rogers is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-18-2010, 09:27 AM   #2
Senior Member
 
wa8yxm's Avatar
 
Damon Owners Club
Workhorse Chassis Owner
Join Date: Mar 2009
Posts: 24,023
Well.. On my Intruder the bed sockets (in fact all the baseboard outlets save the one in front of the passanger seat on the firewall) are on the same breaker as the fridge

The televisions are on the same circuit as that one "Except" socket, both TV's. but my rig has been re-wired for inverter operation.

Now... What I suspect:

Many RVers have, as it happens, a few screws loose... Many of these screws are located in the main circuit breaker box

Disconnect from shore power, Make sure the generator is off, I recommend putting the shore power cord WHERE YOU CAN SEE IT (or sit on it) to insure nobody plugs you in when you don't expect it.

Open the main breaker box and check every screw inside to make sure it is tight

Some of mine took well over a full turn

It is also possible that you have a tripped GFCI somewhere (At night go looking for the light, the small indicator light) but I suspect that is not a GFCI circuit. Still. Possible.
__________________

__________________
Home is where I park it!
wa8yxm is offline   Reply With Quote
Old 04-19-2010, 02:21 PM   #3
Junior Member
 
Pete Rogers's Avatar
 
Join Date: Apr 2010
Location: Nottingham
Posts: 2
Many Thanks

Many thanks

I have traced the fault to the distribution box as you advised, the screws were tight but the wire was not in the clamp but trapped behind the screw which has oxidised and the plastic. I have fastened it correctly and all is well with the world.

Thanks again for you help

Pete
Pete Rogers is offline   Reply With Quote
Old 04-20-2010, 12:01 PM   #4
Senior Member
 
wa8yxm's Avatar
 
Damon Owners Club
Workhorse Chassis Owner
Join Date: Mar 2009
Posts: 24,023
WOW... Now that is not one I'd expect.. They missed the hole completly eh.

I'd send a note to Damon on that one

Glad I could help.. even if I was slightly off on the problem/solution (It was close enough though)
__________________
Home is where I park it!
wa8yxm is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Water System Problem wingtrike Alpine Coach Owner's Forum 4 03-25-2010 07:53 PM
Magnadyne DVD Problem - Possible Fix Robin_M Monaco Owner's Forum 21 07-06-2009 07:58 PM
Voyager color backup camera system installed!! SargeW Winnebago Industries Owner's Forum 3 08-01-2006 07:41 AM
Workhorse Fuel System DriVer Workhorse and Chevrolet Chassis Motorhome Forum 18 07-19-2006 07:44 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:58 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.