RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Thor Industries Owner's Forum > Damon
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-02-2011, 05:58 AM   #1
Member
 
Join Date: Sep 2008
Location: albert lea mn.
Posts: 33
mileage malfunction.

i have a 07 demon day-break emphasis on break went on a short trip it had 7500 miles on it. when i started it up to leave it had 50 miles on it. and fluctuate between 150 and zero till i got home. it is a digital one and i need help to figure out what the heck is wrong thanks.


"make it your goal to lead a quiet life, mind your own business and work with your hands."
__________________

the breeze 1 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-02-2011, 09:34 AM   #2
Senior Member
 
The General's Avatar
 
Forest River Owners Club
Freightliner Owners Club
Join Date: Sep 2007
Location: Rancho Cordova, California
Posts: 1,037
Send a message via Yahoo to The General
Breeze,

Check your chasis battery for weak or dead cells and ground wire for corrosion.
Start simple, then go expensive,

Steve
__________________

The General is offline   Reply With Quote
Old 05-02-2011, 01:59 PM   #3
Member
 
Join Date: Sep 2008
Location: albert lea mn.
Posts: 33
thanks steve, i took it in for service today and they are going to check it out. when i get it back i will let you know what happened. thanks.
the breeze 1 is offline   Reply With Quote
Old 05-02-2011, 02:13 PM   #4
Senior Member
 
steved44's Avatar
 
Join Date: Nov 2007
Posts: 190
I had a similar thing happen to me last fall. This is a 05 Allegro Bus with a freightliner chassis. I pulled into white sands national monument with 52,520 miles on it, parked for an hour and when I started back up I had 725 miles on it???? Has worked fine ever since, but I only have 3600 miles on it now. I wonder if the warranty will start back up. Maybe I was too close to Roswell. Works fine now, just has the wrong mileage on the odometer. I called freightliner and they said If I brought it in they would probably replace the odometer, but then it would still be starting at 0 miles, so I'm just going to keep driving it and see if it ever happens again. Steve
steved44 is offline   Reply With Quote
Old 05-02-2011, 02:42 PM   #5
Senior Member
 
The General's Avatar
 
Forest River Owners Club
Freightliner Owners Club
Join Date: Sep 2007
Location: Rancho Cordova, California
Posts: 1,037
Send a message via Yahoo to The General
Quote:
Originally Posted by steved44 View Post
I had a similar thing happen to me last fall. This is a 05 Allegro Bus with a freightliner chassis. I pulled into white sands national monument with 52,520 miles on it, parked for an hour and when I started back up I had 725 miles on it???? Has worked fine ever since, but I only have 3600 miles on it now. I wonder if the warranty will start back up. Maybe I was too close to Roswell. Works fine now, just has the wrong mileage on the odometer. I called freightliner and they said If I brought it in they would probably replace the odometer, but then it would still be starting at 0 miles, so I'm just going to keep driving it and see if it ever happens again. Steve
-

Darn new contraptions.....don't make em like they used to!


Steve
The General is offline   Reply With Quote
Old 05-02-2011, 02:44 PM   #6
Senior Member
 
Ford Super Duty Owner
Join Date: Dec 2009
Location: Mcdonough, Ga.
Posts: 5,017
Most of the ones I worked on, had a wafer battery to keep the odometer working when the power was off. It sounds like the battery is loose or weak. If the speedometer has to be pulled, you or the dealer has to sign a affadavit as to the true millage. It will be returned with the correct millage on it.
ga traveler is online now   Reply With Quote
Old 05-02-2011, 02:55 PM   #7
Senior Member
 
Ford Super Duty Owner
Join Date: Dec 2009
Location: Mcdonough, Ga.
Posts: 5,017
Quote:
Originally Posted by steved44 View Post
I had a similar thing happen to me last fall. This is a 05 Allegro Bus with a freightliner chassis. I pulled into white sands national monument with 52,520 miles on it, parked for an hour and when I started back up I had 725 miles on it???? Has worked fine ever since, but I only have 3600 miles on it now. I wonder if the warranty will start back up. Maybe I was too close to Roswell. Works fine now, just has the wrong mileage on the odometer. I called freightliner and they said If I brought it in they would probably replace the odometer, but then it would still be starting at 0 miles, so I'm just going to keep driving it and see if it ever happens again. Steve
Steve; I don't know who you spoke to at freightliner, but I have replaced a lot of these odometers. When you send in the old one, you have to send a affadavit (notorized) stating the true millage. I am sure you know, it is a felony to change the millage on a vehicle.
ga traveler is online now   Reply With Quote
Old 05-07-2011, 08:21 AM   #8
Member
 
Join Date: Sep 2008
Location: albert lea mn.
Posts: 33
they brought the RV back today, they had everything done but the odometer, waiting to hear from them. will let you know.
__________________

the breeze 1 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
UFO cluster not remembering mileage -Gramps- Workhorse and Chevrolet Chassis Motorhome Forum 32 10-10-2010 07:15 AM
Lousy Fuel Mileage RKamperRV Navigation, Routes & Roads 8 07-25-2010 05:55 PM
Older model vs. high mileage Abby1313 Class C Motorhome Discussions 19 07-18-2010 09:53 AM
Mileage JDT Monaco Owner's Forum 15 09-06-2009 06:00 PM
Mileage benefits increase John Harrelson Military / Veteran RVing 2 02-03-2008 06:36 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:20 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.