Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Thor Industries Owner's Forum > Damon
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-20-2010, 05:06 PM   #1
Junior Member
 
Join Date: May 2009
Posts: 25
wiper motor?

im still working on my wipers. they wont shut off most of the time unless you turn it all the way to the mist setting,and sometimes that doesnt work for awhile. they dont delay, they just run in the delay setting. they run on high in the low setting and low in the high setting. ive added an extra ground to the motor, tried a new delay module, tried a new wiper switch in the column. the only thing left is harness and motor. also it doesnt matter if its raining or not. and i have took the module completely out of the system and the motor shuts off in the off position, just no delay, speeds are still reversed and washer function doesnt activate wipers. this is a 2006 damon daybreak on a 2004 P32 workhorse chassis. any suggestions? also does anyone know if the wiper motor crosses with an automotive part number?
__________________

__________________
2006 damon daybreak 3060 on a p32 chassis
mlp911 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-21-2010, 01:03 PM   #2
iRV2 Marketing
 
DriVer's Avatar
 
Winnebago Owners Club
Workhorse Chassis Owner
Coastal Campers
Carolina Campers
Join Date: Jan 2000
Location: Conway, SC
Posts: 23,365
Blog Entries: 70
Quote:
Originally Posted by mlp911 View Post
... this is a 2006 damon daybreak on a 2004 P32 workhorse chassis. any suggestions? also does anyone know if the wiper motor crosses with an automotive part number?
mlp911, What preceeded this event or was this a sudden onset? This is very weird - almost like there's a short in the harness or something!
__________________

__________________
03 Adventurer 38G, Workhorse W22
F&R Track Bars, Safety+ , Ultrapower, Taylor Extremes, SGII
TST 507, Blue Ox, SMI, Koni FSD, CrossFire
RV/MH Hall of Fame - Lifetime Member
DriVer is offline   Reply With Quote
Old 05-22-2010, 12:03 PM   #3
Junior Member
 
Join Date: May 2009
Posts: 25
well i bought this mh a little over a year ago, i never tried the wipers while checking it out. just one of those things you dont think about. didnt realize there was a problem till the first time i tried to use them. the wipers work, sorta. just not right. since they worked enough i havent tried to figure out whats wrong till now. i have some parts contacts at my local chevy dealer so i was able to try a new delay module and wiper switch without buying them but niether fixed the problem. seems like once the wiper motor starts running it backfeeds thru the harness and wont shutoff. but by removing the module completly they do turn off in the off position. so its either a short in the harness, motor, or i got a bad new module.
__________________
2006 damon daybreak 3060 on a p32 chassis
mlp911 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Windshield wiper saga, complicated by dealership dishonesty best5 Winnebago Industries Owner's Forum 19 08-28-2015 10:21 AM
Wiper Washer Fluid Pump Motor Stays On? Slick7 Workhorse and Chevrolet Chassis Motorhome Forum 2 05-11-2010 05:07 PM
Wiper Motor Mikeeg Newmar Owner's Forum 5 08-25-2008 11:08 AM
New Monaco LaPalma and Holiday Rambler Vacationer Motor Homes Utilize Workhorse UFO™ DriVer RV Industry Press 2 11-27-2006 05:59 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:24 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.