RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Thor Industries Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-08-2014, 02:07 AM   #1
Junior Member
 
Join Date: Jan 2014
Posts: 27
Battery cable loose ace 29.2

Hello hoping I could get some help! The local RV repair company I used for winterizing and de winterizing did a terrible job! I had them replace the drain screen that froze. Now I realize they left a cable loose in my battery compartment. There is a cable that looks to be attached to the frame and one end is not attached at all, any idea where I attach it? Help! My batteries go dead pretty quick 2-4 hrs so maybe it helps with charging?

Thank you
Kevin
__________________

Kkuper is online now   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-08-2014, 05:23 AM   #2
Member
Commercial Member
 
Join Date: Apr 2012
Posts: 41
Have you check the water in your batteries? If your batteries were dead or low they may have frozen. Once they are dead they can freeze and will need replaced. As for the wire I would probably need a little more info. If you could post a picture that would be helpful. A load test on the battery is a good way to tell what you have.
__________________

okrvrepair is offline   Reply With Quote
Old 05-08-2014, 08:53 AM   #3
Senior Member
 
Join Date: Apr 2012
Location: Kansas City
Posts: 257
post a picture, all cables should be attached and nothing loose. I'm assuming they detached the ground or somthing.
__________________
2013 Thor ACE 29.2
Harlee79 is offline   Reply With Quote
Old 05-08-2014, 11:26 PM   #4
Junior Member
 
Join Date: Jan 2014
Posts: 27
Click image for larger version

Name:	ImageUploadedByiRV2 - RV Forum1399613076.490578.jpg
Views:	65
Size:	618.2 KB
ID:	62411[ATTACH]62412[/ATTACH

Here are pics of what cable is loose one end is attached to the frame other is loose. My batteries are discharging quick.

Thank you Kevin
Attached Thumbnails
Click image for larger version

Name:	ImageUploadedByiRV2 - RV Forum1399613090.047558.jpg
Views:	48
Size:	719.7 KB
ID:	62412  
Kkuper is online now   Reply With Quote
Old 05-09-2014, 05:47 AM   #5
Senior Member
 
Farmer Steve's Avatar
 
Mid Atlantic Campers
Join Date: Oct 2013
Posts: 340
Quote:
Originally Posted by Kkuper View Post
Attachment 62411[ATTACH]62412[/ATTACH

Here are pics of what cable is loose one end is attached to the frame other is loose. My batteries are discharging quick.

Thank you Kevin
Yep clean posts and install cable to neg -, add distilled water to batteries to line about half inch below top. Charge batteries with a smart charger or drive it around awhile (should charge itself) then load test with a toaster. That's what I call mine because it has heating strips like a toaster. If you don't have one Auto Zones can check it for you. Good batteries hold a load without the needle dropping much. My guess is you have one bad battery that is shorted or open. Unfortunately, you should replace both if that is the case as I have never had good luck with one old and new battery. 35 engines on our farm and way too many batteries!
__________________
14 Newmar Ventana LE 3845, eze-tow, bunch-a-tractors
Farmer Steve is offline   Reply With Quote
Old 05-18-2014, 11:06 PM   #6
Junior Member
 
Join Date: Jan 2014
Posts: 27
Thank you I did as suggested, cleaned terminals charged batteries and added water. I was out this weekend and no battery issues in AK at all although was 74 and sunny until 11 pm so no lights needed.

Thanks for all of your help!

If any of you come to Alaska let me know and I'll point you in the right direction!

Kevin
__________________

Kkuper is online now   Reply With Quote
Reply

Tags
battery



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 Ford Focus Battery disconnect Patchy Toads and Motorhome Related Towing 177 06-05-2019 07:00 PM
2014 ACE 29.2 power issues Trzecij Thor Industries Owner's Forum 3 04-29-2014 04:27 PM
1st Post: new, freshly charged battery with little use is dead 323 Travel Trailer Discussion 20 03-02-2014 07:40 PM
Any 2014 ace 29.2 owners disappointed with new generator location??? gowestwardho Thor Industries Owner's Forum 3 03-02-2014 06:15 AM
Serrano Battery Question Penguy Thor Industries Owner's Forum 1 01-09-2014 07:31 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:58 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.