RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Thor Industries Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-30-2014, 06:01 PM   #1
Senior Member
 
Virago-Rider's Avatar
 
Join Date: Apr 2014
Location: Oklahoma
Posts: 681
Battery charging question.

Can someone explain how the battery charging system on the MH works? Where might the charger be located? Is it the same as the 120VAC to 12 VDC converter, or is it a separate box?


Sent from my iPad2 using iRV2 - RV Forum
__________________

__________________
1998 Thor Windsport 33SL
2007 Chevy Uplander toad (tow master dolly)
1985 Yamaha Virago XV700
Virago-Rider is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-30-2014, 10:00 PM   #2
Senior Member
 
Virago-Rider's Avatar
 
Join Date: Apr 2014
Location: Oklahoma
Posts: 681
More info...

I have the InteliPower PD9245C converter/charger. At the output terminals on it I get 13.6 VDC. At the batteries I have just over 12 VDC. If I unplug the rv, I get nothing from the converter.. As I would expect. Plug it back in, 13.6 VDC.

At the batteries, the voltage never changes if I am plugged in or not. So. The mystery is, where is the power going when it leaves the converter?

Somewhere it is not getting to the batteries. Unless I am just not seeing something.

I can use all the various 12 VDC lights, run the slide in/out... All that works, but it seems the batteries are not being charged when plugged in.

Send your wisdom my way please.


Sent from my iPad2 using iRV2 - RV Forum
__________________

__________________
1998 Thor Windsport 33SL
2007 Chevy Uplander toad (tow master dolly)
1985 Yamaha Virago XV700
Virago-Rider is offline   Reply With Quote
Old 05-30-2014, 10:01 PM   #3
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 18,200
My Mh, the converter/charger is all one unit , electronic output limiting and up to 75 amps of 12v power to charge batteries, run all the coaches internal 12v systems.
Do you have a brand name off the converter/charger that's in your coach , maybe we can round up the paper work , manuals and spec sheets for you.

Edit: your second post came in while I was typing , I'll read and re-post.
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 05-30-2014, 10:04 PM   #4
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 18,200
Do your coach batteries ever go dead?
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 05-30-2014, 10:17 PM   #5
Senior Member
 
Virago-Rider's Avatar
 
Join Date: Apr 2014
Location: Oklahoma
Posts: 681
I don't know. We bought this not ling ago. Got it cheap because so many things didn't work and the dealer just wanted it off the lot. So far, everything that was not working I have been able to fix fairly easy. Automatic steps, tv antenna wiring, tail lights, water leaks, sewer leak...... Down to this and replacing the jack down sensors on 2 of the jacks.

I just want to be sure it is working correctly before I head out.

As I said above, I see 13.6 VDC at the output of the converter. But just the battery voltage at the battery. That reading does not change if I am plugged into 120 vac, not plugged in, battery disconnected..... Voltage at the battery stays the same... Unless I turn on some lights... Then it drops a bit. But, it seems if the converter/charger is putting out 13.6 I should see that, or near that at the battery. And I would think I should see some change when plugged in or not plugged in.

Perhaps I am wrong.




Sent from my iPad2 using iRV2 - RV Forum
__________________
1998 Thor Windsport 33SL
2007 Chevy Uplander toad (tow master dolly)
1985 Yamaha Virago XV700
Virago-Rider is offline   Reply With Quote
Old 05-30-2014, 10:33 PM   #6
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 18,200
No , if the C/charger is putting out 13.6v you should be seeing that at the coach batteries, not necessarily the chassis batteries though. How far from the C/charger to the coach battery , can you trace the wire to check for a bad circuit breaker, or poor connections.

Edit: I see you have another post going on battery condition, replacement. If the coach battery is in poor shape , it may have developed a high resistance to charge and that could be messing with your readings. Or do you have a new battery in place?
If you pull the positive battery cable off the battery and check for voltage do you get the 13.6v from the converter charger?
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 05-30-2014, 10:48 PM   #7
Senior Member
 
Virago-Rider's Avatar
 
Join Date: Apr 2014
Location: Oklahoma
Posts: 681
I have the dead battery out at the moment. So only the good one is in there. I did not check with both disconnected. I will do that tomorrow. As for tracing the wires...... I think a psycic would have trouble doing that on this rig. They are run under the floor, but not visible from under the camper... I may pull the fuse box off the wall and see if the 2 big wires from the C/C go to it.


Sent from my iPad2 using iRV2 - RV Forum
__________________
1998 Thor Windsport 33SL
2007 Chevy Uplander toad (tow master dolly)
1985 Yamaha Virago XV700
Virago-Rider is offline   Reply With Quote
Old 05-30-2014, 11:23 PM   #8
Senior Member
 
Join Date: Apr 2013
Posts: 370
It sounds like your batteries may be weak, or there is a voltage drop from your converter to your battery. A fully charged 12 volt battery measures about 12.7 volts. A measurement of only 12 volts indicates a discharged state.

Good rv battery info found here: The RV Battery Charging Puzzle « HandyBob's Blog
__________________
2003 Itasca Sunrise 32v F53
Okiedoke is offline   Reply With Quote
Old 05-31-2014, 04:35 AM   #9
Senior Member
 
njs42's Avatar
 
National RV Owners Club
Workhorse Chassis Owner
Join Date: Apr 2011
Location: Federal Way, Wa.
Posts: 2,901
It seems clear from your other post that your batteries are dead. Getting one good one installed deep cycle will probably solve your dilemma the cheapest way. Trying to run the system with dead batteries will cause a multitude of other problems so if you can get one good one depending on your financial situation do it soon.
__________________

__________________
I do all my own stunts
03 Dolphin LX 6355, Workhorse W22, 8.1 vortec, 04 CR-V, Blue Ox, Brake Pro----Norm, Barb and
Doc(He's a PhD)
njs42 is offline   Reply With Quote
Reply

Tags
battery, charging



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trailer Battery not charging BigTow RV Systems & Appliances 9 05-30-2014 12:05 AM
revolution battery charging Mickey123 Fleetwood Owner's Forum 5 05-06-2014 08:24 AM
Battery Charging Question atamians Travel Trailer Discussion 12 05-03-2014 09:16 PM
Chassis battery question becks Monaco Owner's Forum 20 03-20-2014 01:30 PM
Serrano Battery Question Penguy Thor Industries Owner's Forum 1 01-09-2014 07:31 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:00 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.