RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Thor Industries Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-02-2019, 06:00 PM   #1
Member
 
KrankyKoot's Avatar
 
Join Date: Jul 2017
Location: Florida
Posts: 47
Horn not working

Just realized that my horn in my Windsport. is not working. Checked fuses and as much wiring as I could behind the dash. Anybody have any idea where I might look?
__________________

__________________
2016 Thor Windsport 29M towing 2011 Mazda Miata
KrankyKoot is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-02-2019, 09:24 PM   #2
Senior Member


 
Holiday Rambler Owners Club
Join Date: Aug 2015
Posts: 4,281
KrankyKoot-

Which fuse did you test? And was there 12V on one or both sides of the fuse holder?
__________________

__________________
Mark
2008 Holiday Rambler Admiral 30PDD (Ford F-53 chassis)
2009 Honda Fit Sport
l1v3fr33ord1 is offline   Reply With Quote
Old 07-03-2019, 08:14 AM   #3
Member
 
KrankyKoot's Avatar
 
Join Date: Jul 2017
Location: Florida
Posts: 47
The fuse is a 20A in the Ford F53 engine bay according to the manual.
__________________
2016 Thor Windsport 29M towing 2011 Mazda Miata
KrankyKoot is offline   Reply With Quote
Old 07-03-2019, 05:40 PM   #4
Senior Member
 
triplewide's Avatar
 
Join Date: Mar 2015
Posts: 1,496
You might try hooking 12 volts to the horn directly to see if it is working. If it is, about the only thing left is the horn switch, fuse, and wiring in between. I don't think there is a relay involved. A good ground is important also.
__________________
2015 ACE 29.3
triplewide is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Replace FL M2 106 Electric Horn to Air Horn SSTuner Freightliner Motorhome Chassis Forum 2 09-29-2018 06:54 AM
Horn fuse is open, Horn doesn't work GurkaJim iRV2.com General Discussion 3 07-12-2011 05:45 AM
Horn (non air) not working on W24 Nonno Workhorse and Chevrolet Chassis Motorhome Forum 13 08-26-2007 03:30 PM
HWH Jacks working, not working and working again? Bob&Pat Winnebago Industries Owner's Forum 6 06-08-2006 04:22 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:25 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.