RV Trip Planning Discussions

Go Back   iRV2 Forums > POWER TRAIN GARAGE FORUMS > Navistar MaxxForce Engine Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-18-2018, 08:17 AM   #15
Senior Member
 
Gdawgs's Avatar
 
Join Date: May 2015
Location: Fayetteville, GA
Posts: 377
Quote:
Originally Posted by gbstewart View Post
Can a person just get rid of the DPF? I know on some trucks there where people installing some kind of kits and reprogramming the computer



Yes but expensive. I have 30k on my MF10 and it's running fine. When I pull of the highway and the high temp light comes on I know my DPF is hot and clean. I never try to do an active regen if the engine is not at operating temps. That's just adding fuel to further clog the DPF. The DPF is easy to remove and has probes before and after that measure pressure. When the difference exceeds a certain level extra fuel is added to burn the soot and clean the filter. I'm thinking there must be a way to fool the ECM and have it see the same pressure before the DPF and after the DPF.
__________________

__________________
2013 HR 43DFT RR10R
All Electric FWS-Tag FMCA 451687
2017 Ford F150 4X4 Toad
Gdawgs is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-18-2018, 03:58 PM   #16
Junior Member
 
Jknight's Avatar
 
Monaco Owners Club
Join Date: Jan 2014
Location: Crossville, Tn
Posts: 4
I have had the same issue twice, 2 years apart. The first was at around 40,000 mi and the second was at 50,000. I get low boost (low 20's) with no alarm lights. The boost will return to normal if the engine is shut off and restarted. This continues until the emissions trouble light comes on. When the international dealer checks the codes it shows a high pressure to the after treatment injector. They remove and clean it and it's good to go.
__________________

__________________
2012 Monaco Knight 36 PFT
2004 Acura RSX
Jknight is offline   Reply With Quote
Old 09-19-2018, 06:14 PM   #17
Member
 
RPrince's Avatar
 
Join Date: Dec 2014
Location: Marble Falls, Texas
Posts: 92
Quote:
Originally Posted by larrykathy View Post
FYI
Yep, we have the Maxxforce 10 with 32000 miles. We've put on about 23000 miles ourselves so far.

In July, I got a DPF needs regen light, then went to flashing and alarm. So I pulled over to do a parked regen. It went through the whole process, about 30 min and then a RED light popped on. It wouldn't run let alone go down the road, it was in limp mode. Had it towed to a International dealer where they said the DPF was clogged. I told them that that was a symptom of something else wrong but they couldn't find anything. So had them do an oil change and service everything else.

The point I was trying to get across to them was, say you have a clogged convertor in your car, they replace the convertor and 2 weeks later you have the same problem, clogged convertor. It was all because a sparkplug was misfiring and raw fuel was being dumped down to the convertor, over heating and clogging the convertor. By replacing the convertor the first time it didn't repair the real problem (sparkplug).

Went another 500 miles and still was getting the regen light every so often, so we went to another dealer. They diagnosed and found that the DPF was almost clogged and was caused by the DPF fuel injector not working. That injector dumps fuel into the exhaust causing the exhaust temperature to rise and burn off the DPF filter, which cleans it. BTW now the exhaust at times is very hot, cant stand in front of it. It cost about $1500.00 for their services.
We've put on at least couple thousand miles since and no problems at all. Have not seen the DPF lights at all and runs great.

I suspect that new programing in the ECM and updated parts will have this problem solved.

Sure hope they can figure out your engine problems Larry.
On a trip to Alaska this summer, the malfunction indicator light on our 2012 Maxxforce 10 came on and power derated to a crawl up the hill we were climbing. I pulled over and tried to do a manual regen, but it didn't do anything. I changed the primary fuel filter in hope that would fix it, but it didn't.

When I restarted the motor, it had more power, but not 100%. We limped into Shelby, MT and tried to find a repair shop close by, but there wasn't one. This was as on Friday afternoon before Memorial day weekend! Decided to turn around and go about 100 miles (slowly) south to Great Falls, MT where there were several diesel truck shops listed, and spend the holiday weekend.

On Tuesday, after hearing back from the shops that I had left messages with over the weekend, I made an early appt at Fleet Maintenace Services. They started working on it at 9am. After doing some computer checks and forcing a regen or two, it was determined that the hydrocarbon injector (Doser valve) wasn't working. It was plugged and needed replacing. According to International, it can't be cleaned with air or solvents... The only one they could find was in Dallas (about 200 miles from our house). The computer indicated that there had been 400 regens done at 38k miles.

The MH was at their shop for three days with them working on it and waiting on parts. The replacement parts were $599.00 and they only charged me $290.0 for labor after working on it for three days. The replacement part #5010735R92 looked a little larger than the old one, and the metal gasket had a larger hole in the middle where the old one one was plugged?? May have redesigned the replacement part?

I would highly recommend this shop if you are in the area needing help. The other truck shops in town did not have access to the International software needed to resolve the problem. The closest International dealer was about 250 miles away in Missoula, MT.

Since the injector was replaced, the motor has run fine. We continued on our trip to Alaska and now have 47k miles with no problems. Hopefully, we won't have anymore issues.

RandyClick image for larger version

Name:	20180918_115101.jpeg
Views:	41
Size:	68.6 KB
ID:	219702Click image for larger version

Name:	20180918_115027.jpeg
Views:	39
Size:	81.8 KB
ID:	219703
__________________
Randy and Laura
2012 Monaco Knight 36PFT
2016 Jeep Wrangler Rubicon
RPrince is offline   Reply With Quote
Old 11-13-2018, 05:12 PM   #18
Senior Member
 
Long Island Mac's Avatar


 
Join Date: Aug 2010
Location: BABYLON LONG ISLAND
Posts: 452
Today, went to have topper replaced, as I had the parts, but presently on a cane. Pulled out of driveway, and made my 1st turn and realized in limp mode. Pulled over, Regent light came on. But zero action when I hit the regent switch. Tried to restart, but engine dies. Now towed to shop, waiting for analization. Up to now, not as happy as should be. Spring, all filters and oil changed, (not tranny tho) at 38000. Have all records. 2 months ago had to replace starter and alternator and two chassis batteries. Belts also as they had to be removed. Now, rethinking how happy I had been with this maxxfoce 10. We'll see what happens in the next few days.
__________________
Tom, Jan with Papillon, Candy
'13 (60th annaversary) AMBASSADOR 40' DFT
/FORD EDGE Don't dream your life away, but live your dream
Long Island Mac is online now   Reply With Quote
Old 11-17-2018, 10:15 AM   #19
Senior Member
 
Long Island Mac's Avatar


 
Join Date: Aug 2010
Location: BABYLON LONG ISLAND
Posts: 452
Maxxforce rgen

Well, here I am again. After above post, after limp mode, wouldn't start. Towed to shop. Next day went down to see. Had the REGEN unit off. It was caked about 1/8 to 1/4 inch of black powder. Canister sent to be baked, and found inside filter separating inside. Waiting for new canister. Injector problem, but what else. Next iteration next Tuesday when new canister arrives. Never had regen light since last computer update, until September in Hershey. (Did last parked regen in 2014.) Pulled into DICK'S, did a parked regen. All good to go. Here I am now??
__________________
Tom, Jan with Papillon, Candy
'13 (60th annaversary) AMBASSADOR 40' DFT
/FORD EDGE Don't dream your life away, but live your dream
Long Island Mac is online now   Reply With Quote
Old 11-17-2018, 05:12 PM   #20
Senior Member
 
Holiday Rambler Owners Club
Join Date: Mar 2014
Location: Wainscott, New York
Posts: 112
We had ourís baked by Stadium in Binghamton. We have since taken it to Four Corners without any additional problems. We are on the East End. Where did you take it on Long Island?
__________________
Stan, Mary, Maggie the Canine Princess & Lucy Princess in Training
2013 Holiday Rambler Ambassador 36pft
2014 Cadillac SRX Toad
diva51 is offline   Reply With Quote
Old 11-18-2018, 07:52 AM   #21
Senior Member
 
Long Island Mac's Avatar


 
Join Date: Aug 2010
Location: BABYLON LONG ISLAND
Posts: 452
Babylon is where it's parked when not on the road. MH now at Authority Fleet Svc in Copaige. 1st time there, previous shop closed. Impressed so far. Mine on lift, two other MH's and a school bus inside. 4/5 guys and owner. Just have to see. They were recommended by King Navistar in Wyndanch, who won't work on MH's.
__________________
Tom, Jan with Papillon, Candy
'13 (60th annaversary) AMBASSADOR 40' DFT
/FORD EDGE Don't dream your life away, but live your dream
Long Island Mac is online now   Reply With Quote
Old 11-18-2018, 09:05 AM   #22
Senior Member
 
Holiday Rambler Owners Club
Join Date: Mar 2014
Location: Wainscott, New York
Posts: 112
Thanks for the info. Looking forward to your conclusion and update.
__________________
Stan, Mary, Maggie the Canine Princess & Lucy Princess in Training
2013 Holiday Rambler Ambassador 36pft
2014 Cadillac SRX Toad
diva51 is offline   Reply With Quote
Old 11-21-2018, 05:18 PM   #23
Senior Member
 
Long Island Mac's Avatar


 
Join Date: Aug 2010
Location: BABYLON LONG ISLAND
Posts: 452
Quote:
Originally Posted by diva51 View Post
Thanks for the info. Looking forward to your conclusion and update.
Well, not a short reply. Was ready for p\u today. 4 work day turnaround!! Replaced DPF system. Computer was set to incorrect parameters. This caused the regent system to not regent when needed. Up until Hershey in September, have not seen a regen light since NAVISTAR rep did a computer update in 2014? Now, I should see a light (when driving) that regen in progress. Also, the halt regen switch was inoperable. (Now, computer flashed to most recent update) This also caused fuel pushed back to oil. Oil changed. I am not a mechanic, but when Dave was explaining it all, made some sense. End result is $7 grand. Extended warranty explicitly does not cover emissions. Will be discussing with warranty company. Soooo that's my sorry story. Leaving 1 January for warmer weather!! Hopping for a good trip with only small problems.
__________________
Tom, Jan with Papillon, Candy
'13 (60th annaversary) AMBASSADOR 40' DFT
/FORD EDGE Don't dream your life away, but live your dream
Long Island Mac is online now   Reply With Quote
Old 11-21-2018, 09:05 PM   #24
Senior Member
 
Traps90's Avatar
 
Monaco Owners Club
Join Date: Sep 2010
Location: Alberta
Posts: 1,377
Well the good news is they got you up and running, but the 7k definitely hurts. Sure hope they have everything fixed and solved.
__________________
Trap, Jan and the Pup
2013 Monaco Diplomat 43dft
2010 Black Jeep Liberty
Traps90 is offline   Reply With Quote
Old 11-22-2018, 08:17 PM   #25
Senior Member
 
Holiday Rambler Owners Club
Join Date: Mar 2014
Location: Wainscott, New York
Posts: 112
Now that you have had the repair complete, we wish you a great trip south!
__________________
Stan, Mary, Maggie the Canine Princess & Lucy Princess in Training
2013 Holiday Rambler Ambassador 36pft
2014 Cadillac SRX Toad
diva51 is offline   Reply With Quote
Old 11-23-2018, 11:27 AM   #26
Senior Member
 
Long Island Mac's Avatar


 
Join Date: Aug 2010
Location: BABYLON LONG ISLAND
Posts: 452
Quote:
Originally Posted by diva51 View Post
Now that you have had the repair complete, we wish you a great trip south!
Yes, hoping for a worry free adventure!!
__________________

__________________
Tom, Jan with Papillon, Candy
'13 (60th annaversary) AMBASSADOR 40' DFT
/FORD EDGE Don't dream your life away, but live your dream
Long Island Mac is online now   Reply With Quote
Reply


« MaxxForce 7 MODs | - »

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bounder: Back from the Shop! Oscar Mike Fleetwood Products Owner's Forum 1 01-18-2013 06:40 PM
Back is not going back? Smitty77 Forum 101 | Announcements | Member Forum Concerns 20 07-20-2012 08:53 PM
Back from the shop! hondo122 Caterpillar Engine Forum 0 04-17-2009 06:45 PM
Need Allison shop/Alignment shop in Phoenix AZ area Mahlon Workhorse and Chevrolet Chassis Motorhome Forum 3 10-10-2006 09:06 PM
Back in the shop again BigRedLancer Winnebago Industries Owner's Forum 3 06-19-2005 09:09 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:27 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.