RV Trip Planning Discussions

Go Back   iRV2 Forums > POWER TRAIN GARAGE FORUMS > Navistar MaxxForce Engine Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-28-2018, 09:41 AM   #1
Senior Member
 
Monaco Owners Club
Holiday Rambler Owners Club
Join Date: Sep 2007
Location: Somewhere, USA
Posts: 315
Blog Entries: 1
Back in the shop

"Regen" light came on, blinking, boost 13lbs. Called the shop they looked at the info from onCommand waiting for them to take a look at it.
__________________

__________________
Larry and Suzette
2013 HR Endeavor 43 PKQ
2006 Jeep Liberty toad, SMI AFO Brake controller
Larry and Suzette is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-28-2018, 07:15 PM   #2
Senior Member
 
Monaco Owners Club
Holiday Rambler Owners Club
Join Date: Sep 2007
Location: Somewhere, USA
Posts: 315
Blog Entries: 1
Quote:
Originally Posted by Larry and Suzette View Post
"Regen" light came on, blinking, boost 13lbs. Called the shop they looked at the info from onCommand waiting for them to take a look at it.
The tech was able to recreate the fault by shaking wires on the DPF area. Check many of the plugs and resupported the wiring. Did a road test over some of the fine Vermont roads. No issues. About 100 miles more with no problems. Parked for the night.
__________________

__________________
Larry and Suzette
2013 HR Endeavor 43 PKQ
2006 Jeep Liberty toad, SMI AFO Brake controller
Larry and Suzette is offline   Reply With Quote
Old 08-31-2018, 07:26 PM   #3
Member
 
Join Date: Sep 2013
Location: near a golf course
Posts: 42
hope this fixes the latest set of problems for you. I have the same engine and have had several trips in and out of shops all along the west coast for five years. real pain in the ass when something goes wrong with these engines. I have been parked for the summer but prior to parking had a heck of a time with forced regens on the side of busy roads. My engine goes into stage three regen with no prior warnings, supposed to go stage 1, 2 and then three. A real problem when in heavy traffic and you know you need to pull over to perform a forced regen (sitting for upwards of an hour burning fuel for no good reason). Can't get any money on trade in for these engines.
ctundra is offline   Reply With Quote
Old 08-31-2018, 08:30 PM   #4
Senior Member
 
Monaco Owners Club
Holiday Rambler Owners Club
Join Date: Sep 2007
Location: Somewhere, USA
Posts: 315
Blog Entries: 1
Quote:
Originally Posted by ctundra View Post
hope this fixes the latest set of problems for you. I have the same engine and have had several trips in and out of shops all along the west coast for five years. real pain in the ass when something goes wrong with these engines. I have been parked for the summer but prior to parking had a heck of a time with forced regens on the side of busy roads. My engine goes into stage three regen with no prior warnings, supposed to go stage 1, 2 and then three. A real problem when in heavy traffic and you know you need to pull over to perform a forced regen (sitting for upwards of an hour burning fuel for no good reason). Can't get any money on trade in for these engines.
Jim at Stadium International in Binghamton NY says it's all after treatment. The timing is not stock, from a dealer shop, get Chicago to log in and see the parameters.

Last is new DOC and most sensors.

Yep it will be a very expensive park model soon.
__________________
Larry and Suzette
2013 HR Endeavor 43 PKQ
2006 Jeep Liberty toad, SMI AFO Brake controller
Larry and Suzette is offline   Reply With Quote
Old 09-01-2018, 12:39 PM   #5
Senior Member
 
Monaco Owners Club
Holiday Rambler Owners Club
Join Date: Sep 2007
Location: Somewhere, USA
Posts: 315
Blog Entries: 1
Quote:
Originally Posted by Larry and Suzette View Post
Jim at Stadium International in Binghamton NY says it's all after treatment. The timing is not stock, from a dealer shop, get Chicago to log in and see the parameters.

Last is new DOC and most sensors.

Yep it will be a very expensive park model soon.
Well the last "fix" didn't. Any good contact at Navistar that may help?
__________________
Larry and Suzette
2013 HR Endeavor 43 PKQ
2006 Jeep Liberty toad, SMI AFO Brake controller
Larry and Suzette is offline   Reply With Quote
Old 09-01-2018, 02:03 PM   #6
Senior Member
 
Forest River Owners Club
Join Date: Sep 2016
Posts: 197
Our issues have all been with the DEF system throwing the check engine light. Lucky for us it reset itself a number of times so we didn’t get into the regen or detune stages. Turned out to be pins in the big harness was misaligned and when jarred it would contact another pin and cause the fault. Without being handled or jiggled it wouldn’t show up. Freightliner ended up going into the wire looms to find it-wasn’t quick or easy. Hope your gets figured out.
__________________
2016 Berkshire XL 40 with 2016 Jeep Wrangler. 380 Cummins.
igave is offline   Reply With Quote
Old 09-05-2018, 01:18 PM   #7
Senior Member
 
Monaco Owners Club
Holiday Rambler Owners Club
Join Date: Sep 2007
Location: Somewhere, USA
Posts: 315
Blog Entries: 1
Quote:
Originally Posted by igave View Post
Our issues have all been with the DEF system throwing the check engine light. Lucky for us it reset itself a number of times so we didn’t get into the regen or detune stages. Turned out to be pins in the big harness was misaligned and when jarred it would contact another pin and cause the fault. Without being handled or jiggled it wouldn’t show up. Freightliner ended up going into the wire looms to find it-wasn’t quick or easy. Hope your gets figured out.
There is no DEF on the 2013 MAXX FORCE 10.
__________________
Larry and Suzette
2013 HR Endeavor 43 PKQ
2006 Jeep Liberty toad, SMI AFO Brake controller
Larry and Suzette is offline   Reply With Quote
Old 09-14-2018, 08:57 AM   #8
Senior Member
 
Traps90's Avatar
 
Monaco Owners Club
Join Date: Sep 2010
Location: Alberta
Posts: 1,377
Hey Larry any update on your latest issues. Let's keep our fingers crossed.
__________________
Trap, Jan and the Pup
2013 Monaco Diplomat 43dft
2010 Black Jeep Liberty
Traps90 is offline   Reply With Quote
Old 09-14-2018, 03:31 PM   #9
Senior Member
 
2 Stroker's Avatar
 
Join Date: Nov 2009
Location: Warren, Oregon
Posts: 2,082
Quote:
Originally Posted by Larry and Suzette View Post
Well the last "fix" didn't. Any good contact at Navistar that may help?
A good friend of mine just got a 2013 HR Endeavor 43' with the MaxxForce 10 and has put around 200mi and it is in the shop already, Brattain International in Portland, Or. Light flashing and I told him it was like the catalytic converter was plugged, 1800rpm and I could walk faster. Did a regen no help. They pulled the def converter or something and said it was plugged and it had to be cooked for 24hrs at high heat. They said it would be close to $3 grand to get this thing running.

2 stroker
__________________
2006 Country Coach Inspire 360 40ft Genoa Designer Series, Samsung 197 RR
Cat C9--STEEL & COPPER Bolt Together Radiator w/ updated rubber mounting
SilverLeaf 330 Magnum 2812 PSW 2011 Ford Edge Sport-Air Force One
2 Stroker is offline   Reply With Quote
Old 09-15-2018, 10:12 AM   #10
Senior Member
 
Traps90's Avatar
 
Monaco Owners Club
Join Date: Sep 2010
Location: Alberta
Posts: 1,377
Quote:
Originally Posted by 2 Stroker View Post
A good friend of mine just got a 2013 HR Endeavor 43' with the MaxxForce 10 and has put around 200mi and it is in the shop already, Brattain International in Portland, Or. Light flashing and I told him it was like the catalytic converter was plugged, 1800rpm and I could walk faster. Did a regen no help. They pulled the def converter or something and said it was plugged and it had to be cooked for 24hrs at high heat. They said it would be close to $3 grand to get this thing running.

2 stroker
Sounds like this coach has had a lot of idling. If he bought it from a dealer, I would suspect that they had idled the coach way to much.
__________________
Trap, Jan and the Pup
2013 Monaco Diplomat 43dft
2010 Black Jeep Liberty
Traps90 is offline   Reply With Quote
Old 09-15-2018, 02:10 PM   #11
Senior Member
 
2 Stroker's Avatar
 
Join Date: Nov 2009
Location: Warren, Oregon
Posts: 2,082
Quote:
Originally Posted by Traps90 View Post
Sounds like this coach has had a lot of idling. If he bought it from a dealer, I would suspect that they had idled the coach way to much.
Yes, they got this fine running machine from a dealer. I was there when they picked it up and not knowing anything about this fine machine I asked, why are the 2 lights on the dash flashing and there tech said as soon as you get it on the road and up to 60 in about 30min they will go out. The old saying (If there lips are moving they are lying)

There is a lady 125mi from Whitehorse in Canada getting a tow (Good Sam) that has been trying to get back to the states for over a month. They have had this fine machine for about 4mo. If they ever get home I think it gone.
2 stroker
__________________
2006 Country Coach Inspire 360 40ft Genoa Designer Series, Samsung 197 RR
Cat C9--STEEL & COPPER Bolt Together Radiator w/ updated rubber mounting
SilverLeaf 330 Magnum 2812 PSW 2011 Ford Edge Sport-Air Force One
2 Stroker is offline   Reply With Quote
Old 09-16-2018, 09:02 AM   #12
Senior Member
 
Traps90's Avatar
 
Monaco Owners Club
Join Date: Sep 2010
Location: Alberta
Posts: 1,377
Quote:
Originally Posted by 2 Stroker View Post
Yes, they got this fine running machine from a dealer. I was there when they picked it up and not knowing anything about this fine machine I asked, why are the 2 lights on the dash flashing and there tech said as soon as you get it on the road and up to 60 in about 30min they will go out. The old saying (If there lips are moving they are lying)

There is a lady 125mi from Whitehorse in Canada getting a tow (Good Sam) that has been trying to get back to the states for over a month. They have had this fine machine for about 4mo. If they ever get home I think it gone.
2 stroker

While I know there are a few people that are having issues, there are a lot that have had no problems with these engines. Some of them are getting close to 100,000 miles with no issues

A friend of mine wishes he had my engine as his 2014 with the new ISL has been towed in 3 times. As with most problems now a days it is electronic and related to the DPF
__________________
Trap, Jan and the Pup
2013 Monaco Diplomat 43dft
2010 Black Jeep Liberty
Traps90 is offline   Reply With Quote
Old 09-16-2018, 09:21 AM   #13
Senior Member
 
gbstewart's Avatar
 
Join Date: Jan 2011
Posts: 382
Can a person just get rid of the DPF? I know on some trucks there where people installing some kind of kits and reprogramming the computer
gbstewart is offline   Reply With Quote
Old 09-18-2018, 01:42 AM   #14
Member
 
larrykathy's Avatar
 
Monaco Owners Club
Holiday Rambler Owners Club
Join Date: Jul 2000
Location: Maricopa, AZ USA
Posts: 83
FYI
Yep, we have the Maxxforce 10 with 32000 miles. We've put on about 23000 miles ourselves so far.

In July, I got a DPF needs regen light, then went to flashing and alarm. So I pulled over to do a parked regen. It went through the whole process, about 30 min and then a RED light popped on. It wouldn't run let alone go down the road, it was in limp mode. Had it towed to a International dealer where they said the DPF was clogged. I told them that that was a symptom of something else wrong but they couldn't find anything. So had them do an oil change and service everything else.

The point I was trying to get across to them was, say you have a clogged convertor in your car, they replace the convertor and 2 weeks later you have the same problem, clogged convertor. It was all because a sparkplug was misfiring and raw fuel was being dumped down to the convertor, over heating and clogging the convertor. By replacing the convertor the first time it didn't repair the real problem (sparkplug).

Went another 500 miles and still was getting the regen light every so often, so we went to another dealer. They diagnosed and found that the DPF was almost clogged and was caused by the DPF fuel injector not working. That injector dumps fuel into the exhaust causing the exhaust temperature to rise and burn off the DPF filter, which cleans it. BTW now the exhaust at times is very hot, cant stand in front of it. It cost about $1500.00 for their services.
We've put on at least couple thousand miles since and no problems at all. Have not seen the DPF lights at all and runs great.

I suspect that new programing in the ECM and updated parts will have this problem solved.

Sure hope they can figure out your engine problems Larry.
__________________

__________________
Larry & Kathy
2014 Monaco Ambassador 38PFT, 2017 Nissan Titan
larrykathy is offline   Reply With Quote
Reply


« MaxxForce 7 MODs | - »

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bounder: Back from the Shop! Oscar Mike Fleetwood Products Owner's Forum 1 01-18-2013 06:40 PM
Back is not going back? Smitty77 Forum 101 | Announcements | Member Forum Concerns 20 07-20-2012 08:53 PM
Back from the shop! hondo122 Caterpillar Engine Forum 0 04-17-2009 06:45 PM
Need Allison shop/Alignment shop in Phoenix AZ area Mahlon Workhorse and Chevrolet Chassis Motorhome Forum 3 10-10-2006 09:06 PM
Back in the shop again BigRedLancer Winnebago Industries Owner's Forum 3 06-19-2005 09:09 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:37 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.