RV Trip Planning Discussions

Go Back   iRV2 Forums > POWER TRAIN GARAGE FORUMS > Navistar MaxxForce Engine Forum
Click Here to Login

Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-20-2018, 12:49 PM   #1
Member
 
cabin man's Avatar
 
Monaco Owners Club
Join Date: Aug 2008
Location: Weedsport, NY
Posts: 91
Max force 10 overflow tank

Having trouble with regen light flashing. Tried doing a request regen . Motor went 1600 rpms for 25 minuets but light never went out or went back to idle! Looked at level in radiator tank and level was ok but seemed to be swirling in the tank . Any idea what could be going on? Also engine looses power on any hill.
__________________

__________________
2013 HR Ambassador, towing a 2017 Jeep Grand Cherokee
cabin man is online now   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-20-2018, 01:49 PM   #2
Senior Member
 
Gdawgs's Avatar
 
Join Date: May 2015
Location: Fayetteville, GA
Posts: 392
Quote:
Originally Posted by cabin man View Post
Having trouble with regen light flashing. Tried doing a request regen . Motor went 1600 rpms for 25 minuets but light never went out or went back to idle! Looked at level in radiator tank and level was ok but seemed to be swirling in the tank . Any idea what could be going on? Also engine looses power on any hill.

Check your manual. Solid, blinking lights have different meanings. I'd try another regen with a hot engine. If the regen isn't successful you may need to have the DPF baked or several more regens. The engine will cut to half power to protect itself if the filter didn't clear with a regen.
__________________

__________________
2013 HR 43DFT RR10R
All Electric FWS-Tag FMCA 451687
2017 Ford F150 4X4 Toad
Gdawgs is offline   Reply With Quote
Old 05-20-2018, 04:03 PM   #3
Member
 
cabin man's Avatar
 
Monaco Owners Club
Join Date: Aug 2008
Location: Weedsport, NY
Posts: 91
thanks I will give the regen another try
__________________
2013 HR Ambassador, towing a 2017 Jeep Grand Cherokee
cabin man is online now   Reply With Quote
Old 05-24-2018, 07:40 AM   #4
Senior Member
 
Traps90's Avatar
 
Monaco Owners Club
Join Date: Sep 2010
Location: Alberta
Posts: 1,388
Quote:
Originally Posted by cabin man View Post
Having trouble with regen light flashing. Tried doing a request regen . Motor went 1600 rpms for 25 minuets but light never went out or went back to idle! Looked at level in radiator tank and level was ok but seemed to be swirling in the tank . Any idea what could be going on? Also engine looses power on any hill.

A parked regen can take up to 45 minutes, I have done 2 so far one was 35 minutes and another was close to 40 minutes.

Do not stop the regen yourself make sure you let it run its cycle.
__________________
Trap, Jan and the Pup
2013 Monaco Diplomat 43dft
2010 Black Jeep Liberty
Traps90 is offline   Reply With Quote
Old 05-24-2018, 06:42 PM   #5
Member
 
cabin man's Avatar
 
Monaco Owners Club
Join Date: Aug 2008
Location: Weedsport, NY
Posts: 91
Took motor home in to international dealer this morning. Going to have it checked over, they also said the computer needed to be updated. Will let everyone know the outcome. Thanks to everyone who replied.
__________________
2013 HR Ambassador, towing a 2017 Jeep Grand Cherokee
cabin man is online now   Reply With Quote
Old 05-25-2018, 06:28 PM   #6
Member
 
cabin man's Avatar
 
Monaco Owners Club
Join Date: Aug 2008
Location: Weedsport, NY
Posts: 91
Picked up the motor home today,they pulled the codes and found the AFI and the port completely plugged ,cleaned the AFI and port. They ran it to temp and ran a regen. Everything looked good and did a road test also. Had them change both fuel filters also. They also did a EMC update. Drove it home about 60 miles and it ran great.
__________________
2013 HR Ambassador, towing a 2017 Jeep Grand Cherokee
cabin man is online now   Reply With Quote
Old 05-26-2018, 04:54 AM   #7
Senior Member
 
Gdawgs's Avatar
 
Join Date: May 2015
Location: Fayetteville, GA
Posts: 392
Quote:
Originally Posted by cabin man View Post
Picked up the motor home today,they pulled the codes and found the AFI and the port completely plugged ,cleaned the AFI and port. They ran it to temp and ran a regen. Everything looked good and did a road test also. Had them change both fuel filters also. They also did a EMC update. Drove it home about 60 miles and it ran great.

Great news..these engines like to be driven hard. I have 28K miles and it runs better the harder it works.
__________________
2013 HR 43DFT RR10R
All Electric FWS-Tag FMCA 451687
2017 Ford F150 4X4 Toad
Gdawgs is offline   Reply With Quote
Old 05-27-2018, 07:22 AM   #8
Senior Member
 
Traps90's Avatar
 
Monaco Owners Club
Join Date: Sep 2010
Location: Alberta
Posts: 1,388
Glad to hear they got you taken care of. As GDawgs said don't baby these engines they are built to be used hard.
__________________
Trap, Jan and the Pup
2013 Monaco Diplomat 43dft
2010 Black Jeep Liberty
Traps90 is offline   Reply With Quote
Old 05-27-2018, 09:13 AM   #9
Member
 
cabin man's Avatar
 
Monaco Owners Club
Join Date: Aug 2008
Location: Weedsport, NY
Posts: 91
I agree on running it hard, think my problems started with the stop and go traffic on 95 heading back north this spring.
__________________
2013 HR Ambassador, towing a 2017 Jeep Grand Cherokee
cabin man is online now   Reply With Quote
Old 06-02-2018, 06:41 PM   #10
Member
 
Join Date: Nov 2011
Posts: 90
These engines do not like to be idled
Applefarmer is offline   Reply With Quote
Old 06-24-2018, 07:38 AM   #11
Member
 
cabin man's Avatar
 
Monaco Owners Club
Join Date: Aug 2008
Location: Weedsport, NY
Posts: 91
Update, We were headed to Delaware for a rally and had gone about 250 miles from the last service and the regen light lit. We were on the PA turnpike so pulled over and did a regen 20 minutes it idled back down. Off we went to only go about 5 miles and now the red light came on. Pulled to side of highway and called for roadside assistance. Thatís another story. Was told by towing service that I had to be off the turnpike or they couldnít tow. Was able to limp off the turnpike and they did tow me to International dealer in Allentown PA 6 hours later. This was on a Saturday so shop was closed. Waited in parking lot until Monday morning thankfully they showed pity on me and took me right in. Had a very good tech that diagnosed that the regen temp was only reaching 400f. The DSI module pressure was incorrect and a new module was needed. A R+R DSI module was installed regen temperature then went to 1200f . It now seems to be running good now no lights on the trip home 400 miles. Seems the first dealer should have caught this.
__________________
2013 HR Ambassador, towing a 2017 Jeep Grand Cherokee
cabin man is online now   Reply With Quote
Old 06-26-2018, 06:54 PM   #12
Senior Member
 
robertj1979's Avatar
 
Join Date: Oct 2012
Location: Charlotte, NC
Posts: 145
I had a similar issue on mine with the regen light coming on along with the stop engine light. When I checked the code, it said low coolant. I noticed that the coolant recovery tank was just slightly below the sensor in the tank and added coolant to the tank. Seemed that for some reason I was getting a regen light and stop engine light at the same time for just low coolant. I also noticed some decrease in power until I added the coolant that also got rid of the stop engine light. Sounds like your situation is somewhat different but thought it unusual that I was getting the stop engine light and regen light just for a low coolant problem.
__________________
Robert and Marisa
2012 Monaco Knight 40 DFT
2012 Jeep Rubicon
robertj1979 is offline   Reply With Quote
Old 06-28-2018, 07:22 PM   #13
Senior Member
 
Traps90's Avatar
 
Monaco Owners Club
Join Date: Sep 2010
Location: Alberta
Posts: 1,388
Sounds like they got you fixed up.
__________________

__________________
Trap, Jan and the Pup
2013 Monaco Diplomat 43dft
2010 Black Jeep Liberty
Traps90 is offline   Reply With Quote
Reply

Tags
tank



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dynamax Customer Satisfaction with Force, Force HD, or DX-3 petrel Class C Motorhome Discussions 0 09-11-2015 06:58 AM
Max Force 7 filters RWeigant Monaco Owner's Forum 5 04-24-2013 03:45 PM
max force gramps66 MH-General Discussions & Problems 3 07-30-2012 10:31 AM
Max Force Engine an oil maker? rg neumann Monaco Owner's Forum 6 10-19-2011 09:35 AM
Max Force 7 Regen Penguy Thor Industries Owner's Forum 10 07-28-2011 03:58 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:26 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.