RV Trip Planning Discussions

Go Back   iRV2 Forums > POWER TRAIN GARAGE FORUMS > Navistar MaxxForce Engine Forum
Click Here to Login

Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-30-2015, 12:21 PM   #1
Senior Member
 
Monaco Owners Club
Holiday Rambler Owners Club
Join Date: Sep 2007
Location: Somewhere, USA
Posts: 314
Blog Entries: 1
MF 10 MIL light flashing

From what I see searching this forum a few others have had a similar problem but I didn't find a clear root cause.

I had the latest update, flash, done on 5/27. Later that day in strong winds and heavy rain the MIL light, which I confused with the HEST, started flashing and boost would not go above 23#'s. There were NO other warnings or buzzers. All engine readings were normal, oil, temp, trans temp, ... We continued on to the campground. The following day I called the dealer who did the flash and explained the problem. The only answer was "don't know what to tell you..." and suggestions to take it to a dealer near us. Near being 100+ miles.

When we were ready to leave the CG I checked and there were no DTC's recorded. So off we went. There was an International dealer along our route so I figured I would stop there. However the MIL didn't flash and I had plenty of boost.

After driving for about 4 hours we stopped for fuel. Upon leaving the fuel stop the MIL began flashing again, somewhat windy, We continued on to a rest area since all other conditions were normal. I called the International dealer that was 20 miles away. They could get to me the next week.

Continued to our next stop. Before I shutdown I did another diag of the ECM and 2 codes were recorded, SPN 94 FMI 1 and SPN 94 FMI 17.

Called another dealer and we have an appointment on Monday. About 30 miles away. None of the 3 different service "managers" suggested having the unit towed.
__________________

__________________
Larry and Suzette
2013 HR Endeavor 43 PKQ
2006 Jeep Liberty toad, SMI AFO Brake controller
Larry and Suzette is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-30-2015, 10:49 PM   #2
Senior Member
 
Traps90's Avatar
 
Monaco Owners Club
Join Date: Sep 2010
Location: Alberta
Posts: 1,388
Larry now that you mention it both times our MIL light came on it was windy. I'm wondering that if could be from an interruption of a passive regen.


Definitely keep us posted of what they find. At least with 2 thrown codes they should have some idea.
__________________

__________________
Trap, Jan and the Pup
2013 Monaco Diplomat 43dft
2010 Black Jeep Liberty
Traps90 is offline   Reply With Quote
Old 06-01-2015, 07:03 AM   #3
Senior Member
 
Traps90's Avatar
 
Monaco Owners Club
Join Date: Sep 2010
Location: Alberta
Posts: 1,388
Larry definitely do keep us posted as I for one will be really interested in hearing what the problem is.
__________________
Trap, Jan and the Pup
2013 Monaco Diplomat 43dft
2010 Black Jeep Liberty
Traps90 is offline   Reply With Quote
Old 06-01-2015, 07:39 AM   #4
Senior Member
 
Monaco Owners Club
Holiday Rambler Owners Club
Join Date: Sep 2007
Location: Somewhere, USA
Posts: 314
Blog Entries: 1
Will do.
When I started up today the light started blinking right away.

I have a call in to a dealer to see if it is safe to drive it in.
Spn 94 fmi 1 and spn 94 fmi 17 show on the diag for ecm.
__________________
Larry and Suzette
2013 HR Endeavor 43 PKQ
2006 Jeep Liberty toad, SMI AFO Brake controller
Larry and Suzette is offline   Reply With Quote
Old 06-01-2015, 10:42 AM   #5
Senior Member
 
Monaco Owners Club
Holiday Rambler Owners Club
Join Date: Sep 2007
Location: Somewhere, USA
Posts: 314
Blog Entries: 1
Those codes indicate a fuel delivery problem. The filters are being changed as well as cleaning the screen on the secondary filter, the one on the engine. More later.
__________________
Larry and Suzette
2013 HR Endeavor 43 PKQ
2006 Jeep Liberty toad, SMI AFO Brake controller
Larry and Suzette is offline   Reply With Quote
Old 06-01-2015, 10:46 PM   #6
Senior Member
 
Monaco Owners Club
Holiday Rambler Owners Club
Join Date: Sep 2007
Location: Somewhere, USA
Posts: 314
Blog Entries: 1
Here is the more I promised,

The owners manual states that the MIL being on indicates an emissions problem and that the DPF will need to be serviced. That may be so but it appears that the light is more of a check engine light. So based on my recent experience I suggest checking for a DTC, Diagonstic Trouble Code, which my coach is easily done.

This being a fuel delivery problem. The ECM limits available power when the SPN 94 and FMI 1/17 codes are thrown.

I drove the coach the 32 miles to Rust Truck Service in Decatur IL. They did their diagnostic thing and FILTERS is the issue. On this engine there is a filter attached to the engine which consists of a prescreen in one housing and the pleated filter element in the other. During a filter change the prescreen needs to be inspected and cleaned. This may not have been done when I had service done by a respected NON International shop in FL in April.

The Rust technician who worked on the coach said that the screen was full of crud. He stated that it did not appear to be algee. He also didn't think it was serviced when the filter was changed.

So for me that means I will have the engine service done by an International shop.

Although I did have a spare primary filter I didn't attempt to change it. To change the secondary filter a 36mm socket and extension are required, which I don't have. But I'm sure I can find a socket.

Thanks all for your input it was very helpful.
__________________
Larry and Suzette
2013 HR Endeavor 43 PKQ
2006 Jeep Liberty toad, SMI AFO Brake controller
Larry and Suzette is offline   Reply With Quote
Old 06-02-2015, 05:06 PM   #7
Senior Member
 
Traps90's Avatar
 
Monaco Owners Club
Join Date: Sep 2010
Location: Alberta
Posts: 1,388
Glad to hear that they got you all fixed up with a fairly easy and straight forward fix. A little frustrating that the place that had changed your oil didn't do a complete job.


Really interesting to find that the fuel problem triggered the MIL, which like you I assumed meant it was for the emission part of the coach
__________________
Trap, Jan and the Pup
2013 Monaco Diplomat 43dft
2010 Black Jeep Liberty
Traps90 is offline   Reply With Quote
Old 06-06-2015, 06:44 AM   #8
Senior Member
 
Monaco Owners Club
Holiday Rambler Owners Club
Join Date: Sep 2007
Location: Somewhere, USA
Posts: 314
Blog Entries: 1
And there is more.
After driving for several hours we stopped for fuel. Several miles later the MIL began flashing again. I looked for DTC's and there were none but the power, boost, was way down. After a while the DPF light began to flash, no buzzer, so I found a place to pull off and initiate a regen. After the regen the DPF and MIL still flashed. I decided to drive it as hard as I could and see if the DPF & MIL would clear. Found another place to pull off. Attempted to initiate another regen but it would not start. Shutdown and let is set for less than a minute. Restarted and the MIL and DPF were off and remained off. Check the DTC's again and there were no codes.

During the one regen the DTC showed 3719 0, DPF highest level.
__________________
Larry and Suzette
2013 HR Endeavor 43 PKQ
2006 Jeep Liberty toad, SMI AFO Brake controller
Larry and Suzette is offline   Reply With Quote
Old 06-06-2015, 07:21 AM   #9
Senior Member
 
Traps90's Avatar
 
Monaco Owners Club
Join Date: Sep 2010
Location: Alberta
Posts: 1,388
Sorry to hear about the new problems, although the fact that the warning lights went away after shutting down and restarting is positive. I sometimes think that without the interruption of shutting down, the computer does not reset. Let's hope this ends your problems.
__________________
Trap, Jan and the Pup
2013 Monaco Diplomat 43dft
2010 Black Jeep Liberty
Traps90 is offline   Reply With Quote
Old 06-09-2015, 07:23 AM   #10
Senior Member
 
Traps90's Avatar
 
Monaco Owners Club
Join Date: Sep 2010
Location: Alberta
Posts: 1,388
Larry have you had any more issues or taken the coach back in. We are definitely watching this post. You have had the most info for anything like this so far.
__________________
Trap, Jan and the Pup
2013 Monaco Diplomat 43dft
2010 Black Jeep Liberty
Traps90 is offline   Reply With Quote
Old 06-09-2015, 03:15 PM   #11
Senior Member
 
Monaco Owners Club
Holiday Rambler Owners Club
Join Date: Sep 2007
Location: Somewhere, USA
Posts: 314
Blog Entries: 1
We sat for a days before travelling 268 or so today. No problems. Also there are no active or stored DTC's.
I resumed adding a algicide, biobor jf at the last 2 fillups
__________________
Larry and Suzette
2013 HR Endeavor 43 PKQ
2006 Jeep Liberty toad, SMI AFO Brake controller
Larry and Suzette is offline   Reply With Quote
Old 06-09-2015, 05:42 PM   #12
Senior Member
 
Monaco Owners Club
Holiday Rambler Owners Club
Join Date: Sep 2007
Location: Somewhere, USA
Posts: 314
Blog Entries: 1
Quote:
Originally Posted by Larry and Suzette View Post
We sat for a days before travelling 268 or so today. No problems. Also there are no active or stored DTC's.
I resumed adding a algicide, biobor jf at the last 2 fillups
It is really a biocide, see biobor jf
__________________
Larry and Suzette
2013 HR Endeavor 43 PKQ
2006 Jeep Liberty toad, SMI AFO Brake controller
Larry and Suzette is offline   Reply With Quote
Old 06-09-2015, 08:40 PM   #13
Senior Member
 
Traps90's Avatar
 
Monaco Owners Club
Join Date: Sep 2010
Location: Alberta
Posts: 1,388
Glad to hear that all went well today, have to admit we have been using http://www.howeslube.com/meanerpowerkleaner.php since about 5k miles
__________________
Trap, Jan and the Pup
2013 Monaco Diplomat 43dft
2010 Black Jeep Liberty
Traps90 is offline   Reply With Quote
Old 06-16-2015, 03:23 PM   #14
Senior Member
 
Monaco Owners Club
Holiday Rambler Owners Club
Join Date: Sep 2007
Location: Somewhere, USA
Posts: 314
Blog Entries: 1
Just to update, we drove about 350 miles in the last 2 days and the MIL flashed and the engine derated at about the 340 mile mark. Pulled into a truck pull off and looked at the code, 3251 fmt 2, DPFDP signal erratic, intermittent or incorrect.

Shut down, cussed, restarted and the MIL was out and there were no active codes. Drove on to Rapid.

The International dealer in Rapid City does not work on coaches but there are willing to put their computer on it and look at the codes. He said there are 15 sensors that could cause the MIL to come on. Since it is intermittent ????

Guess I'll have to drive it until it breaks.
__________________

__________________
Larry and Suzette
2013 HR Endeavor 43 PKQ
2006 Jeep Liberty toad, SMI AFO Brake controller
Larry and Suzette is offline   Reply With Quote
Reply

Tags
light



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Brake Light and ABS light stays on Voyageurs Workhorse and Chevrolet Chassis Motorhome Forum 6 10-23-2014 11:56 AM
Bathroom light fixture Coachmen Catalina Ga911Chick Travel Trailer Discussion 3 06-28-2014 06:57 AM
Norcold 9100(?) fridge AC light flashing trampsrv RV Systems & Appliances 2 06-19-2014 05:47 AM
Solar panel monitoring light w diode donnyjay MH-General Discussions & Problems 2 03-28-2014 09:44 AM
Flashing Battery Light DonL Spartan Motorhome Chassis Forum 1 01-16-2014 03:58 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:48 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.