Go Back   iRV2 Forums > POWER TRAIN GARAGE FORUMS > Cummins Engines
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-17-2014, 09:01 AM   #1
Junior Member
 
cvik's Avatar
 
Holiday Rambler Owners Club
Join Date: Jun 2011
Location: Lakeland, FL
Posts: 25
Cruise Control

I have a 1995 Holiday Rambler Navigator with 330 hp Cummins & 3060 Allison Transmission. The cruise control will engage & work properly for about 30 minutes, then the coach starts a slow steady surging ahead about 1 mph per surge. I try disengaging, shutting off the cruise, resetting the cruise control, the coach continues to surge ahead. Seems to work fine until things get good & warm. The tach to me seems to hold pretty steady on level ground, the speedometer creeps up ever so slow with each surge. It takes a couple of minutes to gain say 5 mph on the speedometer.
__________________

__________________
cvik is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-17-2014, 09:57 AM   #2
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 15,212
Any sign of speedo fluctuation while driving using the throttle ?
Could be an early indication of a speed sensor problem.
Have you tried getting codes from the transmission controller ?
Attached Files
File Type: pdf Allison trans codes.pdf (425.7 KB, 40 views)
__________________

__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 07-18-2014, 08:52 AM   #3
Junior Member
 
cvik's Avatar
 
Holiday Rambler Owners Club
Join Date: Jun 2011
Location: Lakeland, FL
Posts: 25
HI skip,
1st, thank you for responding. No sign that I can tell with speedo fluctuation.
How does one gain access for transmission codes? And then the meaning of?
Carl
__________________
cvik is offline   Reply With Quote
Old 07-18-2014, 11:07 AM   #4
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 15,212
If your transmission controller, and the code retrieval procedure , isn't covered in the attached file to my last post let me know , and I'll dig around for an older version of the instruction manual.
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 07-21-2014, 07:46 AM   #5
Junior Member
 
cvik's Avatar
 
Holiday Rambler Owners Club
Join Date: Jun 2011
Location: Lakeland, FL
Posts: 25
Hi Skip,
Thanks again. Downloaded the file. Not sure if it applies. If it's not to much to ask, would you mind looking up the older version? Thanks again
Carl
__________________
cvik is offline   Reply With Quote
Old 07-21-2014, 08:30 AM   #6
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 15,212
The info in the file is set up a little funny ( JMHO) . With the WTEC IV info in the first pages and the older WTEC III ( World Transmission Electronic Control ) info on the last pages with no real separation. Last time I was on the Allison web site , I see they've gone to WTEC V control system. So the info and systems are changing again.
Could you post a picture of your trans control pad or shifter; and I'll start digging.

On a side note , other members have reported improvement in other transmission and speedo related issues , by cleaning and reseating the wiring connectors at the transmission speed sensors. Most have 2 sensors , one on the bell housing and the other on the tail shaft. Drivers side of the trans.
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 07-22-2014, 05:03 AM   #7
Member
 
Join Date: Jun 2009
Posts: 37
I have a 2000 Diplomat. At least once a year I have a similar problem. I have to unplug a 15 pin connector in the electric bay under the driver seat and clean it and all is well for another year or so. I believe it to be corrosion caused by humidity.
__________________
jdecastro is online now   Reply With Quote
Old 07-23-2014, 03:21 AM   #8
Senior Member
 
Elictrix's Avatar
 
Join Date: May 2014
Posts: 120
Allison codes are retrieved by pushing the Up and Down arrows together. Release them once the display changes from N.

Most transmissions should have an oil level sensor fitted, so the fist display will be oL(oil level).
Press both arrows together again. The display should now show d1, followed by -- if no codes are stored, or a four digit error code if any codes are stored, eg d1 2415.
Briefly press the Mode button to read the next code, eg d2 4522.
Continue until you get --, eg d4 --.
The Mode light will be on if the displayed code is active.

You would have much bigger issues than just an erratic speedo if you had a fault with the transmission speed sensors. The transmission would probably have major driveability problems, or wouldn't shift at all.
__________________

__________________
Elictrix is offline   Reply With Quote
Reply

Tags
cruise control



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 Cruise Control Garyp47 Ford Motorhome Chassis Forum 16 07-05-2014 08:30 AM
Cruise Control Quit Working Romeo Newmar Owner's Forum 21 06-09-2014 09:22 AM
Replacement Cruise Control DonL Monaco Owner's Forum 3 05-20-2014 07:26 PM
Cruise control out of control bjreynolds Newmar Owner's Forum 6 05-11-2014 12:12 AM
Cruise Control on and you have a Blow Out kketterling Monaco Owner's Forum 13 03-19-2014 06:53 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:23 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.