RV Trip Planning Discussions

Go Back   iRV2 Forums > POWER TRAIN GARAGE FORUMS > Cummins Engines
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-23-2009, 07:06 AM   #1
Junior Member
 
Winnebago Owners Club
Join Date: Sep 2009
Location: Southern California
Posts: 9
Cummins ISB fault code

Hi all,

We just bought a new (to us) 2002 Journey 32DL with a Cummins 300 and Allison 6 speed ~64k miles. Mid-way home from the midwest to the west coast (1900 miles) we started to get an intermittent check engine light (CEL) upon coasting downhill (but only with the exhaust brake off and foot off the gas). Twice the rig even started spewing smoke and lost all power for a few seconds. The rest of the ride home I made sure to stay on the gas or on the exhaust brake, and the light didn't return while driving.

Now whenever I start the engine, or let the rig idle after parking it the CEL will come on and when I start driving there is very little power for a few seconds. Then the light goes out and things run normally.

Now we're home and I just installed the Silverleaf VMSpc software. The code that I get for the CEL is: ENG, SID, 254, 8, Controller #1, Frequency Error. I called Cummins and they don't even list a code 254 (maybe I should have asked for code 254-8???). Does anybody have any experience with something similar, or a list of Cummins codes that may shed some light?

Thanks in advance,
Lars and Tamara
__________________

LTJourney is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-23-2009, 08:49 PM   #2
Senior Member
 
Hooligan's Avatar
 
Freightliner Owners Club
Join Date: Apr 2002
Location: Pensacola
Posts: 2,550
Cummins fault codes are here. ISB Fault Codes List

As you can see, no 254 code??? Wish I could be more help....
__________________

__________________
Hooligan, Pensacola, Fl -U.S. Coast Guard 1956-1985
2016 Thor Siesta Sprinter 24ST diesel -1972 Moto Guzzi
Our Pug "Lily" & "George" the Newfoundland
Hooligan is offline   Reply With Quote
Old 09-23-2009, 09:53 PM   #3
Junior Member
 
Winnebago Owners Club
Join Date: Sep 2009
Location: Southern California
Posts: 9
Thanks Hooligan,

I also posted on the Silverleaf site and was told it is a "bad ECM" code. I'll call Cummins tomorrow and see what they say...

Lars
__________________
2002 Winnebago Journey 32DL
1963 CJ7
Waywegos 4Wheel Drive Club
LTJourney is offline   Reply With Quote
Old 09-24-2009, 07:48 PM   #4
Senior Member
 
Winnebago Owners Club
Join Date: May 2009
Posts: 144
Quote:
Originally Posted by LTJourney View Post
Hi all,

We just bought a new (to us) 2002 Journey 32DL with a Cummins 300 and Allison 6 speed ~64k miles. Mid-way home from the midwest to the west coast (1900 miles) we started to get an intermittent check engine light (CEL) upon coasting downhill (but only with the exhaust brake off and foot off the gas). Twice the rig even started spewing smoke and lost all power for a few seconds. The rest of the ride home I made sure to stay on the gas or on the exhaust brake, and the light didn't return while driving.

Now whenever I start the engine, or let the rig idle after parking it the CEL will come on and when I start driving there is very little power for a few seconds. Then the light goes out and things run normally.

Now we're home and I just installed the Silverleaf VMSpc software. The code that I get for the CEL is: ENG, SID, 254, 8, Controller #1, Frequency Error. I called Cummins and they don't even list a code 254 (maybe I should have asked for code 254-8???). Does anybody have any experience with something similar, or a list of Cummins codes that may shed some light?

Thanks in advance,
Lars and Tamara

Hello Lars and Tamara. I can't help you with the error code; don't have that equipment.

Have you or a shop changed the fuel filter recently? Earlier this summer I changed mine on our 32T and later (on a cross country trip) noticed similar problems to yours, but not as severe. When the "check engine" light kept coming on and off I pulled into n RV place north of Dallas and persuaded them to change the fuel filter. It cost me $104 (shop minimum) to learn that the main fuel filter has an o-ring to go on the center screw-on connector that that maker drops loose in the package that's easy to lose or overlook. Must cost all of 10 cents! With that replaced, all was well.

Just a thought.

JT
__________________
JT Kirby
2006 32T Journey
2010 Chevy Malibu toad
RV'nOldTimer is offline   Reply With Quote
Old 04-24-2011, 07:02 PM   #5
Junior Member
 
Join Date: Oct 2006
Location: Manassas, Virginia
Posts: 3
ISB Fault Code

I am having the same issue and was wondering what was wrong with yours? Any help would be greatly appreciated.
Mikeg39z is offline   Reply With Quote
Old 04-25-2011, 03:49 PM   #6
Senior Member
 
Join Date: Apr 2011
Posts: 165
I think they replaced his TURBO this is similar to what mine is doing also I think it has something to do with the VGT in the turbo and the electronics good luck getting Cummins to do anything I think they know about the problem but won't do anything about it our motorhome only has 28000 miles and is 6 months out of warranty. Won't buy another one or one of those rip off extended warranties either.
camping fam is offline   Reply With Quote
Old 04-25-2011, 07:08 PM   #7
Junior Member
 
Join Date: Mar 2011
Posts: 9
the code you pulled out translats to cummins code 368 see attach link for description
http://www.miamibustech.com/optare/O...lt%20Codes.pdf
gear-head is offline   Reply With Quote
Old 04-25-2011, 07:19 PM   #8
Junior Member
 
Join Date: Oct 2006
Location: Manassas, Virginia
Posts: 3
I appreciate your help. Probably that great VP44 Injector Pump ready to quit. I will get the flow chart and dig deeper. Thanks again.
__________________
Mike Gaston
2002 Fleetwood Bounder 39Z
300 Cummins ISB
Mikeg39z is offline   Reply With Quote
Old 04-25-2011, 07:24 PM   #9
Senior Member
 
Join Date: Apr 2011
Posts: 165
I wondeer what happened to LTJourney I tried to contact him
__________________

camping fam is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cummins ISB trouble code and power loss LTJourney MH-General Discussions & Problems 3 09-23-2009 09:23 AM
Cummins ISB Exhaust Brake for 2003 Engine UFO Pilot Freightliner Motorhome Chassis Forum 8 07-15-2009 07:11 AM
Cummins ISB fuel/h2o separator info Tagalong Winnebago Industries Owner's Forum 9 06-30-2008 07:23 PM
2008 Cummins ISB 6.7L Garbageman Winnebago Industries Owner's Forum 4 11-14-2007 05:19 AM
Cummins ISB Engine Shutdown chasfm11 MH-General Discussions & Problems 10 07-20-2006 03:32 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:21 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.