RV Trip Planning Discussions

Go Back   iRV2 Forums > POWER TRAIN GARAGE FORUMS > Allison Transmission Forum
Click Here to Login

Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-25-2018, 09:54 AM   #1
Junior Member
 
Join Date: Nov 2014
Posts: 12
Check Trans Light

Hi all, wonder if anyone can help, i have a holiday Rambler Ambassador 2000 year, we drove from the Uk to Spain 1200 miles no problems, started up the RV and now the check trans light is on, i have had an Allison technician out and he put his diagnostic machine on it and there is no problem with the gearbox he said it is a wireing issue, any idea where to start looking we are stuck up a mointain and cannot move the RV.

Thanks Denis
__________________

Denis442 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-25-2018, 11:30 AM   #2
Junior Member
 
Monaco Owners Club
Join Date: Sep 2014
Posts: 10
Hi Denis,
i had a similar problem with my allison 3000MH with pushbutton selector, the Display on the Unit was without any light on- I unplugged the plug to the Control unit on the backside of the gear lever and plugged it back in again, as a second possibility the power supply to the allison. It's powered directly from the chassis battery, I have a fuse near the battery, it can also have contact problems, remove and check the fuse and plug it in again.
hope this helps you further.

Roland
__________________

__________________
2002 Monaco Dynasty 34 York, ISL400, Honda Deauville NT700 VA
Georgie-Boy is offline   Reply With Quote
Old 10-25-2018, 11:53 AM   #3
Junior Member
 
Join Date: Nov 2014
Posts: 12
Check Trans Light

Hi Roland thanks for trying to help, i have the gear selecto/lever, ive tried everything else that you have sugested but still the light stays on, when the Allison technician came out the only code he got out was P0880, he said the gearbox was fine it is a wireing issue but on these RV's the problem could be anywhere.


Thanks Denis
Denis442 is offline   Reply With Quote
Old 10-25-2018, 12:06 PM   #4
Junior Member
 
Monaco Owners Club
Join Date: Sep 2014
Posts: 10
Hi Denis, i think you have checked all of this items
Roland
Attached Thumbnails
Click image for larger version

Name:	P0880.JPG
Views:	72
Size:	97.1 KB
ID:	223768  
__________________
2002 Monaco Dynasty 34 York, ISL400, Honda Deauville NT700 VA
Georgie-Boy is offline   Reply With Quote
Old 10-25-2018, 12:58 PM   #5
Junior Member
 
Join Date: Nov 2014
Posts: 12
Check trans light

Hi Roland, yes i have checked all of these but still no joy.

Thanks Denis
Denis442 is offline   Reply With Quote
Old 10-25-2018, 01:52 PM   #6
Senior Member
 
Join Date: Aug 2011
Posts: 199
Experienced the same issue. Was a faulty ground wire from the transmission "computer" by the drivers seat to the battery in the rear. They could not trace the wire all the way to the battery so they cut it and grounded it to the frame. Has since worked fine
__________________
2003 HR Imperial PKDD 40
bgholson is offline   Reply With Quote
Old 10-25-2018, 02:07 PM   #7
Junior Member
 
Join Date: Nov 2014
Posts: 12
Check trans light

Hi thanks for the information we definatley think it is a wire some where just a matter of finding it, will have another go tomorrow.

Thanks Denis
Denis442 is offline   Reply With Quote
Old 10-26-2018, 01:26 PM   #8
Junior Member
 
Join Date: Nov 2014
Posts: 12
Check trans light

Well still no luck, checked all connections fuses relays, rv runs for about 10 minutes then light comes on, we can hear something clicking thats when the light comes.
Denis442 is offline   Reply With Quote
Old 10-26-2018, 01:45 PM   #9
Senior Member
 
grindstone01's Avatar
 
Join Date: Oct 2017
Location: FULL TIMERS
Posts: 2,800
You may have already tried this but disconnect the battery for 5 min or so and let the ECM system reboot at start up.
grindstone01 is offline   Reply With Quote
Old 10-26-2018, 02:59 PM   #10
Junior Member
 
Join Date: Nov 2014
Posts: 12
Check trans light

Haven't tried that will do that tomorrow its late at night here now,
Thanks for the advice.

Denis
Denis442 is offline   Reply With Quote
Old 11-15-2018, 08:15 PM   #11
Junior Member
 
Join Date: Jul 2015
Posts: 6
2004 Imperial

Quote:
Originally Posted by bgholson View Post
Experienced the same issue. Was a faulty ground wire from the transmission "computer" by the drivers seat to the battery in the rear. They could not trace the wire all the way to the battery so they cut it and grounded it to the frame. Has since worked fine
Bob,

I am having a similar issue right now with my 2004 Imperial. My pad would light up and I got error codes which said to change them Allison vcm, ecm, or whatever. Anyhow changed it and now pad will not light up al all and coach will not start. Where under the drivers seat did you find this wire to ground that was bad. Thanks.. Jim Tate
JimTate is offline   Reply With Quote
Old 11-15-2018, 08:17 PM   #12
Junior Member
 
Join Date: Jul 2015
Posts: 6
Quote:
Originally Posted by Georgie-Boy View Post
Hi Denis,
i had a similar problem with my allison 3000MH with pushbutton selector, the Display on the Unit was without any light on- I unplugged the plug to the Control unit on the backside of the gear lever and plugged it back in again, as a second possibility the power supply to the allison. It's powered directly from the chassis battery, I have a fuse near the battery, it can also have contact problems, remove and check the fuse and plug it in again.
hope this helps you further.

Roland
Was this a touch pad selector?
JimTate is offline   Reply With Quote
Old 11-16-2018, 02:16 AM   #13
Junior Member
 
Monaco Owners Club
Join Date: Sep 2014
Posts: 10
Yes, it was a touch pad Selector

Roland
__________________
2002 Monaco Dynasty 34 York, ISL400, Honda Deauville NT700 VA
Georgie-Boy is offline   Reply With Quote
Old 11-16-2018, 06:25 AM   #14
Senior Member
 
Join Date: Aug 2011
Posts: 199
Quote:
Originally Posted by JimTate View Post
Bob,



I am having a similar issue right now with my 2004 Imperial. My pad would light up and I got error codes which said to change them Allison vcm, ecm, or whatever. Anyhow changed it and now pad will not light up al all and coach will not start. Where under the drivers seat did you find this wire to ground that was bad. Thanks.. Jim Tate


Drivers seat panel by your left leg. Remove the panel and you will see a box about 4x6 " or so. This is the transmission "computer" (forgot what they called it). One of the wires into the computer is the ground. Sorry I can't be more helpful than this
__________________

__________________
2003 HR Imperial PKDD 40
bgholson is offline   Reply With Quote
Reply

Tags
light



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
05 Holiday Rambler Neptune Check engine, Check Trans Light bob ferris Monaco Owner's Forum 1 07-21-2016 10:35 AM
check trans light gcoondog1 Allison Transmission Forum 1 08-29-2012 09:30 AM
Intermittant Check Trans / warning light tomgagne Allison Transmission Forum 3 08-10-2012 03:59 PM
Check trans light Lol Allison Transmission Forum 4 11-01-2008 03:12 AM
Check Trans. Light came on jimandsandy Freightliner Motorhome Chassis Forum 10 01-14-2007 08:41 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:06 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.