Go Back   iRV2 Forums > POWER TRAIN GARAGE FORUMS > Allison Transmission Forum
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-01-2008, 07:02 PM   #1
Junior Member
 
wildirishman's Avatar
 
Join Date: Jul 2008
Posts: 29
I am getting a service light and error code displaying 66 00. Any idea what this is for?
__________________

__________________
Colorful Colorado
2002 Fleetwood Revolution 38B
Cummins 8.3L ISC
wildirishman is online now   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-23-2008, 01:17 AM   #2
Junior Member
 
Join Date: Jul 2008
Posts: 7
D1 66 00 getting same but I don't have a code manual to be able to know what is causing it.
__________________

__________________
Service Eng is offline   Reply With Quote
Old 07-23-2008, 02:55 AM   #3
Member
 
Join Date: Nov 2002
Location: Richmond,MA
Posts: 84
code 66-00 indicates a "serial communications interface" fault.

Main code 66 indicates the ECU is expecting to get its throttle position sensor (TPS) signal across a serial
communication interface from a computer-controlled engine. Either the engine computer is not sending the TPS
information or the wiring between the engine and transmission computers has failed.
Code 66 00 can occur when the transmission ECU remains powered when the engine ECM is powered down.
The transmission sees this as a communication link failure.
Hope this helps you start troubleshooting.
__________________
Have the Best Day You Can

Grumpy Dave is offline   Reply With Quote
Old 07-23-2008, 04:09 AM   #4
Junior Member
 
Join Date: Jul 2008
Posts: 7
Thanks. But the engine starts OK. The throttle works. When the gear is engaged the reverse or 3 flashes. When it does sometime get into gear, it will only go in reverse gear or forward drive. When I switch off, I have play again with the lever until it gets in gear. I have by-passed all the air switches just in case it was a faulty air switch. I have tested the ECU, sensors on MD3060 on different trucks- they work. There is a little black pcb full in epoxy. This one I have not tested on other equip yet. YOur useful advice please.
Thanks
__________________
Service Eng is offline   Reply With Quote
Old 07-23-2008, 07:23 AM   #5
Member
 
Join Date: Nov 2002
Location: Richmond,MA
Posts: 84
I can't for sure say how it effects the engine start but...This info is from the 1998 Allison WTEC2 Troubleshooting manual. the66-00 code does not set a "do not shift" light and the "inhibited operation description" is - use default throttle values, DNA (ECU stops adaptive shift control while the code is active)
__________________
Have the Best Day You Can

Grumpy Dave is offline   Reply With Quote
Old 07-23-2008, 07:31 AM   #6
Member
 
Join Date: Nov 2002
Location: Richmond,MA
Posts: 84
troubleshooting,
1.Check for a TPS signal from the engine to the transmission, an engine computer malfunction, or an engine TPS fault.
2. Check wires 142 and 151 between the engine and transmission ECUs for an open or short and check that all connections are clean and tightly connected.
3. Use the Pro-Link to see if the ECU is receiving power when it should not.
__________________
Have the Best Day You Can

Grumpy Dave is offline   Reply With Quote
Old 07-24-2008, 05:15 AM   #7
Junior Member
 
Join Date: Jul 2008
Posts: 7
Has anyone got wiring diagram for the MD3060. Mail address anarraina@hotmail.com --
__________________
Service Eng is offline   Reply With Quote
Old 07-25-2008, 03:49 PM   #8
Member
 
Join Date: Jul 2006
Posts: 46
Quote:
Originally posted by Service Eng:
Has anyone got wiring diagram for the MD3060. Mail address anarraina@hotmail.com --
Entire trouble shooting manual sent.
__________________
Steve & Judy
96 American Tradition
samert111 is offline   Reply With Quote
Old 07-27-2008, 08:31 AM   #9
Junior Member
 
Join Date: Jul 2008
Posts: 7
Thanks a lot. This will surely help me a lot. Thanks Thanks Thanks.
I'll let you know how I get along with this problem. I found out that there is another filter inside the gear box. I will check that too.
__________________
Service Eng is offline   Reply With Quote
Old 07-28-2008, 01:40 AM   #10
Junior Member
 
Join Date: Jul 2008
Posts: 7
I have started check only to find out that the cable and wiring harness is of different type.
Date code : 03-10-2004
Model No : WT3ECU911A
\throttle : Auto detect.
Gov Rpm : 2500
Pri-Mode : 1-3S2
Sec-Mode : 1-4S3
TID : 3
In fact I need a WTECIII trouble shooting manual.
I have checked all the cables from the Transmission to ECU and all OK ( COntinuity test and no short )
I have checked all the cables from the air valves to ECU also. The rest I cant figure out.

Thanks
__________________
Service Eng is offline   Reply With Quote
Old 07-28-2008, 01:45 AM   #11
Junior Member
 
Join Date: Jul 2008
Posts: 7
I have also changed the ECU to another truck. It works fine. I have also changed the gear shift lever and that works too. I have taken the whole box with ECU & VIM complete and tested on another truck and it works. There must be an intermittent cable from the engine ECU to the transmission ECU that I cant find without proper WTECIII wiring.
__________________
Service Eng is offline   Reply With Quote
Old 08-27-2008, 06:20 PM   #12
Junior Member
 
wildirishman's Avatar
 
Join Date: Jul 2008
Posts: 29
still having the same trouble (D1 66 00)

How do I know which wires are:
Check wires 142 and 151 between the engine and transmission ECUs for an open or short and check that all connections are clean and tightly connected
__________________
Colorful Colorado
2002 Fleetwood Revolution 38B
Cummins 8.3L ISC
wildirishman is online now   Reply With Quote
Old 08-27-2008, 06:23 PM   #13
Junior Member
 
wildirishman's Avatar
 
Join Date: Jul 2008
Posts: 29
Also - if anyone can forward a copy of the trouble shooting manual I would greatly appreciate it.

pheney@comcast.net

Thanks in advance!
__________________
Colorful Colorado
2002 Fleetwood Revolution 38B
Cummins 8.3L ISC
wildirishman is online now   Reply With Quote
Old 08-28-2008, 03:34 AM   #14
Junior Member
 
Join Date: Jul 2008
Posts: 7
Hey Pheney. I have sorted out my problem. It was only an intermittent air valve switch. But unfortunately for me it had a normal closed contact. Hence bypassing it with a piece of wire was not of any help (specially if you dont have any wiring diagram to see this ). What ECU have you got? If you have a WTECII I can help with the trouble shooting manual. I am still looking for a trouble shooting manual for a WTECIII.
__________________

__________________
Service Eng is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Max HP on a 95 MD3060??? ToddR Allison Transmission Forum 4 01-07-2009 06:16 PM
MD3060 LEAK PLYMOUTH1962 Allison Transmission Forum 3 12-08-2008 04:22 PM
New DipStick Hole Plug On MD3060??? ToddR Allison Transmission Forum 2 11-11-2008 08:21 AM
"Service" message on Allison MD3060 display w/code 21 / 23 samert111 Allison Transmission Forum 8 07-25-2008 04:30 PM
Actia message center service informaiton Tom N Workhorse and Chevrolet Chassis Motorhome Forum 31 04-25-2006 05:30 AM

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

RV & Travel Trailer Communities

Our RV & Travel Trailer sites encompasses virtually all types of Recreational Vehicles, from brand-specific to general RV communities.

» More about our RV Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002-2012 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:54 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2014, vBulletin Solutions, Inc.