RV Trip Planning Discussions

Go Back   iRV2 Forums > POWER TRAIN GARAGE FORUMS > Allison Transmission Forum
Click Here to Login

Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-26-2018, 08:12 PM   #1
Member
 
Join Date: Nov 2009
Posts: 43
No drive or Reverse

Hi Allisonman

Thanks for your help.

A friend of mind is stuck by our local fuel station with his 2004 Fleetwood Revolution motorhome on a Spartan chassis for the last week or so. Push button 6 speed 3000 Allison. It does not shift in drive or reverse. Engine check light come on and beep about every 3 second ( 370 ISL 8.9LCummins ) He try to get a code by pushing the arrow button all he gets is a square in the display no code. Our local truck shop connect a computer to it and they got a code to replace both input and output speed sensor it did not help. He said that there is a small glow in the mode screen. He call an Allison tech and he can t get them for a while. He told me the model of the trany was 46354893.

Any ideas?
Very much appreciated. Norm
__________________

papp is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-27-2018, 10:20 AM   #2
Senior Member
 
bdpreece's Avatar
 
Monaco Owners Club
Join Date: Mar 2000
Location: Yuma Arizona USA
Posts: 2,769
Ok; a total shot in the dark here but I assume he drove it in and now it won't drive out. I would start with what I would call a total factory reset. Disconnect the ground wire from both sets of batteries. Wait about 20 minutes or more then hook them back up and try system. Got nothing to loose at this point so give it a try.
__________________

__________________
Brian, Loretta & Daisy (Golden Retriever)
2008 Holiday Rambler Endeavor 40 PDQ , ISL 400
2014 Ford Explorer toad
bdpreece is online now   Reply With Quote
Old 09-27-2018, 10:21 AM   #3
Member
 
Join Date: Nov 2009
Posts: 43
Is this motorhome transmission interlock with anything like slideout ? I would guess you have to applied the brake before shifting? Faulty brake switch? I will ask these question to my friend later. One way would be to check the brake lights. I also hear that engine speed would be an issue.
papp is offline   Reply With Quote
Old 09-27-2018, 01:16 PM   #4
Community Moderator
 
TonyDi's Avatar


 
Newmar Owners Club
Join Date: Feb 2011
Location: Central NJ
Posts: 16,752
I agree with the possibility of it being related to an interlock. If he has auto slide locks he may have a bad sensor or the closed sensor in the slide itself may be at fault. That's my best idea.
__________________
Tony & Ruth........... FMCA#F416727
Newmar Dutch Star 4320, Spartan MM Chassis, Cat C9, 2018 Jeep Wrangler Unlimited, Blue Ox Aventa LX, and AF1. TST 507 TPMS
TonyDi is online now   Reply With Quote
Old 10-04-2018, 08:31 PM   #5
Member
 
Join Date: Feb 2018
Location: SW WA
Posts: 42
Also no D or R

Sitting @ Western Star in Ridgefield WA right now. Hope they dont try to sell me reman when all i need is engine speed sensor. Some VERY bad reviews. Funny thing is, Allison distributor right next door. Fishy, they sent me here. Pacific Power, same people who replaced my MD 3060 in 2013, and AGAIN in 2014!
Cat568 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Proper Procedure to shift from Drive to Reverse or R to D? CoachStreamr Allison Transmission Forum 37 04-02-2018 11:37 AM
Clinking noise when going from Drive to Reverse ? WRP Jayco Owner's Forum 5 10-27-2017 05:52 PM
1994 F53 460 CID will not move in drive or reverse nightriderrv Ford Motorhome Chassis Forum 50 06-26-2012 09:12 PM
2 wheel drive vs 4 wheel drive?? Ted Thurlby Excel Owner's Forum 18 12-01-2008 06:59 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:52 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.