RV Trip Planning Discussions

Go Back   iRV2 Forums > POWER TRAIN GARAGE FORUMS > Allison Transmission Forum
Click Here to Login

Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 04-10-2019, 04:56 PM   #1
Junior Member
 
Join Date: Apr 2017
Posts: 3
Service transmission light goes on and off while I am driving

Our 98 American Eagle's "Service Transmission" light comes on when starting motorhome, then goes off while driving. A while later, when stopping at a light, the message light comes on again. This can happen several times during a trip.
Would appreciate any ideas on why this is happening? The transmission is an Allison.
Thank you!

__________________

graphite1948 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-10-2019, 05:49 PM   #2
Senior Member
 
bob caldwell's Avatar


 
Join Date: May 2017
Location: Vancouver Wash
Posts: 5,015
Just maybe it needs servicing.......
__________________

__________________
2010 Rockwood Sig Ultra lite 5er 8280......'99 Ram 2500, Cummins. 4x4.....Pullrite Superglide.......Use to work in calender factory.....got fired for tak'n a few days off.....
bob caldwell is offline   Reply With Quote
Old 04-10-2019, 06:12 PM   #3
Senior Member
 
spdracr39's Avatar


 
Monaco Owners Club
Join Date: Jul 2016
Location: Cabot, Arkansas
Posts: 1,695
read the codes, it will tell you what the issue might be.

https://cdn.mpparts.com/pdfs/Trans%20Codes.pdf
__________________
2004 Beaver Monterey Laguna/2015 Chevy Equinox
2014 Chaparral 327RLKS 5'er (FOR SALE)
2017 GMC 2500HD SLE 6.0L Z71 4x4 Standard Bed
https://wordpress.com/posts/enjoying-life.net
spdracr39 is offline   Reply With Quote
Reply

Tags
light, service, transmission



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Parking brake light off and on while driving bclaar Travel Supreme Owner's Forum 5 01-31-2019 07:28 AM
Powergear Jacks Alarm goes off when jacks are up and turns off when they are down. Honey_Hole National RV Owner's Forum 9 01-12-2016 08:37 PM
Dash goes out while driving rcarriere Entegra Owner's Forum 15 11-07-2014 03:05 PM
engine light and trans light on while driving davidsaxby Cummins Engines 5 09-23-2012 03:45 PM
Transmission keyboard shuts off while driving ninjalobo Country Coach Owners Forum 9 05-01-2012 07:43 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:50 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.